My Account
× My Account Forum Buy Now

Last Epoch Forums

General performance issues and missing map outlines on GNU+Linux

Hi guys

Just wanted to bring this to your attention, since it’s an ongoing issue.

The game’s performance, no matter the graphical setting/resolution, is very poor. This seems to be the case on Windows as well on GNU+Linux, but it’s more prominent on GNU+Linux. This of course varies and it depends on the system/hardware, somewhere it’s barely present and somewhere it’s very noticeable.

I’ve tried pretty much everything, the lowest and highest details/resolution and it’s always the same. The FPS is usually between 40-50 when the things are calm and not much going on, but it often drops to 30 and below. Which, as you can imagine is not a great experience and is not allowing us to enjoy and play the game like we are meant to.

I’ve also noticed that the game has a habbit of taking up all of the RAM, which sometimes leads to a crash due to no memory left.

Another thing that plagues us are visual bugs, where the world map is black, with only points of interest showing, the map in-game and the minimap are missing terrain/outlines and are only showing the points of interest. This seems to only affect players that use GNU+Linux and only on AMD cards? Some inventory items show as blank squares in inventory too.

My system info is as follows:

System:
  Host: void Kernel: 5.13.19_1 x86_64 bits: 64 Desktop: KDE Plasma 5.23.3
  Distro: void
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0
  serial: <superuser required> UEFI: American Megatrends v: 3.70 date: 06/09/2020
CPU:
  Info: 6-Core AMD Ryzen 5 3600 [MT MCP] speed: 2199 MHz min/max: 2200/3600 MHz
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu
  v: kernel
  Display: server: X.Org 1.20.13 driver: loaded: amdgpu resolution: 3840x2160
  OpenGL:
  renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.41.0 5.13.19_1 LLVM 12.0.1)
  v: 4.6 Mesa 21.2.6

Here are some of the threads where these issues are reported:

https://forum.lastepoch.com/t/unacceptable-frame-rates-7-8-2080ti/20449/7

https://forum.lastepoch.com/t/frozen-harbor-fps-falls-off-cliff-please-fix/44939/3

https://forum.lastepoch.com/t/gnu-linux-poor-game-performance-graphic-glitches-vulkan-not-working/42169/11

Just wanted to check if this is something that you are aware of and is there any work being done to fix these problems?

Please let me know if there is anything that I can provide or do to help with fixing these.

Thank you in advance.

3 Likes

Please don’t directly ping multiple staff in a post, especially 3 days before a patch unless it’s ultra urgent. (I deleted the pings to hopefully stop others from getting it)

Hey there…

Bug issues aside… These are known and I am confident that EHG will get to them eventually.

Performance… Well, the game is in beta & is generally unoptimised and while the devs do make performance improvements and hotfixes with each patch, they have as yet not confirmed that they are concentrating on performance issues. I expect that this is purely an issue of resources and the conflict between gettting the game completed vs optimisation priorities.

Please note that your GPU - RX470 is only about 30% faster than the MINIMUM spec required to play LE so getting 40-50 fps with drops into the 30s are actually what I would expect from the game right now on your hardware (depending on settings).

For example, I use a 1060 GPU - the recommended GPU - and I get between 50-60fps for 90% of the game at very low settings, all special features disabled/very low @ 1080p resolution with a framerate limit of 60fps (important). I find the game runs very smooth and is very stable and doesnt look bad at all…

There is obviously much that can be done to improve performance but honestly, based on the state of the game right now, I’d say that its actually pretty good - all things considered. If the game were released and 100% completed, then I would agree that the performance is poor but its not done yet so…

1 Like

Hello Mike,

I understand that you guys are probably very busy right now with getting the patch ready, but I don’t see how bringing this up can negatively affect the staff.

This is by no means an urgent problem, but it is the one that needs to be addressed, and the reason for pinging the staff is because these problems have been reported in the past and are still present today. So I was unsure whether you guys are aware of this or not, hence the ping.

Once you guys have the time, please let me know if there is anything that I can do to help.

@vapourfire

Please stop posting in my threads, if you had taken the time to read the reported problems, you would see that players with better hardware than mine are experiencing performance problems too. This report thread is directed to Eleventh Hour Games.

Thank you.

Sure… At your request I will mute you… Just to let you know I replied in some of those threads you linked to and even many more that discuss these exact topics that you havent referenced so I am well aware of the issues that Linux users are having. I understand that you are frustrated but you also need to understand that the devs can only do as much as they can and I believe they are… Shouting at them helps no-one.

1 Like

Sadly the performance problems are nothing new. I never noticed the RAM overflow issue on my end. My system is equipped with 16 GB RAM so maybe this is enough to feed the game properly. However it should run with 8 GB RAM according to the systemrequirements.

A game like last epoch doesn’t need to run at high FPS. But it should give us at least stable 60 FPS to have a smooth experience. The main problem is that LE is using OpenGL instead of Vulkan. It could use Vulkan but to enable the API the Unity3D Version of the game needs to be updated to a newer release. According to a reply from the developmentteam this would stall the entire developmentprocess for several months.

Sadly also the problems with AMD GPU’s using the MESA drivers are nothing new. The game had a bug where enabling ambient occlusion (which is enabled by default) caused massive flickering rendering the game unplayable, I reported the problem but nothing happened. The bug was then (accidentally) fixed by the MESA developers while they where fixing a bug in Wasteland 3 which in turn also uses Unity3D with the OpenGL renderer.

I am pretty sure that Last Epoch has never been tested with an AMD GPU+MESA on linux. Maybe the developmentteam will pay more attention to the linux version now that the steamdeck is announced.

However while not officially supported you can run the game through Steampaly/Proton. This will give you a much smother performance. Worked flawless the last time i tried.

Bump.

Bump.

Bump.

Bump.

From forum FAQ:

  • Don’t post no-content replies.
1 Like

The issues are not being addressed, it needs to stay up.

It is common rule on forums that bug reports are not bumped. You don´t speed up fix with bumping.

They have to be for visibility sake, otherwise they will get lost in sea of threads. As you can see none of the devs acknowledged these yet in this thread.

There are many similar threads about performance which is normal for beta. You can´t expect that devs will reply in each as they can use time better like for developing fix … You still don´t understand that you will achieve nothing with bumping. Your bumps would be deleted in another forum with more mods.

Yes, there are similar threads out there, however this one has a very specific problem on a GNU+Linux platform. The problem that exists for 2+ years now, which devs seem to have “acknowledged” at one point long ago, but suddenly forgot about it’s existence.

There was no asking for logs here, no nothing… If a dev doesn’t respond to a bug report thread, it means they are not aware of it and no work is being done to fix it, as simple as that.

What you don’t understand is that if I don’t post in this thread to keep it alive, it will just get locked and forgotten in 2 months, just as many others before it.

With that being said, I kindly ask you to stop posting in my thread because it’s directed to EHG and no one else. If my threads/posts bother you, please mute/ignore me.

Thank you.

Bump.

I’ve owned this game for quite a while now (since early 2019) and we are still waiting for the performance issues to get better for Linux. I really hope this gets addressed sooner or later.

Greetings,

I would like to pitch in that I’m having the same issues as OP, the main issue however for me is the map not rendering.

Sitting with a 5600G and I just wanna play some high quality ARPG on Linux in order to complete my transition to aforementioned OS-family. There are some other minor faults which I can live with, but for me a non-existent mini map is a no no…

You are doing a great job with this title and we all see that much love is being poured in, some kind of reply would be appreciated if this issue is being investigated at all. Or if we all have to suffer in the eternal waiting game of doom!

Sincerely,
Henry

Same issues that everyone else has reported here, making playing on Linux completely un-enjoyable. Considering how long it has been I have to wonder if Linux will get the axe like Mac did.

1 Like