My Account
× My Account Forum Buy Now

Last Epoch Forums

GNU+Linux poor game performance, graphic glitches & Vulkan not working

Hello Last Epoch support,

I’m playing LE on Void GNU+Linux and I’ve ran into few problems.

Game performance is really bad, it seems to run around 30 FPS most of the time, FPS drops are very noticeable. Changing graphic details doesn’t seem to do much. I can’t run the game with -force-vulkan, it either doesn’t start at all or it gets stuck on a splashscreen.

Minimap is completely transparent, I can only see points of interest, but no terrain borders etc. Same thing happens when I press ‘Tab’, it’s not set to transparent in options and nothing changes when I move the slider.

When I press ‘M’ to open the map, the entire background is completely black and I can only see the waypoints.

Rune icons are not rendering when I open my inventory, they’re invisible.

Same things happen whether I use Steam or standalone client.

My computer specs are as follows:

Ryzen 5 3600
16GB DDR4
RX 470 4GB

Void GNU+Linux
Kernel 5.12
Mesa 21.1
Vulkan 1.2

I took some screenshots to show the graphic glitches I mentioned:

Hey.

Thanks for posting this feedback.

I do not use Linux to play any games (LE included) but I can chip in here regarding some of the things you have mentioned.

Game performance. You have not included your in-game settings but I can confirm that on your GPU (the Rx480 is recommended so your 470 is actually closer to the minimum required to LE), you shouldnt be getting much more than about 40fps in the current beta and unoptimised game state depending on your settings/resolutions. This is irrespective of OS version of the game. By comparison I run a 1060 GPU on Windows and after almost 1k hours of play experience, I run 1080p, all in-game settings on very low and limit the framerate to 55fps… With these settings I have found the game is stable, I get almost no artifacts or black screen issues, I get virtually no freezing or crashes and when there are fps spikes, they are much reduced to the point of being barely noticeable. If i push my hardware I can get 100fps but the wheels wobble and I get very unstable play to the point where its not worth the constant instability. Once EHG get to dealing with the performanc optimisation needed then this could improve but for now expectations should be curtailed and conservative settings are the best way to go.

In game settings also play a part in bugs - i.e. lots of people start out playing with Ultra level settings on high resolutions - assuming that their hardware should handle it… but then they get a wide variety of errors and stability problems… Reducing the settings almost always reduced the occurance of in-game graphical related issues and definitely helps with performance & stability.

Obviously gpu drivers make a difference here - from past posts, there are comments for Linux uses regarding driver issues that do the same things on Windows systems… Certain Mesa driver versions have been known to cause issues too… One of the side effects of bad/outdated drivers on Windows is the black background issue you are experiencing - on windows its not just restricted to the Map screen, but happens when you load in a new map… These have usually been solved by either updating or rolling back drivers to alternative versions… It is likely a similar issue on Linux.

Vulkan not working is a known issue. No response from the devs on this.

Rune icons being invisble is a new one on any OS… but I would expect it could be related to the above glitching…

Hello there! I thought I might chime in with some information. While I am a complete newb to Last Epoch, I am quite well versed in Linux.

I too, until I read your post, had two invisible maps, and invisible rune icons. It took me a very long time to get to Chapter 2, because I was wandering around without any aim. Once I read your post, I saw how to force Vulkan; I thought: why not give it a try. It worked out spectacularly–graphically. However, it only solved one problem: my corner map now at least has outlines of where to go. Hitting TAB still gives me invisi-map, and now, more than ever, my runes don’t even show up in the inventory. They don’t have the silver-ish border anymore.

Here is my situation:

Playing LE from Steam Launcher with option: -force-Vulkan
Linux Kernel: 5.4.0-80
OpenGL: 4.6
Mesa: 20.2.6
Vulcan: 1.2.3

I hope you are able to get at least one of your maps to work.

1 Like

Interesting forcing vulkan for me does fix the map issue. But it tanks performance. I get not pushing vulkan performance but at the same time it’s not like windows can’t use vulkan. Maybe I’ll try with proton next time see if that fixes some of the graphical bugs without tanking performance as much.

As a follow-up, I tried to use Proton Experimental to run LE; I was met with a perpetually-loading LE screen. However, then I tried the Steam Linux Runtime compatibility, and it is working much better! I still don’t have the main map, but the corner map works fine, and my runes show up, and all the graphical glitches from using Vulkan are gone.

Might I suggest, @Azwraith, that you use the “Steam Linux Runtime” in the Steam Compatibility tools? I don’t have your hardware specs, so I cannot tell if you’ll get more than 30FPS, but I’m hoping you do!

1 Like

No matter what graphic settings I use, it’s the same. Map stays transparent and runes are invisible in the inventory.

Performance is terrible, the game easily eats up all of my RAM and has OOM crashes… One other game comes to mind where I had terrible performance like this - 7 Days to Die. That’s also a Unity engine game, so it could be engine related.

I’m also disappointed that devs aren’t responding at all, it’s been 6 days since I reported this and no dev tried to help or even acknowledge the problem :confused:

Hey… Sorry you are still having hassles - unfortunately playing on linux does seem to require a lot of under the hood messing around…

Quick note about this - LE is only officially supported on Ubuntu linux and Void is an entirely separate Linux distribution (as I understand it) so it is very likely that this could be part of the issue here… Other players have been able to get the game working on other distros (i.e. not Ubuntu) but it has not been an easy task - at least not from reading the threads on the forum…

There are a few players that have found they can get LE to play in a virtualised environment on Linux very well - this is obviously an option.

Important thing to note, your GPU is never going to give you even OK performance so I am not sure what your expectations are in this regard - especially when you say things like “Performance is terrible”. As I mentioned in my post above I wouldnt expect you to get more than 40fps on the absolute lowest in-game configs so any underlying performance issues caused by your os/drivers etc already has a very low base to start from…

Add these to the fact that LE is in beta and generally unoptimised (on any platform), means that you should not expect anything resembling decent fps rates.

EDIT: You also need to be willing to try various driver combinations as indicated by the others in this thread… Even on Windows, people need to be willing to rollback or try other options to get things to work…

If you want a formal response from EHG support, then you need to open a ticket directly with them… these forums are more a general “can anyone help me” place… (imho at least).

That’s just plain generalizing, ‘messing around’ under the hood is not what’s needed here at all (reasons will be below). Besides, problems aren’t uncommon on Windows either.

I’ve not been able to find anywhere where it explicitly says that it’s only officially supported on Ubuntu GNU+Linux. Steam page mentions Ubuntu for minimum and recommended systems, but official support page shows only ‘linux’. Supported Platforms – Last Epoch Support

I can understand if they choose to support only Ubuntu, but it should be clearly stated.

That aside, these issues are not related to me using a distribution other than Ubuntu. I’ve done some searching and I found that other people had these problems as well, including the ones using Ubuntu:

RX 470, while not the newest or the fastest GPU out there, it still handles even more demanding games without issues. For an example, Path of Exile tends to run at a higher and more stable framerate even when there is a lot going on the screen.

Again, I’ve tried the lowest graphic settings & lowering resolution, the game still behaves the same. Which indicates that the game isn’t optimized yet, and that is fine with the game being in early access, as long as it’s addressed in the near future.

If you check the threads that I linked, you will see that the issues I reported have been present for at least a year, probably even longer and they’ve been identified by EHG devs. So there is at least a year worth of driver and system version difference/variety to show that it’s unlikely the driver problem.

@vapourfire ,

You seem to have good intentions, but I can’t help but feel that you say a lot, but are actually not saying anything, at least nothing of the essence.

So far, nearly everything you said seems like you are defending EHG and subtly trying to shift the blame/responsibility on the player/system/driver etc.

Generic approach doesn’t work everywhere, even more so if it’s a platform that you are not actively using or aren’t familiar with.

If there are issues with the game, they should be visible so the devs can take care of them.

As many have mentioned - LE is in beta and is definitely unoptimised… There is no point in comparing the performance of launched games like PoE to a beta game like LE in the state it is… This serves no purpose. LE isnt optimised - just reading through the Bugs, Technical and Feedback forums will confirm this… My point is that any expectations that you may have that your old hardware is likely to provide decent performance needs to be reconsidered with this in mind… If I didnt do this then I would consider the 50-55fps performance that I get on my 1060 as pretty crap - but I consider it pretty good all things considered and I do not compare it to other games because of this.

There a lots of stability & performance problems in LE… no-one is denying that… However, neither of us work at at EHG and do not have any insight into how they are addressing the issues in the game or prioritising things like performance when things are changing dramatically from patch to patch…

What you need to understand is that this is a beta game and has changed dramatically in the last year - just compare the old UI pics to what the game looks like now to get just the tip of the iceberg as to what has changed (and thats only the front end).

EHG has spent a lot of time working on the multiplayer aspects of the game which by their own admission has made them change lots of the core backend parts of the game - why would they spend time fixing things that are now replaced anyway…

I have zero involvement in EHG beyond being an active player and trying to assist in the community… I am not defending EHG in any way beyond cutting them some slack as they have proven time and time again to be one of the better development houses in terms of community interaction and commitment…

99% of the time the generic approach to issues helps the average player… because the problem is usually something simple and part of problem solving is to eliminate all possible causes of problems - which have ranged from messed up OS installs, corrupted game installed, corrupted or outdated drivers, poor expectations of performance and a hundred other little things.

Following a generic process also helps the devs because it isolates the “usual” issues from something the devs can actually replicate and trace…

Look… this kind of attitude does no one any favours… and to be honest after reading this I could care less if you can play the game or not.