Disconnecting every time I change areas

Tried it. Worked for about an hour. Took a chance on running a keyed dungeon and it disconnected me while changing areas after the second transition. Another key wasted.
I shouldn’t have to make special exceptions for the game…and it didn’t work anyway.

Im also having the same issue from 2 days ago.
I played LE the last 2 patchs and i hadn’t this issue… (and i didnt change nothing about my PC or Internet)
Tried to create an exception for the LE folder in Windows Security but the lost-connection pop-up window came even faster.

1 Like

Same issue, they need to add a console so we can troubleshoot this.
Also, what is up with these “official” responses, they written by AI ?

In the event of a disconnect from the Game server, please follow the steps below as troubleshooting options:

  • Using a VPN has proved helpful for many players. If you do not have the ability to purchase a VPN, Cloudflare Warp is a free VPN that has been tested by the community.

using a vpn as a solution, u joking mate ?

  • SG TCP Optimizer is a program that many players have also found helpful when experiencing these issues

I don’t think this is great advice, how bout you tell us what ports to open if that’s needed, and don’t come with any upnp bs.

  • Contacting your ISP may also be a useful option as it has been found many providers have a block on certain items.

what though, which ranges, what ports ?

  • Adjust your DNS settings

can we get more vague please ?


I’ve played Last Epoch for several years without any issue. A few weeks ago I reinstalled Windows on my computer and suddenly I got disconnected more or less every time I changed zone.

Same network, same computer HW. Just a fresh Windows 11 installation and a new installation of Last Epoch.

I tried using VPN, reinstalling the game, kill other applications, update and restart the router, but nothing worked.

Two days ago I rolled back the network driver. So instead of using the driver (Realtek) from MSI website I rolled back to using a driver included with Windows. For two days I have been able to play without ANY disconnects so far.

Perhaps it will help someone with the same symptoms.

Driver before roll back

Driver after roll back


Chiming in to add a voice to the conversation; I am in the same situation.


New week, new attempt at a keyed dungeon, same results. I made it through 3 areas in the lightless dungeon and the game disconnected right before the boss. I then tried to log back in from the character screen and the game crashed. I have not been able to finish a keyed dungeon for months because of this bug.
Its a broken game. Telling everyone not to buy it. Over 30 days with absolutely no response from Devs on a bug that makes the game unplayable.

Tried the rollback that MightyNicko Mentioned above and was able to finish a keyed dungeon!

I’m not convinced that the issue is fixed, and I am still concerned that I needed to rollback drivers to play a game when all the other games I play were working fine.

This worked like a charm.

Rolling back the driver worked. I was able to play for a few hours straight without being disconnected! Great news for people who already love this game and are willing to put in the effort to play.

Still not a great state for the game to be in for new players who won’t put in any effort. I really hope that the devs can get this figured out so that people don’t have to find creative solutions.

I’ve got a 2.5gbe onboard network adapter, and I was using the Realtek drivers. Reverting back to the windows drivers with rollback seems to have fixed disconnecting between zones. Now I’ve got a new issue where I’m constantly rubber-banding and picking up/skills have a half second or so delay that was not there previously. I can play longer now, I just enjoy the game less while playing.

1 Like

I too have just re installed the game with plans to get back into it for 1.0 However I am in the same boat I can’t make it more than 1 or 2 loading screens without being disconnected roll back drivers have not worked either.

Confirmed this worked for me as well.

I can also confirm that using generic windows drivers worked for me as well. I’m nearly in the exact same situation as you were. Fresh Win11 install, an MSI motherboard with a RealTek network card, and the latest driver installed.

I had tried everything to fix it myself and nothing was working. Firewalls, port forwarding, run as admin, file verify, Windows exclusions, VPN, network sharing from another PC,… None of it worked.

The PC that had the issues was working on Last Epoch flawlessly before my Win11 upgrade, but I wasn’t using the latest drivers when I was using Win10. I also had another computer running LE, (doing co-op with the wife) and it was running a fresh Win11 install as well, but it never disconnected. So, I had two PCs on the same network, with fresh Win11 installs, and only one of them was disconnecting repeatedly.

The working PC has an Intel card for wired and a MediaTek card for wireless. Both worked without issues on the latest drivers.

The PC that had constant disconnects when switching zones, loading dungeons, or monoliths had the RealTek network card with the latest drivers. Side note - I was able to reproduce the connection issues on another PCIe network card I slotted in with the latest drivers as well. This problem is definitely linked to RealTek cards and their drivers.

I completely uninstalled the latest RealTek drivers and had Windows replace it with their generic driver. I played for hours last night in multiplayer with 0 issues. LOVE IT.

If there are others out there who have tried everything else, I would implore you to try this regardless of what network card you have and DEFINITELY do this if you have a RealTek network card.

R.I.P. all the keys I wasted throughout this week testing solutions to resolve this issue, haha!

Good luck all, I hope I was able to help someone out there. I know MightyNicko’s post helped me a ton. Thank you!

1 Like

If any upgrades were made to the EUW servers they may have resolved the issue on my end. SG TCP Optimizer seemed to help somewhat prior to whatever divine intervention rendered the game playable again.

1 Like

Still experiencing the same issue, all suggested solutions did nothing for me.

1 Like

This is exactly my experience. I installed the generic Win 11 drivers, which helped the disconnects, but I have rubber-banding and weird delays now.

Worked for me.

Installing another network driver did solve my disconnect issues.

I forgot I posted here about this.
What solved it for me was seeing this post.

I got Ubiquity and saw that it was disconnecting me, when I whitelisted my gamer it just worked.

Still no fix for me, tried all of the above.
Including but not limited to;
Full windows re-install
Full game re-install
Full drivers re install
DNS set to LE servers
Running game as Administrator
Windows Defender exception
No Defender No Fire Wall
Modem/Router power cycles
SG TCP Optimizer
Using different server locations
Static IP through ISP
(ISP is the same at my office, and no disconnects when playing there)
VPN from different locations in the US and outside the US as well.
Probably forgetting somethings I’ve tried as well, and to no avail.

Seems like my character gets de-sync’d from the server, then after about 60 seconds in DC’d