Disconnecting every time I change areas

I have the same issue.
Beacon Fiber Internet (Oregon)
I’m on WiFi but have zero issues with any other games.
I had this same issue on a 1g up/down connection in Portland, OR.
I’ve tried Linksys and Realtek Wirelss NICs (802.11)
This has been an issue ever since they introduced co-op play.
I’ve read that some people fix the issue by removing their Realtek drivers and installing generic windows drivers. I am already using the generic windows drivers.

Sometimes I will log in, play and zone 2 or 3 times without issue.
Most of the time, I’m disconnected after clicking play, then every time I zone.

I’ve tried using the portals before beginning my play session, to port to another portal and back 2 or 3 times and don’t have an issue. I have not tried a VPN, but really shouldn’t have to. It’s 2024. What is most troubling to me is the lack of response from the Devs on this topic.

I just started having this issue on my Steam Deck when they dropped the patch today. Prior to that no issues at all. Windows PC on the same network works completely fine so it’s not my network or ISP. If anyone has a fix for the Deck I’m all ears because nothing I’ve done has gotten the game to work again.

Same issue. Hate having to run thru area again just to get to another disco

I have the same problem. Sometimes I’m trying to zone in about 10 times and getting disconnected and I’m just closing the game and going to do something else in this case. Trying some time later to zone once again and then it works fine.

1 Like

I can only say boys try the 2022 Realtec driver for your network adapter that fixed it for me,
at 2023 version i get again disconnects

Same here, been disconnecting from every dungeon or Arena, I have done, just very exhausting to motivate yourself with the already low drop rates,. when you get disconencted rightr before the boss

same here, tryd som tipps from reddit etc but nothing works. random discos around the world. porting, attacking, changing skills… it has no pattern

Still an issue, anyone find a reliable fix?

Well I dont wanna give false hope but I guess I might found a solution. Steam cloud files corrupted or files from Save Folder also corrupted. After deleting all files, I could play for the frist time 4 hours in a raw without DCs until I log out. Bad part I lost my lvl 96 character. I hope tomorrow I can also play the game without issues.

What is the file path for these? Rather, how does one go about deleting these, and which files exactly?

March 24th, this issue is still prominent. I don’t know how they haven’t addressed literal game breaking bugs in months. Just had to run through the same area like 25 times because it DCs every single time I try to move areas. Doesn’t matter where I am or where I’m going. I was starting to like this game too.

reported here:

and here

Just bought the game today.

Well, I have an Intel NIC and am running Linux and still having these issues. However, I MAY have found a solution (not just for Linux)…or it might be a coincidence.

“Unexpected packet larger than min frame size” gave a clue. TY, Hyoah! (Though something being bigger than the minimum seams like it would NOT be a problem?)

I changed my MTU to 9000 (instead of the very typical 1500). Just on the PC, not on the router. Apparently doing this is called Jumbo Frames. I’m really not sure WHY you would want to do this in normal circumstances, but OK, sure.

GIANT DISCLAIMER!: Messing with your MTU can cause networking things to NOT WORK right. Lag, no route, disconnects, probably web security certificates. Results can vary. DO THIS AT YOUR OWN RISK. (You also can just put it back, too).

Linux: (change eth0 to your own nic)

ip link show | grep mtu

ip link set eth0 mtu 9000

Maybe someone will be kind enough to post how to do this on Win10/11.

This all said, this is NOT AT ALL NORMAL and the game should be fixed. “Use a VPN” and “Use TCP Optimizer” are also not acceptable solutions…but these working at least make more sence on WHY they work.

11th Hour, please fix your packet size issues. C’mon!

today is not posible to play disconects every 5 min, fix your servers

There are multiple posts that are much older then this thread that are about the exact thing.
Devs wont comment / care.

I can complete only 1 of 3 tries in danges. While changing zone i had connection lost to the game server. I cant even slam my items because I cant reach final boss on sanctum

same, i have that issue from last 1.5 month, nothing changed, no fixes from game devs.
A lot of peoples have same issues and it seems like they are not going to fix it.

I’ve also had this issue for the last 2 months with no fixes.