Several connection issues. Can't play the game

Hello, I’m having connection issues while playing the game. Almost every time I switch maps, it’s a 50/50 chance, and most of the time I get disconnected. When I return to the game, I can’t immediately join my friend’s game; I have to keep logging out and in with my character to rejoin the group. I’ve searched the forum extensively for solutions and found several that didn’t work. I’ve reset DNS, changed the port to, reinstalled the game, and verified the files. If anyone has any solution, I’d appreciate it.


I m having the same issue it unplayable, please if someone can help, I’d appreciate that.

By any change using Ubiquiti firewall. or a other firewall, you might want to check the logs

As i have same issue, and see below warnings in the log at the moment of the disconnect.
Detection Category P2P
SignatureET P2P ThunderNetwork UDP

As a work around i made a firewall rule to allow last epoch servers.
A bit of pain in the butt too make a last epoch servers list (36) at the moment

Hello, I m not using Ubiquiti firewall just a normal one. I tried giving it rules etc. but nothing even used a new router even spoke with my ISP they check nothing since I don’t have any issues with other games.

Had the same symtoms and I solved it this way:

Cheers, gonna try it out, I’ll update if it works!

yup, i can play the game now, cheers mate!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.