Beta 0.9.2b Patch Notes


  • Fixed a bug where using a Rune of Research could not create a Glyph of Insight.
  • Fixed a bug causing projectiles to be destroyed early in the Ritual Lake echo layout.
  • Fixed a bug which caused Frostclaw’s Glamdring node to scale with increased and more melee damage stats.
  • Fixed a bug where submitting a bug report when your Log File was too large could crash the game client.
  • Submitting a bug report now also includes the Log File for your previous session as well.
  • Fixed a bug where Adanai’s personal item dropped as a Staff instead of a Dagger. This fix will not retroactively affect existing items.
  • Fixed a bug where Frost Claw did not have localized text.
  • Fixed visual issues with Frostclaw’s Fire and Lightning conversions.
  • Fixed visual bugs with the Rogue’s appearance when creating a new character.
  • Fixed a bug where players would stand completely still after certain skill animation ended, rather than returning to their idle animation.
    • Summon Spriggan
    • Upheaval
    • Default Attack
    • Ice Thorns
    • Summon Scorpion
    • Earthquake
  • Updated animations for channeled Flurry when using a polearm or two-handed axe.
  • Updated sound effects for Immortal Eye enemies.
  • Fixed footstep sounds being incorrect for players.
  • Replaced the very old sounds on Divine Bolt and Volcanus’ shard ability with newer ones.
  • Fixed various minor environmental audio issues.

What We’re Working On

Thank you for your bug reports and feedback. We’re still working on addressing more issues for future patches.

Here are some things we’re currently investigating:

  • Transition times between scenes can be quite long.
  • Rarely disconnecting immediately after connecting to a new server.
  • Sometimes, your player model is duplicated after entering a new scene and the camera gets stuck. Portaling out to another server usually fixes this.
  • Rune Prisons can rarely fail to spawn an Exiled Mage.
  • Enemies in Arena and Monolith often do not animate properly.
  • Certain abilities failing to hit enemies correctly.
  • Swapping loot filters can cause the loot filter interface to bug out.
  • Textures can pile up on the ground as you load more monolith echoes, causing strange visuals and increased memory usage.
  • Item name lengths are now “Long” when they should be “Normal”.

It’s not rare, it happens every time, if a prison is near the player spawn.
Also I appreciate, that the mage fights monsters as well. But why he fights us, if we have freed him? Why do we need to free a prisoner in the first place? I would like new content to be consistent with the lore, so that there aren’t any attack helicopter mini-bosses in the future (but if you add them, I won’t compain).


It’s like being put in solitary confinement for eons. This can drive any person crazy. I actually think it’s a perfect reaction from these mages.

so you don’t work on this?
it is disgusting. I can’t normally play your game and you don’t even care at all. It is not just a visual non-important bug it is a gameplay breaking one. So should be first priority

Oh the irony…

Why is there no fix for the shuriken armor bug?

1 Like

There are some reports about people losing their Spellblade’s offhand item. It also happened to a friend of mine. Now I am afraid to log into my Spellblade. Is this also looked into or do I just have to risk it?

I don’t see anything about the following issue (I’ve tried to send in a bug report with screen grab but going to the report form temporarily clears the bug). A rune description box can appear during crafting or item comparison that will overlay the area of the screen it appears on. The overlaid description box will follow the cursor. If I try to do an item comparison the item to be compared to my equipped item does not appear, the rune box replaces it. It only goes away if I leave the mono/campaign zone.

No fix for buggy quest echoes in multiplayer?. Not even a word about it? Idk about you but it’s pretty “game breaking” for us. It’s pretty annoying to do a single timeline twice so just both of us can move on to the next timeline, it’s so time consuming despite this is still just earlier echoes. Just imagine if it’s empowered that needs 800-900 or something.

When ur playing in a party. Only the person that activated the echo gets completion for that echo. That person also gets the echo rewards.

The other players get 2 options to pick from for there reward.

U do not need to run the echo twice to complete it for both players. To move on to the next. U can if u want to.

If this is what u mean by doing the echo twice bug. Its not a bug thats intended

Were you talking about the final video in that post? That’s what’s supposed to happen. You had more than enough stability to do the boss so after you killed the boss it consumed the stability & permitted you to skip the first two quest echoes once you’ve got enough stability to do the boss.

What you didn’t show was whether or not it unlocked the bridge to the next echo or unlocked the chosen echo.

Okay so that’s why my Spellblade lost his offhand lol, I thought I’d taken it off randomly at some point and couldn’t find it.

Nothing to say about the Temporal Sanctum loading bug in offline ? ok maybe it’s solved alone, i will try a key

We were doing quest echo and not normal echoes. And I used to play with another friend that completes it for both of us as long as we both have the first and second quest echo completed and sufficient stability. Also I asked around in global chat and pretty much everyone said it should complete for both of us.

Like I said, it used to complete for both of me and my other friend I used to play few months ago. I can guarantee you that even doing the first or second or even the last quest echo even my friend was the one who started it, it all also completes for me, having a check mark on these (except no check mark on 3rd one ofc).

We both have the same progress. Neither of these happened to us when we’re unlocking echoes together as we level up since like I said it completes simultaneously for both of us. Otherwise I would’ve made this kind of post back then if it was really “intended”.

As for the bridge:

  1. Using our Rune master character, all bridges were unlocked when we entered the MoF together for some reason. So it’s kinda harder to tell if the same would’ve happened just like on our first character. And so impossible to tell if “that” bridge would’ve unlocked.
  2. Using our first character (both sentinel base), it was even more buggy. Not even the starting bridge to get to Fall of the Outcasts unlocks. Even after completing Fall of the Outcasts timeline, none of the bridges unlocks either. Though after several restarts and experimentation whoever gets to be the party leader or leaving the party first etc, then it finally unlocked.

Idk, I might be missing some piece of information here, or some patch notes I missed.

you didnt fix the locked monoliths? So first you lose my offhand and now i still cant play? MY MONOLITHS ARE LOCKED LE -64 ERROR . I PAID MONEY FOR THIS SO LET ME PLAAAAY

What’s going mate? I thought you were gone


My main note about the empty Rune Prisons, for what it’s worth, is that for me it has ALWAYS happened with 100% consistency when the Rune Prison was immediately on-screen as soon as I loaded into a Monolith. It almost feels as if whatever guarantees no enemies spawn on top of you during the load is removing the nascent enemy from the prison. :V

Can’t wait for this one so I can play with the new javelin unique! Hope it gets fixed soon!

There was a post a week or so ago about this happening and one of the Devs stated it should go into your stash or Gift box or it’ll drop on the ground. If you didn’t see it in your stash or on the ground maybe check your Gift box just to see if it might be there.

Sad. There are already 50+ Lost connection reports in the Forum but still not in this list for them to fix. How come they are ignoring this issue even though lots of players already reported it? Weird because our money is completely wasted because we cannot play the game
Search results for ‘lost connection’ - Last Epoch Forums