My Account
× My Account Forum Buy Now

Last Epoch Forums

Consistent low fps

lastEpochInfo.zip (22.2 KB)
Got the game the other day and started playing. 1080ti, and ryzen 1950x with 32GB ram. Build doesn’t seem to matter, as the fps outside of towns even outside of combat hovers at around 25-40fps in most zones (especially welryn docks. That is the lowest I’ve found so far). It also does not make a difference whether I have settings set to all ultra or very low, the fps changes maybe 2fps tops. I’ve followed everything in Boost FPS - possible fix and received no benefit from any of it. I am also fully aware that the game is still in beta/early access and the devs have not been able to focus on optimization yet. I’m just curious if there is something easy I’m missing, otherwise just giving them another data point for when they do get around to optimization.

Edit: In case relevant using Nvidia’s performance overlay for data collection shows my cpu never goes above 15% utilization, and gpu never goes above 55% utilization.

Hey, Welcome to the forums…

Please can you post your le_graphicsmanager.ini file… I will reply in another post once I have gone through your player.log and dxdiag…

Ok…

  1. Your player.log doesnt show anything obviously out of place… Its mostly debug code for the devs and there is one crash on exit - which probably happened when you alt tabbed away from the the game after exiting… Nothing to worry about that I can see otherwise (note I am not a EHG or Unity dev).

  2. Your DXDiag shows that you are running windows OS version 19041… there are two updates since then 19042 and 19043… I would suggest you update these… There are dubious updates from earlier in the year (specifically KB5001330 and KB5001337 ) that absolutely nailed FPS in various games - they have been subsequently updated so its important to update the OS to make sure you are not still using them.

  3. Your graphics card driver is dated 6/20/2021 - please confirm that this is NOT version 466.77 - that specific driver has problems with LE… If it is, then I recommend rolling back to a previous one or trying the 471.x later ones…

  4. Boost FPS is a pretty old post now so I doubt most of that will have much of a difference.

  5. Dxdiag diagnostic section (end of the file) seems to show a lot of memory leak errors - normally these can be ignored but it seems to be happening with lots of different things - everything from OBS to Steam to Chrome and to various games including LE… Generally these errors are just windows providing information that some app hasnt managed its memory usage properly but its not usually a good sign if lots of different apps report the same type of error… This could point to anything from bad code in the apps to corrupted graphics drivers to potentially too aggressive XMP/Memory profiles on a system… It is best that you go through your Windows Log and see if there are any issues that need attention… You may need to consider running a safe mode graphic drivers uninstall and new install just to ensure that its correctly installed (or use something like DDU). You may need to also check what speed your memory is running at and make sure its within spec.

  6. Disable or temporarily do not use anything while trying to play LE… This includes overlays like Steam/Nvidia, OBS etc… Unity (the game engine LE uses) is known to have odd problems with other applications (e.g. Citrix /Teamviewer ) so its best while testing to temporarliy not have anything else running to tick it off as potential causes of problems.

  7. Performance wise, as you already mentioned, LE is in beta and definitely HAS performance issues so you need to be realistic in your expectations - and yes, your hardware should be capable of more once you are sure that the underlying issue is resolved… Once you have done the above possible suggestions you can try the following:

    • Set your in-game graphics settings to 1080p, 60fps framerate limited (enable checkbox) ALL in-game settings to very low, disabled or the lowest possible setting.
    • Monitor your GPU usage % and thermals and see how stable the game is - this includes if the game exhibits odd freezing or big fps spikes (30+fps drops).
    • Next, increase the resolution (if needed) to whatever you want to play at and compare the same metrics of GPU usage etc… A good target is that your GPU should be running comfortably at no more than 60-70% usage… This leaves headroom for the game to spike to max while playing without maxing out the GPU for long periods and making the game unstable.
    • Next increase the framerate limit (DO NOT remove it and DO NOT use vsync) to whatever your screen can handle or less.
    • Monitor the GPU usage and adjust the framerate limit to keep it comfortable.
    • Next, you can increase the in-game quality settings one at a time to find a compromise between stability (crashes, freezes, fps spikes) and visual eye-candy.
    • Although your 1080 Ti should be able to handle a fair amount of quality, I would not go higher than Medium/High. But you need to monitor your GPU and see what works for you. Very High / Ultra are best left to much newer hardware and honestly imho, the difference in graphic quality is not really noticable in a game like this… and the GPU will be happier…
  8. Last point… There are known issues with FPS loss in the game that cannot really be dealt with… Things like lots of minions, busy combat with lots of mobs, lots of skills proccing all over the screen… big mob pulls etc… There are even issues with GPU usage spiking when opening the stash / inventory windows… These are things that the devs know about and will eventually get fixed but for now its important to realise when these things happen.

  9. Oh yes… and one last one… Make 100% that you verify the game files through steam… This is important.

lastEpochInfo2.zip (24.0 KB)
Thanks for the reply! I’ve gone through and tested more. Numbering will be in reply to your numbering.

  1. Updated windows to the newest version.

  2. Checked my graphics driver. Was 471.11. After reading one of your later bullet points I did a clean uninstall with ddu in safemode and then reinstalled driver. Should still be 471.11.

  3. The XMP/Memory profiles are in line with my cpu, and after a clean install of the graphics driver there shouldn’t be any corrupted driver parts laying about.

  4. Tried things with and without other stuff running

  5. I always play 1080 60fps as I only have 1080 60hz monitors. I set everything to very low/lowest setting. My GPU usage never went above 40%. My friend with his 2060 gets ~120 fps consistently on high settings and my 1080ti benchmarks 50% faster/stronger (barring rtx). As for vsync, I’m using that because if I don’t there is horrible screen tearing to the point it hurts to look at. I did test without vsync on though (and framerate limited) and there was literally no difference in frame rate.

  6. This occurs outside of cities even after I have emptied the map of enemies.

  7. Files were verified through steam.

After all of that testing at both very low and ultra both yielded identical framerates of 30-45 outside of cities. The only explanation I can think of given my friend’s rig and his experience is what optimization has been done has been done for intel and not amd or for some reason the devs are implementing some ray tracing features without a way to turn it off (I highly doubt that one). Once again, I’m not mad or anything I’m just trying to help troubleshoot through this for my own sake and as an extra data point for the devs to work with. Thanks again for the reply and if you have any more ideas/thoughts please let me know.

Hey.

2 - Updated windows ok… As a double check, especially as nothing seems to have worked - look in the WIndows update history and see if the KB5001330 and KB5001337 updates are still active on your system… They shouldnt be if Windows Update ran properly.

3 - Graphics driver ok… 471.11 should be ok. its new so I am alway a little skeptical especially on older hardware but I cannot say if it may be the cause… As a last resort, you may have to consider going back to something from a while ago and seeing if it does anything.

4 - Ok… Memory issues are unlikely but its important to check anyways… Especially if there are lots of them.

6a - I use a 1060 3gb and if I am willing to handle the fan noise I can get around 75 fps on very low settings @ 1080p outside of combat in pretty much any map. If I throw caution to the wind, I can get 100fps but things get a little flaky if I do that and the game tends to freeze up or crash. I have no doubt that your 1080 should be performing better but I am pretty confident there is something specific on your setup causing this.

6b - Vsync… Obviously framerate limiting and vsync do pretty much the same thing so they should be interchangeable but vsync in LE seems to misbehave often… and it doesnt allow for you to fine tune things… Hmm screen tearing… This rings a bell… Cant find the post right now but I recall something about rolling back to older drivers helped resolve this for some people… There was also a solution by forcing the Nvidia driver to take over the vsync with an exception in the driver level for the LE executable - i.e. disable vsync & framerate limiting in-game and figure out what settings in-game give you an average fps (you can use F11 in game to show fps top left) just higher than your monitor refresh and then tell Nvidia to enable vsync automatically instead of allowing the game to chose…) This resolved the tearing by doing it at a driver level instead of in LE.

Intel/Amd I’d put money on it not being that at all. There are plenty of AMD players here. Your processor is similar in performance to mine (i5-7500) barring the vastly more cores/threads which I dont think LE is taking advantage of anyway right now…

Ray tracing features etc… nah I think we are a very long way off from the devs trying those kinds of things yet… Its all focus on content & multiplayer right now…

The difference in Ultra and Very low should be significant… If I do that on my 1060, I get slide show performance almost instantly no matter where I am. The fact that you see no perceptable difference is VERY ODD… The bug/technical forums are full of people who tried Ultra settings assuming that their hardware would handle the unoptimised game and after crashing, freezing and generally bad fps, changing to Medium or lower resolved most issues that were not driver related.

With this in mind:

  • Do you have any configuration in your driver that is overriding the in-game settings?

  • When you set the in-game settings - did you try the very low base starting settings I suggested in 7? with everything off - it could be that one of the settings is triggering this issue… (dont use the master option at the top, manually change each setting).

  • Can you monitor your 1080 ti core clock speeds and see if they are fluctuating? There have been issues (see this post) where bad drivers caused a 2080Ti to reduce its clock speeds for no apparent reason… This was on 0.8.2 so its fairly recent.

Thanks again for taking the time to help me troubleshoot this.

  1. Realized there was a new build of win 10 I could use 21h1 or something like that. Updated to that, then checked for those updates, I do not have those updates.

  2. Out of curiosity what driver version are you using for your 1060? Because when I started playing last night I had a driver from late 2019. Then I updated to the latest. Neither have made a difference

  3. Quadruple checked everything about my memory including timings.

6b. I have tried both driver vsync and driver adaptive vsync, aside from not helping my fps issues, it also still causes screen tearing oddly. And only for this game.

I’ve also tried various driver settings, overclocking and underclocking cpu. Oddly I did manage to snag 10fps gain across the board by turning supersampling on and downscaling from 4k instead of 1080p. It is like the game is just refusing to utilize my gpu. Also my lowest fps (so far) is wrelyn docks where all the void terrain is moving simultaneously. Again though tested all of this on very low and ultra and there is no fps difference. As for my 1080’s clock speeds I am sitting around 1.5k mhz give or take 500 for combat so it doesn’t appear to be downclocking randomly. I also have tried essentially every combination of settings from lowest to highest at this point including manually turning everything off/to the lowest. No change in fps or maybe 5 tops. hard to tell it oscillates slightly. Thanks again for taking your time to help.

Hey.

Windows updates - ok.

I am actually still using a very old driver… 461.40 - its been very stable for me at the res I play at and I usually only update drivers if its known to fix a problem I have… The old “If its not broken dont fix it” applies for me… And I am using an old gpu so I doubt very much there is anything in the new drivers that is going to benefit me.

Vsync… wish I could confirm for sure on this issue as my gut is saying that its involved or at least hinting at something… might need some google research to see how others have dealt with the issue - something might go ding…

I doubt very much that anything you do on your CPU will have a difference unless its extremely overclocked/underclocked… LE isnt optimised and I doubt very much its going to use any of your additional cores anyway… A simply thing would be to disable any OCs on your CPU/GPU/Memory for testing purposes…

Supersampling… hmm… again, a setting at the driver level… another tick for something driver related…

WelrynDocks… Look, there have been maps that cause inexplicable fps drops, but most of these have been corrected by the devs in previous patches… So, its possible that there is something in the maps that is triggering this issue but its really hard to replicate - especially when I can go to the same place and not notice anything… Out of interest, does this same thing happen on the maps with the meat grinder worm animation?

GPU clock speeds… Ok… another thing to tick off then…

Ok… what next?

  • Try an older driver… What can you lose really?

  • I know its tedious, but try not to change more than one thing at a time while testing…

  • Found this online … Poor 1080 performance resolved by swapping PCI-E slot on motherboard… Actually found quite a few references to this with 1080s… reseating the PCI slot and reconnecting power connectors seems to have been a common problem :crazy_face:

  • Found countless google entries for “1080 Ti low FPS” - while it seems to happen on a wide variety of games and mainly when the card first launched, it looks like you are not alone in your frustration…

  • Try disabling windows game mode (Settings/Gaming) and the gaming bar …

  • As you only have the one graphics card forcing Windows to assign a specific GPu to the game seems silly so I dont think that would make any difference.

  • Lots of people had issues with Nvidia DSR options… seems like the various settings make quite a difference - obviously this was on much older drivers so I am not sure - but maybe this is something to test if you havent already…

  • Found a few referenced to G-Sync and Vsync fighting with each other but as neither of your monitors support Gsync I would assume that this is not an issue.

So I tried your driver and nothing changed so reverted back again.

Vsync can’t be attached to the issue as most of my testing has been without it at this point (and just dealing with screen tear).

The CPU clocking was just to see if the game was just wanting speed over all else (regardless of core count) since not yet optimized. Wasn’t the case.

Supersampling increased my fps. That said reverted because my card was going nuclear trying to push 4k.

Upon considerably more testing (played another 8 hours last night) Welryn Docks and Welryn Lower City are the two zones I’ve had consistent issues in. Cities I’m getting ~100 fps. Some zones I’m getting 120 like ancient cave. If I had to posit a guess it would be the sheer amount of void that is slowly jiggling at all times on those two zones, but other zones with lesser amounts of void do not have the issue even though they also have the same animation. It might be a critical mass of the animation causing it? I still am not getting most maps higher than 70 fps though even with lowest settings and everything disabled. I play at 60 so it is useable but my rig ~should~ be capable of more (could just be optimization at this point though).

Oddly I am still only seeing at most a 10fps difference in any area between very low settings and ultra. I settled on medium because it makes the bad zones slightly more tolerable. Edit: Of note I am seeing a graphics difference even if I’m barely seeing an fps difference.

Disabled windows game mode. Had disabled it way in the past, but it seems it turned itself back on at some point. Either way off now and didn’t make a difference.

DSR increased my framerate, so I’d argue that is the opposite of an issue. I turned it back off though because as stated earlier my card was going nuclear trying to maintain 4k.

Yeah no gsync being used anywhere.

Thanks again for taking the time to go through this with me. I’m relatively certain it is not a driver issue as this is the only game I have issues with. If I turn vsync off I can get 120 fps in monster hunter world ultra settings with maxed volumetric fog even, or cyberpunk 2077 ~90 fps high settings (with rtx off). Unless you can think of anything else I will have to chalk it up to those two maps and optimization in general for now.

Np… I tend to use the technical support section as my winding down at the end of the day so I dont mind helping out… most of the time things are easy to fix… other times like this can get complicated.

Someone else just reported a similar thing with the Welryn maps but using a 2060 and their logs show totally different messages to yours and they have other general system problems that could be affecting things. Enought that I dropped the devs a ping to see if they know of any particular issue with the Welryn maps based on the messages.

Critical mass of animation - definitely… just not usually in a static map… its usually when there are plenty of mobs/minions on screen and lots of skill interactions all happening at the same time - thats a known issue that everyone can confirm… Last time maps were fps problems was I think in about Aug last year with maps that had absymal fps spikes but the devs replaced them or fixed the problem ones… Lets see what the devs respond with…

Should be capable of… yip… no denying that fact… personally I would prefer the devs worked on performance/stability than more content (or multiplayer) but I will be tarred and feathered at dawn if I say that out loud…

I’ll let you know if I get any other info or find something new to try.

Just hopping in again to mention other things I’ve tried.

I updated my bios because I essentially had a launch bios and there were two updates for performance since. Sadly no help.

I’ve tried toggling memory between distributed and local since the 1950x has 2 die and I am quad channel (as you are supposed to be for it). No change.

I can be doing intensive other things on the computer (such as streaming at “medium” encoding speed) and it does not cause the fps to drop any further than it already does.

I’ve found a handful of other maps. The map with tons of spiders right before welryn docks. Ruins of welryn. And it feels like almost every third map after (just woke up if you want I can specify every map I had issues on).

Part of me believes it is something to do with my rig but given some maps I get 120 fps on ultra and others I get 30 on very low it makes me very unsure. I’m also still unsettled that switching between ultra and very low is netting maybe a 5fps difference on any map.

This really is the most frustrating thing because it makes no sense for there only to be a delta of 5 fps between the highest and lowest quality settings… its illogical for a modern game (even a beta one) to exhibit this and definitely not at 1080p.

Decided to monitor the cpu side of resource manager since upon further reflection the graphics settings not affecting the fps means it is likely a cpu bottleneck. These aren’t frequent or consistent but the game is causing 2 threads to cap occasionally. Unsure if related but it is a new path to potentially look down. This is on a AMD Ryzen Threadripper 1950x OC’d at 3.75ghz

I tend to use https://pc-builds.com/calculator/Ryzen_Threadripper_1950X/GeForce_GTX_1080_Ti/0Nk0XF8A/32/100/ when checking for bottleneck problems…

I recall checking yours earlier but decided against mentioning it because you are running in 1080p… If you were trying higher res, then that definitely could be an issue…

And if you trust that website, its your GPU not your cpu that is potentially the bottleneck…

I’ve come to the realization the CPU peaks are from zone loads. Otherwise not going above like 60% on any thread. I also opened up my comp and dusted it out. While I was in there I realized my GPU was in a PCIE 3.0 x8 so I moved it to an x16. Sadly it did not help aside from the GPU not going above 36% usage now and like 40c. Legitimately just feels like the game is refusing to use resources at hand. I think I have officially tried literally everything in my power at this point.

Wouldnt that have been an amazing solution… :wink: no such luck…

Pretty much…

Still hoping the devs get back with something tho… chin up… :stuck_out_tongue_winking_eye:

Did some searching and this guy sounds like he had my exact (or very similar) problem but at a slightly higher fps cap. I wonder if his got resolved.

Edit: Tested disabling one of my monitors. Aside from it causing vsync to think my monitor was 75hz there was no difference (after turning vsync back off).

Well before my time here… all I can say is the game bears very little resemblance to what it was then…

@nwf Did you ever sort out or get an explaination for the odd FPS issues in your post?

So I’ve essentially narrowed it down to a CPU bottleneck due to how the game is optimized. Nothing on my end even approaches touching the fps, and none of my threads are even going above 60% usage. Since I last posted I have updated my bios, toggled hardware accelerated GPU scheduling, tried running compatibility mode for windows 8 and 7. Nothing affects the framerate. I’m bottlenecking without even using 2/3 of a thread just due to how they have optimized so far, so all I can do is wait and hope they find a way to optimize that doesn’t cripple first gen threadripper or for something they do to cause a change. Once again, not mad. It is early access. I am just documenting this all on the chance they read this and the hope that they find a fix for it.

1 Like