Can't get past character select

Downloaded the beta, and when I make characters I always receive the error “Lost connection to game server” before I load in. I’ve reinstalled the beta four times, restarted my pc, deleted local files between installs. I’ve run out of ideas. I would try to make a new display name (its the only thing left I can think of) but for some reason I am not able to alter my display name.


Same here, created character and cannot enter the world. It takes forever trying to load then says “Lost connection to game server”. My 3 friends playing have no issue with connection. It’s not an issue on my end, my internet is fantastic with 1000 up and down and <40ms pinging the server.

1 Like

Same =(
was hoping the patch would do stuff and things but no luck. My brother is able to play with no issues but signed up for the beta several hours before I did.
dunno if its worth a mention, but my steam profile stuff is private while my brother’s is public. maybe they’re using some steam network magic to make things happen?

So weird thing that worked, I turned on my VPN. Suddenly no issue connecting.

1 Like

if I had a VPN to turn off, I’d try it that. it seems weird to make it past the initial login, only to fail to load into the world on a character. wondering if steam cached stuff it wasn’t supposed to, since it often holds onto preference data for various games even after uninstall / reinstall.

did another uninstall / reinstall, no change. no security software installed so not sure what other settings I can tweak :frowning:

Yeah I just figured I’d mention it because I would expect to have problems with it on not off, but turning it on fixes the issue. I still can’t connect without it on.

Having the same issue post 0.9 launch. Thankfully the vpn suggestion from shwaynorris allows me to play, but using a vpn to play is frustrating. Not sure where to even turn to for help with this kind of thing.

1 Like

I have the same exact problem, can’t get past the character selection, game gets stuck on loading/connecting then crashes. I’ve tried using a vpn and then it connects to the game normally, but I dislike playing while using a vpn, and if I close it after logging in, it just disconnects and then crashes the game. I live in Egypt and normally connect to EU servers and never had any problems connecting to any online games before, please help with this issue.

This was extremely frustrating to read since me and a LOT of other people still have the same problem of not being able to connect unless we use a VPN

1 Like

Same issue here, infinite map load screen after character selection, looks like VPN is the way to which makes no sense why I should use VPN to play the game…

Is this thread live? I have the similar issue with Last Epoch - Unity 2019.4.40f1_ffc62b691db5 crash after character select screen?

There is a link to reddit post with the same issue

1 Like

If you find something like could not resolve host or dns in your Player.log file
Then you likely have a DNS issue. You can change your primary and secondary DNS servers to something more reliable than the default of your ISP (Google DNS for example). For those saying that VPN fixes the issue, a normal side effect of using a VPN is it using a different DNS server configuration.

Same issue, changed DNS and flushed DNS. Still loses connection after character selection.

Not sure where my player.log file is, but I already use google dns, and i still need to use a vpn to get past the character select screen, not to mention ive never had problems connecting to any other online game before…

Still stuck after character selection even trying changing DNS on adapter… can connect and play with VPN…

I was able to create a character no problem last night. This morning I was able to join no problem. Now this afternoon I’m having the same problem as described in this thread with the exception that connecting to a VPN doesn’t resolve it so I currently do not have a workaround to play.

An update for those also with this issue - I was able to fix mine by verifying game files in Steam. No idea why it broke, but that was the fix that worked for me. If VPN does not solve your problem, maybe try that.

Tried that with no luck sadly

I also can’t connect past the character select menu.
Player.log (56.5 KB)
Here’s my log, maybe it will help?