My Account
× My Account Forum Buy Now

Last Epoch Forums

Stash category duplicate - need to manually modify a file?

Imgur
There are two “Arena” categories but I created only one.
The two have the exact same content: one “Keys” tab. I can’t delete any of them because they are not empty.
I already had this problem recently. I had to move the tab to another category then delete the two duplicates and create a new category for the tab.
Before the problem happens, I only browsed between categories and used the Search function of the right bar. I was looking for items with a specific word (not the same the two times the problem occured).

The problem is even worse now.
When I create a new category, it becomes a duplicate of an existing one. Then I have to move all tabs, delete the two categories and create another, hoping the issue will not come back.

The problem continues.
Is there any way to check the stash file and to repair it?
I’m really considering removing the file and creating a new empty stash.

Imgur
On the right column I right-clicked the “Exalted” category and the game selects the “Idols” category. “Exalted” seems empty by if I click it, I see all the tabs from “Idols”. And I can’t delete “Exalted” because, even though it is empty, the game says it has tabs.

Hey… It really seems like your stash is messed up…

I have looked at the stash file Epoch_Local_Global_Data_Beta and in mine the tab / category information is at the end and fairly “readible” …

I would suggest that before you delete everything and start over… maybe you can backup your files, and then look at your tab entries and see if you can deduce by looking at the category and tab ids to find the ones that are messed up and see if you could manually just move then around…

Obviously the game might crash when you next load it and other things but hey… its beta and you have a problem… People like Tunk & Dammit or obviously EHG might be able to “fix” it but pretty sure they will have better things to do… :frowning:

Another thing I would consider doing is backing up your existing files (all of them), removing them and then creating a new character and creating a few stash tabs & categories so that the game creates a whole new stash file etc… .then you can compare a clean stash with your messed up one. Then, if you can figure it out, you can copy your savegames etc all back…

Obviously this is all at your own risk… and I doubt EHG would approve of any of this, but you are trying to rescue your stash… :wink:

OK, thanks. So in the file I can find this:
“categories”:[{“categoryID”:0,“iconID”:0,“colorID”:12,“displayName”:“Uniques”,“displayOrder”:0},{“categoryID”:1,“iconID”:0,“colorID”:17,“displayName”:“Idols”,“displayOrder”:1},{“categoryID”:1,“iconID”:0,“colorID”:15,“displayName”:“Exalted”,“displayOrder”:2},{“categoryID”:3,“iconID”:0,“colorID”:13,“displayName”:“Arena”,“displayOrder”:3}]
If I understand correctly, “Idols” and “Exalted” have the same categoryID number, which could explain the issue.

If someone from EHG can read this: am I allowed to edit this part and change this setting? Or is it against the TOS?
I was considering deleting the stash file, but I’d prefer fixing this one if possible.

Hello @Mike_W this is what I was talking about on Discord.
Do you think it’s permitted by the ToS to manually edit the file in order to fix the categoryID?

Personally I would just try it… The game is in beta and things mess up and if this works to fix your problem then honestly, its not like you are trying to hack the game, you are just trying to fix something specific to your local savegame.

It may even help EHG prevent this kind of problem in future patches…

Yes, I would really tend to do so and I think I’ll do, but I’d like to have EHG’s opinion about it.
I’m sure they can’t say “you can edit your file”, but they can draw the line of what modifications are allowed. I sawx how the file is, I will not try to change any other element, it would be too dangerous and it would be cheating!

Edit: it’s done and the problem seems to be fixed, the stash works fine with two different heroes, I’ve been able to swap categories for several tabs without any issue.

1 Like

Hello @KissingAiur some information for you.

  • If I remember well, the problem started when I tried to drag a tab from a category to another
  • At that moment, the two categories appeared as the same (same content when clicking them, unable to remove any of the two because they were not empty, even if one appeared empty on the right column)
  • In the file, the two categories had the same “categoryID”
  • I manually edited one categoryID in the file to set it to an unused and continuous value (it went 0-1-1-3 and I set it to 0-1-2-3)
  • Now the stash seems to work properly

So there may be a bug related to dragging a tab from one category to another.
Is it something that is supposed to work? Or are we supposed to only drag tabs inside the same category?

Dragging a tab from one category to the next is not a supported feature currently.

There are multiple stash bugs that we are tracking, I believe this is one of them.

Thanks for the report.

OK, thanks for the confirmation!
I hope my testing will be useful, have a nice day.

I have the exact same issue still and I’m a bit unsure what the fix is. Do I have to completely reset my account? Am I allowed to edit one file to fix it without getting banned from the ladder?

I would suggest you edit your file, after backup. I can’t guarantee EHG is 100 OK with that, but this solution has spread and multiple players applied it without any problem.

Hi
Have the same problem, and will try your fix.
The document is in “file” type, so should I correct it, and save it as .txt? Or did you work it around somehow?
I would love if you can post more steps after you edit the categories ID order.
Did you also edit the temp file or only the source one?
Thanks in advance

EDIT:
I changed both files and overwrote previous versions.
Worked just fine :slight_smile:
Thanks for your solution.

1 Like