Lost connection to Game Server (more than 1 Day)

Hi Guys,
need your help please… can’t login to game server (level 55 Paladin).
Last time i was able to play was about a day ago (act IX i was on the bird flying) and then suddenly the game “crashed” with you lost connection to game server … since then, its not playable anymore !!

i flushed my ip settings, changed dns server, tried to use vpn … nothing helped at all.
here you have an video of the error:

please help ! thank you !

UP … guys what is this dogshit ?!
Reported a Bug also … but no reply ?

tried to create a new online char … this shit works … but with my level 55 paladin, im not able to connect … this is fucking stupid !

i bet, there is a problem with the zone i got disconnected the last time i could play …

Did you ever get this resolved? Having the same issue

nope …
still yet no response from EHG

@EHG_Alux @EHG_Foton @EHG_Mike @EHG_Caliph @EHG_Justin @EHG_Kain @EHG

really ? no support in this case ?! come on guys !
after 1 million sold copies, there should be any support crew ?!

We apologize that you are experiencing this issue. It is something our team is aware of and is currently doing their best to resolve it as quickly as possible. In the meantime, we do have a few connection troubleshooting options we can offer that may help until a more permanent solution is found:

  • Changing your Server on the Log-in screen
  • Using a VPN has proved helpful for many players. If you do not have the ability to purchase a VPN, Cloudflare Warp is a free VPN that has been tested by the community.
  • Sometimes a VPN will block players from connecting, please turn your VPN off to see if this is the issue.
  • SG TCP Optimizer is a program that many players have also found helpful when experiencing these issues. This Youtube video can help you set it up if you need it.
  • Contacting your ISP may also be a useful option as it has been found many providers have a block on certain items.
  • Adjust your DNS settings
  • Check to see if your Firewall has an exception for Last Epoch
  • Please use https://gcping.com/ to see if your IP is being affected by Google Cloud

If none of the above prove helpful, please know that the team is working on a solution. To keep tabs on this information, please visit our Forums, as this will be the first place such information will be posted

i did all of those options you mentioned … as i wrote … when i create a new char, everything works fine … so this is not related to any connection problems or dns or ip or …

there is something blocking my char from beeing able to login again ?

Please submit a support ticket at https://support.lastepoch.com/ and our support staff will guide you further.

so … after one week … i’m still not able to play my char … are u kidding me ?
support ticket → created, no answer !

come on guys … @EHG_Caliph is there a possibility for refund ? i bought 2 copies … for me and my wife … pls refund both of them bcs we are not able to play together anymore …

Apologies for the inconvenience.
Please know that we are processing the support queue as fast as possible, I have looked into your request and it’s already been reported to game devs.
Regarding refund request support will be able to help you with that as well.

I have the same issue - i’m locked out of my rogue but can play my other chars. The connection crash happened after the Heorot / Rayeh scene after talking to Yuria in chapter 7. Please assist! @EHG_Caliph

Same issue here, above 12 hrs with this error @EHG_Caliph Torik_MM character

Hi Caliph,

any news regarding this ?
I didnt get any informations on my support ticket till now.

as you can see, i’m not the only one !

thank you !

Did you get this resolved? @h8uall

Nope… u?

Nope…

its fucking working :slight_smile:

How did you get this fixed or did it just randomly fix it self? My friend has tried everything and can not login. Everytime he goes to login it just kicks him and says lost connection. We have uninstalled and reinstalled like 50x, last night we refunded the game, deleted everything, re-BOUGHT the game, it worked for 15 minutes before kicking him out again and now the Lost Connection is back everytime he goes to login… WHAT THE F!?

This is pretty much what happens to me as well. I went a few days without any issues and was pretty happy because I was like, maybe it’s finally good. NOPE! Today, same issue, lots of disconnects. Can’t play for more than about 15 minutes. It’s beyond infuriating! Haven’t done anything different between yesterday, the day before and today so it doesn’t seem to be anything on my end as far as I can tell.

“Try turning a VPN on, but also try turning it off.” - kewlest suggestion to fix client issues ever.