My Account
× My Account Forum Buy Now

Last Epoch Forums

[Linux] High ram usage

Hey, so i have a ram proble.

Install : I play the linux version of the game on POP_OS! (based on Ubuntu 22.04), installed through steam. There are no .exe in the game folder, so i am sure the game is not running through Proton.

My config : I have a AMD Ryzen 5 5500, a gtx 1060 6Gb, 16Gb of ram DDR4 (3200Mhz).

Description of the problem : When i launch the game, i have a “app not responding” window (every time). If i wait 15-20s the game launches and i can play. The problem is, on the first screen, where you click connect, i can see that the game is using 11-12 Gb of ram (on a menu with 4 buttons) on verry low settings and up to 14Gb of ram on medium/high settings.

After 2-3 hours of playing, the game end up eating all the ram available and my computer crashes. Sometimes, the game will close, sometimes i will have to hard-reset the computer !

I asked in the in-game chat how much ram the game was using for people and the answers were around 3-8Gb in high-verry high settings. There appears to be a problem here.

Ram consumption checked using htop commandline AND mangoHUD monitoring tool.

Files : le_graphicsmanager.ini (488 Bytes)
System_info.txt (159.0 KB)

There are varying reports of excessive RAM usage on linux but I dont think anyone has been able to pinpoint the exact factors that influence this… Some Linux users have no issue while others (like yourself) have the problem to the point where it seems like its got some sort of memory leak…

In-Game settings definitely affect RAM usage, but it could also be driver related, game version, mesa drivers, vulkan and even how the OS distro is handling things - even very specific combinations of driver versions… On Windows there are no memory issues similar to what you are describing - the only time anything similar to this has happened is due to old drivers.

A few things…

  • Can you include your player.log - it may have debug information that could explain what is specifically happening on your system that is using up the excessive memory. It should also include what graphics subsystem is running/versions etc…

  • Can you attempt to run the game under Proton (Steam compatibility settings)… The Discord channel has many people saying that they have no problems running the game using Proton - some even say they get better performance using it.

  • Please disable any and all overlays while testing LE… these do cause issues in some instances. (This includes Steam Overlay).

  • A quick check of your system info shows that there are newer Nvidia drivers (515)… Please can you double check all drivers to make sure that you are running the most recent of anything that could be related…

  • Please change your TerrainQuality = Medium to VeryLow - this is the one setting that uses the memory loading textures etc… Temporariliy set it to VeryLow to make sure that everything is on the lowest possible setting…

  • Make sure that you Verify the Game file integrity via Steam - its possible that your install might be messed up…

Thanks for the quick answer !

So, to answer a few of your suggestion :

  • The terrain quality did not affect the ram usage in my tests !
  • I tried the proton version, the steam linux version and the EGH launcher linux version. I had 2 player logs (attached at the end of this message)
  • The proton version uses just as much ram as the linux version, but it also uses 100% of my VRam (6Gb). The fps are far worse.
  • The EGH launcher version has the same performances as the Steam version.
  • I disabled all overlays and monitored the performances with htop and nvidia-smi, nothing changed.
  • I tried to verify the files integrity via steam, no problem. I deleted the game, the ~/.config/unity3d/Eleventh Hour Games/Last Epoch/ , and reinstalled, the problem persists.
  • I’ll try to update the drivers later. At the moment, the latest version is not available in the official repo of my distribution and i don’t want to brick my install because i tried to install my drivers carelessly !

Logs : Player-prev.log (963.6 KB)
Player.log on google drive because the file was too large for the forum

Hey there…

(aside: you can zip the logs)

As expected the proton version seems to be a mixed bag. I have a feeling its definitely distro related somehow…

The Player-prev log - is showing FMOD & sound library errors which dont appear in the Player.log…

Unfortunately both your logs are flooded with the Logitech keyboard wrapper errors… The game is meant to ignore these but it seems like this is a problem on Linux.

DllNotFoundException: Unable to load DLL ‘LogitechLedEnginesWrapper’

These errrors are repeating over and over and accound for virtually your entire log - the normal debug messages are simply not there because of it.

Without any other input, I would guess that this likely involved in what you are experiencing - either the game is just giving up after a while or its whats involved in the runaway RAM… Its unfortunately not something that I speculate on as I am not an EHG dev.

Another linux user was reporting crashes, and his log looks virtually the same - flooded with the logitech drivers - He was also using an Ubuntu based distro but with an AMD GPU.

Looks like EHG may have to look at this one…

@KissingAiur - sorry to ping you on this, but this is another Linux user with the same logitech errors flooding the player.log and experiencing high ram and instability… Hope you have a moment to see whats up.

Thx for your detailed answer, for the keyboard, i might be guilty of using a IBM model M 1991, so it’s strange to have Logitech drivers issues. I’ll check if there are better drivers for this dinosaur of a keyboard xD

Lol… havent seen one of those is forever. Damn fine keyboard for typing… but I doubt its got anything to do with the issue… I think its just the game not gracefully realising there are no logitech drivers installed and it seems that (unlike on windows) you cannot disable it.