Game randomly crashing - Linux

Hello. I am playing the native version on Ubuntu 21.10. The game keeps randomly crashing. Sometimes it crashes after 5 minutes and sometimes I can play for few hours without crashing. I tried different graphic setting presets (Ultra, High, Very Low), but the behavior is the same.

PC Specs:
Intel Xeon E3-1231 v3
AMD Radeon RX 5700 XT
16 GB DDR3 (117.6 KB)

Hey there… Welcome to the forums…

Looks like you may be struggling with the same Logitech error that quite a few Linux players seem to be having recently… Devs havent confirmed this is the cause of crashes but given that you are now the 3rd person (at least) having the same log messages, there is probably something to it.

Note: Irrespective of the log message, your CPU is borderline - its a smidge faster than the minimum CPU required for LE so you will most definitely need to be very conservative with your in-game configuration to play LE. The game is very CPU bound in certain situations and this will cause a problem for your CPU. Your CPU is also TOO SLOW for your GPU - to the point where you are likely to experience the negative effects of bottlenecking - i.e. setting the game at a level the CPU might handle vs what the GPU can handle will cause problems with the GPU waiting for the CPU. This can translate into instability - especially if the performance of the two are significantly different as is the case in your situation. You can obviously mitigate this by increasing resolution to load/slow the GPU etc, but your CPU is still going to struggle no matter what…

Your log is flooded with the following error…

DllNotFoundException: Unable to load DLL ‘LogitechLedEnginesWrapper’: The specified module could not be found.

The following bug reports have the same logs as you and are experiencing random crashes over time - irrespective of in-game settings or hardware.

@KissingAiur - another ping for a Linux user having the exact same Logitech messages flooding thier logs and having crashes…

Hello. Thanks for the reply. I found RGB settings under Gameplay tab in the settings at the bottom of the page. I clicked it, and it didn’t seem like anything happened. But after restarting it was turned off and the log isn’t flooded with the same message anymore. It crashed once on ultra settings, but i changed it to very low and so far no problem - thanks for the advice on my cpu. I will report if the crashes start happening again.

Thanks for the update… especially about how you seem to have stopped the problem - other linux users dont seem to be able to toggle the setting off… but I am not sure if they restarted between setting change as you did…

Ultra… yes, if you are going to crash due to performance stability issues, then using Ultra mode will do it… I play on very low and honestly dont mind the lack of eye-candy… I much prefer stability… Hopefully the next patch will optimise things some more …

CPU… sure…

Hey, just wanted to say that on my side, i can’t un-tick the RGB option (clicking on it does nothing). Tried both in game and on loggin screen !

@Dassem345 : if you know how to do, it would be cool if you could share with us your ram usage in game (when in a city, just alt+tab, open a terminal and type “top” without the quotes then press enter. If you’re not confident in trying this, that’s ok x)

Quick idea… no clue if this could help.

Fiddled around on Windows, and the RGB setting is not in the game setting file so I searched through the windows registry and found it there… I am wondering where this information could be stored on Linux… I am definitely not a linux sysadmin to that level of configuration so I have no idea but perhaps it could be found & manually edited to force it to be disabled? Assuming these toggles even exist somewhere on Linux…

On windows the registry settings are:

I have ~25 percent RAM usage in town and ~28 in combat on very low preset.
I managed to reproduce the turning off of the RGB settings. I clicked it few times with left and right click and then restart. It took a few restarts to do it.
The game still keeps crashing. The RAM usage during the crashes stays the same as in normal gameplay. Today i had 3 crashes like 5 minutes in and twice after 30 minutes. I saved few logs.

Player1.log (67.5 KB)
Player2.log (43.0 KB)
Player3.log (41.2 KB)
Player4.log (47.5 KB)
Player5.log (110.7 KB)

UPDATE: In the location .config/unity3d/Eleventh Hour Games/Last Epoch (same as log files) there is file called perfs. On line 17, there is the RGB enabled option. Set it to 0 and it turns off.

Regarding your crashes… Can you check what version of the game you are running through Steam - i.e. are you using the native or Proton version?

Some linux users on Discord swear by the Proton version but maybe its worth trying each?

Also, have you tried checking your Mesa drivers? I see that the shows 22.10.2 but your player.log is showing 22.2 devel… Perhaps try updating these? I know that Linux users have found that specific combinations of drivers and apis can be very important.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.