My Account
× My Account Forum Buy Now

Last Epoch Forums

Game crash on login from Steam and unable to link Steam account

  • Bought game on steam, crash on splash screen.
  • Restarted PC, started game on Steam again, made it to register account screen but crash on submission of registration
  • Decided to login via Last Epoch website, which is successful after verification code via email. However, account does not think I own the game.
  • Cannot see option to link Steam Account on My Account page in last epoch website (Steam Client was open).
  • Launching game from Steam now crashes on splash screen and sometimes causes Steam to crash afterwards
  • Launching game directly from exe does not cause a crash, but since the account does not think I own the game, I still cannot play.

Please help.

Player.log attached, there are no files in the Crashes folder.
Player.log (31.8 KB)
Player-prev.log (30.0 KB)

Hey… Welcome to the forums…

Sorry you are having hassles…

Account related issues need to be dealt with directly by EHG… if nothing below works then you will have to contact them directly.

First thing to do with any crashes through Steam is to verify the game files. Very important that you do this more than once just to make sure…

Obviously make sure you are online when trying to launch the game and that you dont have any firewall issues - these can crash LE at the login phase (basically a timeout).

As the first crash is on the splash screen this could indicate a graphic driver issue… I am going to assume that you are running a system that at least meets the games system requirements so you need to make sure that you are using a recent graphics driver… something from the last 2 to 3 months… For Nvidia, dont use driver 466.77. I do not recommend using the latest and greatest driver - especially if you have older hardware - but get something newish…

Also … with a 1070… Do NOT attempt to run the game at its maximum in-game quality settings… Use medium and be sure to enable a framerate limit the moment you can get into the game.

According to your player.log, there is a system out of memory error just about the point when LE tries to login - I cannot obviously provide any further info on this because I dont have any more info on your system specifics. You didnt provide your dxdiag file or in-game settings so I cannot check various things like:

  • see if there are any memory related issues on your system… I would suggest running some memory testing to be sure something odd is not happening on your system.
  • what OS or OS patch you are running - make sure its at least 19042 or 43 for Windows10
  • if the diagnostic section (end of the dxdiag export) shows any specific problems on your system that could be contributing to LE issues. This is especially important based on the info from the player.log

Lastly, while testing, make sure not to run any other applications to eliminate them as a possible cause of issues. Anything - doesnt matter how obscure or irrelevant you might think it is. This includes things like streaming apps, graphics overlays like Steam/Nvidia etc… temporarily just dont use them.

Thanks for the detailed reply, much appreciated.

Steam Account has now been linked, and I can get into the game. However, the game still crashes upon entering the 2nd area.

  • I have downgraded the driver to 466.27 and also tried the latest version, 471.11, no difference observed
  • Game settings are all Medium with FXAA running at 1080p. If I run at native 1440p, the game crashes immediately upon loading the 1st area
  • Limiting the FPS to 60 makes no difference
  • Running the game in Full Screen vs Maximised Window makes no difference
  • I don’t believe I have memory issues
    • I have run the Windows Memory diagnostic tool, no errors reported
    • Prime95 with Blend test seems to run fine
    • Path of Exile, Borderlands 3, Metro Exodus and Mass Effect Legendary Edition all runs fine without any crashes at 1440p.
  • No other apps running

Please find the DxDiag and the latest player.log attached.

DxDiag.txt (77.8 KB)
Player.log (71.9 KB)
Player-prev.log (66.0 KB)

Hey… So getting into the game is a step in the right direction at least.

Can you confirm that you did the Steam file verification - this is important as corrupted installs cause no end of problems… Need to be sure.

Hmm,… this is indicative of the performance related instability in LE at the moment… Try the following: set your game to 1080p, 60fps framerate limited (remember to check the checkbox else the slider does nothing), ALL in-game settings to very low or disabled or the lowest possible option (very important). If the game works in this “base” config then you definitely have the known issue and have to be conservative with your settings. You then need to slowly up the resolution and then increase the FPS (while monitoring your GPU usage to ensure that its averaging something decent and not in the 80-90% all the time). and lastly you then up individual graphics settings (still monitoring your GPU usage)… Honeslty tho, with a 1070… I would recommend you just stick to the low settings on the resolution you want to play at and keep the fps capped at around 70-80 fps for best stability - imho the eye-candy isnt really worth the stability trade off.

Are you sure you enabled the framerate limiting checkbox? Limiting the framerate is very noticable as LE will max out a GPU if you leave it unlimited and this makes the game VERY unstable and it can crash loading new maps or freeze (a few seconds) for no apparent reason during play.

Player.log… Ok. this one is different… it still has the memory error but it comes after a D3D11 Error - also related to memory issues and then it crashes with System Memory issues… This could be gpu driver related or perhaps something fishy with your DirectX implementation… You may have to do a full driver uninstall via Windows Safe Mode (or use something like DDU) to make sure that the correct drivers are installed and not corrupted.

You havent provided your le_graphicsmanager file so I cannot check, but what graphics card texture memory options you have chosen? Chose the lowest option for testing… and if you can, monitor your GPU memory usage and see if its maxing out (again, bad).

The player.log is referencing a Crash folder in the Last Epoch - can you check if there is one and an error log file? This can help trace the problem.

Dxdiag info…

Most things look ok re OS patching, drivers etc so I will skip the diagnostic section at the end:

  • The LE apphangs are there should be an error.log generated in a crash folder - please check.

  • MemDiagV1 logs are reported that as far as I recall are informational - i.e. they confirm the test ran - you can see this in the normal Windows Logs… However, is there any way you can run something that tests from bios or bootmode? like Memtest? - this is a much better way to make sure on your ram.

  • WARNING IMPORTANT ISSUE dwm.exe has crashed at least once… This is the Windows Desktop Manager service that controls all the fancy windows rendering, hardware accelleration and 3d parts of the OS display… It has NOTHING to do with LE but could be causing LEs problems. There have been at least 3 people I know of that have had this error on their dxdiag report and all three have had inexplicable crashes when trying to play LE… After a lot of back and forth with updating drivers and running things like Windows System File Checker and doing driver reinstallations in safe mode, 2 of these where resolved by reinstalling Windows 10 - no more dwm errors and LE works perfectly… unfortunately there was no way to tell exactly what caused the problem because of the reinstall… If this is what is messing with LE, then this could be a problem to find the solution. I do not recommend that you leave this particular unresolved - irrespective of LE working or not.

I would suggest the following:

  1. verify the steam game files if you havent already.

  2. Do the testing with the lowest base in-game settings.

  3. because of the d3d11 errors & the dwm.exe error, I would suggest you run the Windows System file checker at least once… and the run Windows Update and check if there are any optional or deferred updates.

  4. Consider doing a full graphics card driver uninstall and new clean install either manually via safe mode or using a tool like DDU.

  5. Check your windows logs for the dwm.exe references and try and make sure that whatever caused it is resolved/unistalled/patched etc. Dont leave this error unattended - irrespective of LE.

  6. Check your system BIOS drivers etc for updates that could be memory related…

Thank you for taking the time to look into this.

Dropping all the settings down to low and enabling vsync seems to have made the game crashing issue go away.

Question on the DWM crash recorded in DxDiag. I’m guessing that’s collated from another log somewhere else in the system? So it could be from a long time ago?

Glad something worked…

I would suggest that you not use vsync tho… the framerate limiting does effectively the same thing, but players have noticed that vsync is doing odd things so the framerate limiting is a better choice… and obviously framerate limiting gives you more control where vsync will just peg at whatever your monitor refresh rate is…

The dxdiag diagnostic section at the end of the file shows the last 10(?) most recent errors on your system… Not 100% sure on that but its the most recent errors in an FIFO order… You should be able to find all of this information in the Windows Event & System logs - some will be warnings, informational or critical errors… You should be able to find the dmw error in one of those to find out exactly when it happened… .and yes… if your system is pretty stable and not having issues, then it could definitely be an old error that has subsequently been corrected by an update or something… It could also have happened numerous times but older ones no longer show up in dxdiag… Key thing is to make sure that its not happening again.

I tested limiting the framerate to 60 but that caused very noticable screen tearing which is why I switched to vsync. Luckily I haven’t encountered any weird issues, so I think I’m going to stick with it for now.

Found the dwm warnings in Event Viewer. There’s only a handful and the very recent ones seems to correspond when LE crashed so I’m reasonably happy it’s not a regular occurrence.

Thank you again for the very helpful advice, it’s been a pleasure interacting with you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.