FPS incredibly unstable after 1.0 patch

Same here. I love this game but it became unplayable. 20fps or less in monoliths. Makes me sad.

1 Like

I honestly have been going insane with how bad this game performs since 1.0. Thinking some setting or my rig is to blame. It truly is a tragedy the state of performance right now. Add another to the 20fps crowd that can’t play any fun builds or blow up big packs with out half-sec freezes. I am ready for a nice long break.

1 Like


Someone on reddit recently wrote a possible solution which actully helped my fps loss
(so far).

Nvidia users:
Nvidia Control Panel → 3D settings → Program settings → Image scaling → ON (30% instead of 50 or 100)

I’ve only played 4h with this setting at fixed 60 fps but it never goes below 55-60.
The ingame quality decreases a little but totally worth it at this point.
Going to try with my normal 170 fps later today.
If the reddit user sees this, thank you for solving my fps issue at least <3

1 Like

This does nothing for me. Sadly.

But let´s be honest…I´m tired of trying things to fix a Problem thats clearly on EHG´s site.
What sucks the most is that there is not a single word from them. No communication, no Infos, no Help. And that is just ridiculous.

1 Like

Ye i agree.
Some patches ago my monitor started to shut down randomly.
Took the pc apart, cleaning it, bought new hmdi/displayport cables but the issue remained.
Ended up buying a new monitor as there would be no way a game could cause that issue.

Well… seems like that patch made my “old” monitor go crazy somehow as it works properly again now.

Yes, this is ridiculous. The company that was supposed to be a model of transparency and communication says nothing. I suspect they just don’t even know how to fix it. I’m tired of releasing games that aren’t optimized for launch and I just stopped playing.

I thought it was me. I turned off all programs running in background and still go from 165fps to 80fps in spikes.

originally, many Elemental Nova cause serious fps drop , from 78->33 ,after changing master quality to low, everything is smooth now…and doesn’t look any differences…dev should really stop doing this kind of thing

I have a good news!
I saw mention in official discord about fps problem, from community manager. Here is a text:

I just want you to know the team are working this, it’s not being forgotten or ignored because it doesn’t affect everyone - this weeks patch has a fix that the Devs are hoping will help with the FPS in Monolith issues, though if it doesn’t help as much as they want - they have another pieces of the puzzle towards fully fixing it


Thank you for sharing this. Let´s hope for the best.

So 1.0.5 is already out, there are some improvements,

Improvements have been made to Monolith visuals and performance along with several bug fixes

game is way better and playable, at least I got stable 60 fps! Still some minor fps drops, also are drops when with mouse over items.

1 Like

Yeah, I´ve tested it since they dropped the Hotfix for the Filterproblem and it feels better than before. I still get drops to around 25FPS in some Echos but overall it feels smoother. Grass density still bypasses Graphic Settings though.

I still have drops to 13 fps, but not so often…

Still unplayable for me. Did one decent echo with 70 FPS, not great but hey, at least I can play. Then I did a second one and it froze when there were a lot of enemies on screen. Fractions of one FPS. Zero improvement.

Still no LE for me, I guess.

1 Like

Its been how long since 1.0, and this is still a very annoying issue. Have a very good pc. This should not still be happening. Constantly loosing 20 - 30 fps while in game moving around the map. I refuse to play this game until you fix it. This is a massive problem, that many are suffering from. PLEASE. actually make this a priority, and get it fixed.


Hi All, just want to add that I have a massive drop of FPS on my PC as well. Use to play on 170 refresh rate with drops to 120 and now dropping down near zero giving massive lags. Please fix it LE Team …


For the first 5-10 minutes the game runs smoothly and without fps issues. When I just start running monoliths I get 200+ fps. After just an hour of playing, the FPS drops to 100 on an ongoing basis. After another hour it’s already about 40. And all this time there are random drops from 200 to 50, etc., depending on the density of the crowd and the effects. Only restarting the game helps. I noticed that after an hour of playing, it consumes 30 GB of virtual memory out of 36. While real memory consumes around 7-8 GB. Devs just do something with it. Thank you.
My specs:
R7 3700X
32gb 3600MHz

Having fps spikes/ drops and game stalling in high density fights within monoliths. Currently using medium overall settings with advanced turned either off or very low. Vsync and AA off. Same results even with different graphics settings. Issue happens usually after 30+ mins of gameplay.

I9 13900k
RTX 4090
64gb ram
980 pro.

1 Like

I hope devs are aware of low performance and will fix it soon. Sometimes it’s a bit unplayable in monolits. Here is example of fps dropping under 60fps:

I have 5900x
32GB Ram 3700CL16
and it runs like Diablo 4 with RT on ultra details in 4k

This help[ed me.

  1. go to your Task Manager in windows
  2. switch to “details” tab
  3. right click on “Last Epoch.exe”
  4. select “Set Affinity” and uncheck “cpu 0”
  5. click “ok”

Kudos to Amos from Steam, i just copied what he wrote. I play Wraithlord and screen can get cluttered, a lot, and my fps would go from 100 to 20-15 in intervals or when Wraithlord eats other minions or when grass and all of that mix, nightmare xD. Now it’s stable 100 no drops when eating nor when in grass monos. Cheers, hope this helps.
Edit> forgot to mention that you need to do this every time when starting the game.

1 Like