Disconnected from server. again, and again, and again

Game was purchased about a week before multiplayer launch. worked fine. multiplayer is launched and the first day (mar 9th) and i log in and play for hours no problem. never had a queue. a friend comes on, and it takes him awhile to get online. we party up and play for a bit. he logs, and i create a new char and play it to like lvl 10. then i log for the night. next day he’s online and we join up and start playing. in like about 30 mins I get disconnected from the server. he is still in game. i come back, party up, and then in less than 5 minutes im disconnected again. try several times, same result. give up for a bit, go hunting for info to see if others are experiencing and dont find anything. next day same thing. no idea how to resolve this. game was bought thru steam, so no merging was involved. i know i dont meet recommended but definitely above required condition to play game. win 10 here, samsung SSD. have tried multiople installs of game, its the only game in my library at the momment. even reinstalled steam. have tried all kinds of trouble shoot. turned off overlays from win 10 and nvidia. given folder exclusive rights against win defender. cleared steam casche, downed from different server on and on. (like this post) still as of today i cant stay in a game for no longer than a few mins. any help or suggestions would be appreciated.

I’m in the same boat, I can only play for 10 minutes. :frowning:

yep still the same here almost a week later. was hoping the patch/hotfix would have helped. while in game for the couple mins before i get booted, my ping is like 46 to 51. it now shows im connecting to east. im in central time united states
. made a comment over on twitter, and the 11th hour jerk over there said i needed to post on support here. well i have, and no response.

Same for me. I just attempted a refund. Unplayable and ZERO support. I’d rather just wait for Diablo 4.

Throwing my comment in for this issue, too. My wife and I have had no luck playing together since 0.9 released, even after the major server issues were resolved. We’ve tried playing every day since launch, and every time there’s like a 50% chance of one of us d/cing during every loading zone, so we can’t play for more than a few minutes before getting a d/c. Playing solo has been completely fine, no connection issues even with online characters - and getting IN to the servers isn’t a problem, either - it’s just constant “lost connection” errors, specifically during loading screens and when we’re partying together, that are the problem.

I filed a support ticket a few days ago but got a generic “we’re aware of server issues” response, which makes me a bit worried that this SPECIFIC issue is getting lost in the sea of general server issues. I totally understand things falling through the cracks, thanks to the rough launch, and this issue definitely doesn’t seem to be affecting everyone… but for those of us who do have it, multiplayer is just completely unplayable, which kinda spoils a lot of the excitement for 0.9. Really hoping this issue will be acknowledged and fixed soon, we’re super excited to be able to play together, as we’re both huge ARPG fans and have been eagerly awaiting the multiplayer patch for years!

having the same issue here, i sent an email to support i think about 2 weeks ago, no response and am still waiting for them to adress this issue.
currently this is unplaybale and its ashame. been waiting for so long for multiplayer.
cant even complete an echo…

I too have been experiencing many disconnects… :rage: