Beta 0.9.2b Patch Notes

Okay so that’s why my Spellblade lost his offhand lol, I thought I’d taken it off randomly at some point and couldn’t find it.

Nothing to say about the Temporal Sanctum loading bug in offline ? ok maybe it’s solved alone, i will try a key

We were doing quest echo and not normal echoes. And I used to play with another friend that completes it for both of us as long as we both have the first and second quest echo completed and sufficient stability. Also I asked around in global chat and pretty much everyone said it should complete for both of us.

Like I said, it used to complete for both of me and my other friend I used to play few months ago. I can guarantee you that even doing the first or second or even the last quest echo even my friend was the one who started it, it all also completes for me, having a check mark on these (except no check mark on 3rd one ofc).

We both have the same progress. Neither of these happened to us when we’re unlocking echoes together as we level up since like I said it completes simultaneously for both of us. Otherwise I would’ve made this kind of post back then if it was really “intended”.

As for the bridge:

  1. Using our Rune master character, all bridges were unlocked when we entered the MoF together for some reason. So it’s kinda harder to tell if the same would’ve happened just like on our first character. And so impossible to tell if “that” bridge would’ve unlocked.
  2. Using our first character (both sentinel base), it was even more buggy. Not even the starting bridge to get to Fall of the Outcasts unlocks. Even after completing Fall of the Outcasts timeline, none of the bridges unlocks either. Though after several restarts and experimentation whoever gets to be the party leader or leaving the party first etc, then it finally unlocked.

Idk, I might be missing some piece of information here, or some patch notes I missed.

you didnt fix the locked monoliths? So first you lose my offhand and now i still cant play? MY MONOLITHS ARE LOCKED LE -64 ERROR . I PAID MONEY FOR THIS SO LET ME PLAAAAY

What’s going mate? I thought you were gone


My main note about the empty Rune Prisons, for what it’s worth, is that for me it has ALWAYS happened with 100% consistency when the Rune Prison was immediately on-screen as soon as I loaded into a Monolith. It almost feels as if whatever guarantees no enemies spawn on top of you during the load is removing the nascent enemy from the prison. :V

Can’t wait for this one so I can play with the new javelin unique! Hope it gets fixed soon!

There was a post a week or so ago about this happening and one of the Devs stated it should go into your stash or Gift box or it’ll drop on the ground. If you didn’t see it in your stash or on the ground maybe check your Gift box just to see if it might be there.

Sad. There are already 50+ Lost connection reports in the Forum but still not in this list for them to fix. How come they are ignoring this issue even though lots of players already reported it? Weird because our money is completely wasted because we cannot play the game
Search results for ‘lost connection’ - Last Epoch Forums

you are not alone. They not even put the issue on their list of what they are working on. Same here very disappointed on them

Glad to know the transition between scenes is being fixed. It’s more than the transition time actually. The more pressing issue is whenever the character enters a portal / zone, there is nothing at all that tells us the scene is loading. We still can move around the character, wondering the game is not responding. And all of a sudden, the destination just pops up. I mean, I’m even fine with waiting a few seconds for entering a zone. A simple loading icon / test / splash screen will make the experience so much better.

Yes, that’s the transition time they’re talking about.

1 Like

Here is the relevant part of the original 0.9.2 patch notes

Here’s a thread with a message from Judd on Reddit, responding to somebody experiencing network issues:

If you check his message history, Judd’s been contacting a number of people on Reddit. It sucks that you haven’t heard anything specific here, but its safe to say they are aware of intermittent issues for some players and investigating

Hope this helps

1 Like

It’s not in the notes, but I hope thru patch magic my Rogue is now fix and I can play it again :smiling_face_with_tear:

Just checked, Rogue still not fix, sad times :skull_and_crossbones:

Seems Rogue is abandoned ATM to say the least. There’s not even a mention in things they are looking at.

Melee rogue with rotating Shurikens for armor boost and shred is totally broken right now. The second time you cast it, it just doesn’t work anymore, manually or through shift, doesn’t matter. Anyways the “online” animation for rotating Shurikens… wth.

And there are a bunch of other bugs/issues regarding rogue. Even the animation issues happen now in the offline mode.

Any idea why my UI text is garbage now on certain UI elements

made a thread with screenshot, not affecting my game but its just triggering mainly due to the fact I dont know how to fix and never had this before ever

It does look odd that there’s a grey/white box around some of the text/numbers (took me a while to spot the issue on my phone). Unfortunately I don’t have a clue about it, sorry.

I appreciate you taking the time to look though. I guess ill do a fresh install. Seems like Unity conspiracy to force me to reinstall the game :slight_smile:

It’s not a “you” problem. It’s a mistake we made with font generation. We will fix it.