My Account
× My Account Forum Buy Now

Last Epoch Forums

[0.8.2] Crash on Startup Standalone, then also via Steam

As the title says, since the patch the game crashes on startup for me with the same error every time. It also has the same error in both the Standalone client and the Steam client. The current downloaded version I have is the Steam client. Here is the timetable of events so far…

I was using the standalone launcher flawlessly. I played on medium graphics settings and was at around level 60ish on my first character. I only bought/downloaded the game a couple of days ago. Sadly, I was really impressed and enjoying it immensely up to that point as well…

After the patch I got a ntdll.dll error and the game exe crashed every time. So, the launcher ran ok with admin elevation, the secondary launcher file ran ok, but then the actual “last epoch.exe” file itself was crashing every time with a windows error box “Last Epoch has stopped working” (see the LEdllerror.txt file for a copy of the text contained).

I uninstalled the standalone by using the uninstall file created in that directory, then I cleaned the registry (I used cccleaner disk space & registry, then after Wise disk cleaner & registry cleaner), rebooted & re-downloaded the client all over again. Re-downloaded all of the game files (8GB ish) for the second time. Same exact issue. I then uninstalled yet again, cleaned registry yet again using same process etc.

I then linked it to my steam account, and installed it via steam. I thought that the ability to verify game files might help… First load, same error.

I changed all of the graphics settings to verylow via the config file. When it was working previously, I had already disabled shadows, most settings were on medium, I had 60fps max framerate set, verticalsync off, and antialiasing on TAA.

I quickly started it again via the desktop shortcut, and miracle of miracles I got to the loading screen with the dreaded LE-13 error so I opened & sent in a ticket. This was ONLY 1 of 2 times I managed to get as far as the login screen though in around 25 attempts so far.

Since then, every attempt to load again crashes with the same ntdll error.
Last night I spent well over 6 hours working on this, not happy, but sadly pleased to learn I’m not the only one with an issue. Something that they’ve done with the graphics updates I suspect is causing this…

The reason I suspect it is a change to the graphics are the entries listed in the crash logs. They seem in a lot of these posts to refer to a line 366 constantly, and arguments missing. Although my current nvidia driver version is now back at 452.09, I should point out that I have also tried the lastest 466.47 release, then the previous “latest stable” 466.11 versions for my GTX 1060. Every time I tested that out, I did a clean install using DDU. So, I have eliminated the possibility that it was due to the graphics driver version. Perhaps the devs can make more use of that information?

I have no Citrix software on my PC, nor have I ever had any. I also have never installed Teamviewer. Both of these were referred to on the internet as possible causes of the mono.dll path problem which appears in diagnostic logs. I am pretty convinced this is a coding issue caused by modifications in the patch itself rather than something purely client side. As I refuse to downgrade to Win10 Telemetry Edition, I still use Win7 x64 Ultimate and as such the game was running in DX11. I am taking a stab in the dark from looking at the crash log and think that maybe something in the new patch is not working properly with DX11? Again, perhaps this is something the Devs could use as info? I know there are still a load of us out there who refuse to go to Win10, so was this release tested using DX11 & Win7 as well or merely forked from a Win10 DX12 setup?

I am attaching quite a few diagnostic files, and I hope that this will help the devs. I really want this to be fixed, rather than having to ask for a refund. Any more diagnostic files that might help, please ask away. I will link to this thread in my reply to the support ticket email I was sent.

LEdllerror.txt (584 Bytes)
le_graphicsmanager.ini (489 Bytes)
Player.log (6.3 KB)
Player-prev.log (5.6 KB)
version.txt (5 Bytes)
Crash_2021-05-25_121007727.zip (31.1 KB)
DxDiag.txt (38.8 KB)

1 Like

EDIT, I mentioned the wrong line number that appears in mine & other player logs. It is line 334… Apologies

Hey, Welcome to the forums…

Sorry you are having such hassles after previously enjoying the game…

Without going into your detail, I am wondering if you are struggling with the same login crashing, startup issue that the devs have confirmed they know about and are dealing with… Especially as you have successfully played the game before my gut feeling is that you need to make sure that its not an external factor messing with you…

If there were no active login crashing problem then I would delve into your specific detail and try to help but I think you should hang tight until the devs respond with a fix/further detail on the login issue.

It’s not a login issue per se, as I have only managed to get to the login screen twice (as mentioned above in detail).
I’ve also diagnosed as many “external” issues as I can and I’m pretty convinced, after spending many hours now, that it is a coding issue in the patch itself causing a conflict.

I appreciate your quick reply, but it doesn’t help me much as in order to reply meaningfully you DO need to “go into the detail” of my very long post above. In that detail, I have specified detailed steps that I took to troubleshoot the issue as much as I can from my end. Having been a fair IT geek for much of my life, this comes back to the same debugging scenario as usual. Look at the problem, identify the environments before & after, identify the changed variables and you inevitably find the root cause. Not immediately the reason, but certainly the culprit.

As you rightly point out, I think that this is something that needs to be fixed by the devs who wrote the new code. I don’t think that these crashes are going to be something that is able to be diagnosed & fixed by the community (as helpful as it appears to be) :smiley:

Add: Also tried setting Antialiasing to OFF as a hail mary…
Same error.
Someone please send Valium…

Understand your reply fully… I was running out the door when I saw your post so I thought I would just drop a quick reply…

My reason for suggesting the possible correlation is that I have been around for a quite a few patches now and sometimes LE has totally unrelated issues that inadvertently change/resolve other things… So while it may not be the login process specifically, it may be that the login process failing is borking something else and causing the crash… Only a dev or someone from EHG would know the ins and outs right now so I can only guess…

The other reason for my quick comment is that it seems you have read through the forums (probably some of my older posts/suggestions too) and have done pretty much what I would have suggested anyway…

So if your problem is not the login related then I may have to light up my socks to think of another possible cause… :stuck_out_tongue_winking_eye:

Cheers mate, sorry if I seemed a little abrupt. I’m feeling a little “frayed around the edges”…

At the moment I am at the stage of seeing if the mono.dll mentions in the logs are a red flag relating to the unity engine. I noticed I had no mono.dll file on my system at all, so I’m researching that and whether or not to actually install mono itself to see if that corrects anything.

Think I might need to take a break in a bit though as my head is about to explode.

P.S. It would be nice, if when they get a second, a dev could chip in on this. I do like a good research mystery, but I feel as though I’m doing a ton of phd unpaid research at the moment for a thesis on Nuclear Physics…

1 Like

:+1:

The problem with the logs are that they include a lot of the debug stuff so its very hard for us as players to figure it out unless of course you happen to be up to speed on cross platform Unity development. Tracing the errors in the logs will drive you bonkers and likely lead you down the garden path to some unknown destination… I have given up with that… I just give it a quick skim to see if something is entirely unfamiliar compared to other logs and work from there…

The error logs in the crash folder (if it managed to create one when it crashed) are usually more useful imho.

Taking a break is probably a good idea… Let the dust settle and EHG might even have dropped a minor patch or two - if they find something critical they are usually quick to do so and this 0.8.2 is huge so while I dont work for EHG I figure that they will probably be chasing their tails after this patch trying to fix new bugs & the login issues so its unlikely they will chip in here… From experience I can say that someone will likely see your post but probably will not respond till they actually have time to do so or maybe even a decent reply/solution.

Yeah, problem is that I’m reluctant to take a break as I only bought the game a couple of days ago and literally only had just under 2 days of playing it…
So it’s like getting your first car, only to be banned from driving less than 48 hours later lol

I know… you just wanna play with the new toy… :stuck_out_tongue_winking_eye:

Cant really offer anything to make you feel better other than putting my neck out there and saying that EHG usually fixes things pretty quickly and considering how many people are having the login issue I am sure they are sweating up a storm in some dev pit…

1 Like

Update:
I have tried chasing the “mono.dll” error listed in vain.
I installed the mono runtime to my PC - same error.
I then tried the unrecommended option of finding a unity generated version of mono.dll in both 32 bit and 64 but flavours and installing & registering them. Same error & crash.
I did then uninstall those dll files as even though I did some due diligence & decompiled them to look at the contents they were still from a 3rd party source.

I had a thorough look at the error logs and player log yet again and this line 334 keeps popping out at me. It appears to my uneducated eye as though some in game objects in the new game code are failing to be registered as DX objects within dx11 and are therefore throwing up the flag of the ntdll error.

This, again as a guess, would indicate to me that the new changes to the gui in this patch are not working with my setup Win7 x64 Ultimate SP1 and more importantly dx11. I am guessing that the game code using Unity 2019 was compiled using Win10 and therefore dx12, and that in using the Unity software to port that across to 7 & dx11 (which as I understand it) uses Mono to facilitate the porting to other OS’s including Linux) it is causing these errors.

So, in short, I don’t think there’s anything more I can do with regards to this issue from my client side. It is something in either the new code, or the compiling process that is causing this crash. I eagerly await the devs/programmers being able to examine the problems & come up with a fix.

Could I humbly suggest that at “Dev HQ” someone also uses a PC running Win 7 & DX11 to test out the standalone client (which should also solve this on the Steam Client).
Using a VM within Win10 to emulate Win7 will NOT be sufficient to throw up errors like this, it really needs to be an actual HD/SSD with only Win7 and more importantly DX11/.net installed on it.

There are many, many of us out there who (despite Microsoft) refuse to use Win10 Telemetry Edition and so despite the official “ending” of support for Win7 it still remains a large percentage of any potential customer base for any games developer.

(On a side note, I’ll go to Linux full time before I ever even spit on a Win10 installer. I’ve done repairs for other people’s PCs using it and I feel like taking a long shower after every encounter with it)

Installed hotfix with baited breath…
Same error. Still crashing.

I am uploading the error/log/crash files in their latest versions again, just in case anything has changed in them.

Crash_2021-05-25_233522063.zip (31.6 KB)
le_graphicsmanager.ini (493 Bytes)
Player.log (6.6 KB)
Player-prev.log (5.9 KB)
version.txt (6 Bytes)

Hope these help…

Damn… Just sat down to see if anything worked…

Is this with the patch that dropped 2h ago i.e. C not B?

Re your testing:
I am using DirectX 11 on Windows 10 - according to my player.log.
Telemetry… yes, it is unpleasant to have to use this.
LE does work on Linux :stuck_out_tongue_winking_eye:

EDIT: See the devs post on the issue…

Yes, it’s now path C I am getting the error on.

Interesting that it works ok on Win10.

While the game might be using DX11, on Win 10 you do also have all the files/patches installed for DX11.1 & DX12 installed as well. These DX updates are usually done via Windows Update, so you get those updates on Win10, whereas the highest level of update on 7 is for DX11.

I’m going to research if there’s a way to spoof update my DX on Win7 today and see if that makes any difference.

P.S. I don’t think that the issue you linked to is related. That and the other Issue are both related to logins. With this crash I can’t even get as far as the login screen for there to be an error. I have found on the Steam forums some other people with the same crashes, so I’ve asked them to also confirm their Operating Systems. I’ll bet a pound to a penny that they’re also running Win7 and never downgraded to 8.1 or 10…

Damn… the patch C had lots of updated items - not just the login - you can see the full changelog on Steam - so I was hoping for a solution there…

Yip - Sorry I didnt say 11.1
Yip - DirectX is no longer a separate update - only through Win Update

I dont think its Win 7 as there are a few people still using it… Granted, their problems were related to performance on very old hardware but they were dyill able to play…

The latest Unity version 2021.1 supports Windows 7 with SP1+ so the game should work on your system as Unity 2019.4 should work too… … Maybe you could even try using some command line arguments for the player (midway down the webpage) … no idea really perhaps you can force a particular mode that makes a difference or help debug more.

Really am running out of suggestions here…

EDIT: Considering your penchant for security… Is there something on your machine that is locked down tight that could be involved here? Admin modes… etc…

Maybe even try running the game in Compatibility Mode?

Yeah, as far as security, I have tried various permutations but as the previous version ran fine I think this is a red herring.

Today my plans are to use the latest versions of the Simplix pack to update my core Windows (I don’t use Win update & haven’t for many moons due to the crap they force). (Simplix give an alternative method of doing Windows updates without any telemetry patches or dodgy spyware installs, it’s great for those of us who got burnt a long time ago with the “force to update” patches that MS forced on Win7 users).

My next plan if that doesn’t work is to try and “dupe” a later version of DX onto my PC.

Your link to the Unity page provides some interesting possibilities, thanks for that. D3D11 does seem to be what is related to the issue, so after all of the above I might try and force the game to run in Vulkan and see if that works. If it did, then it would prove that it was indeed the DX11 that was causing the issue.

I am like a dog with a bone here and from all my analysis of the crash & player logs I am absolutely convinced that this is all caused by a rendering issue of new or amended objects contained with the major patch.

It would really be nice is just one tech support guy could chip in at some stage and at least let me know if I am on the right path to finding a solution to this. At the moment I feel a bit like an unpaid intern sat in a satellite office working on a full time job with zero communications back to my employer… I think I am chasing the right rabbit, but some confirmation from someone actually involved from the coding and compiling side would at least confirm or deny that. IF I could get that proof and then find a fix, it at least might prove worthwhile to anyone else who might find themselves in the same situation. This is the whole reason I am trying to document everything I am trying as a correction.

Actually, I guess another thing I might try if all of the above fails is actually installing Unity itself on my PC. Perhaps that itself might force correct/install any DX dependencies missing?

While reading your reply about Windows Update/Simplix etc… a thought popped into my head and will not leave… Its got nothing to do with LE and the problems you are having…

“Why the hell are you not using Linux?”

Totally off topic - I understand every one of your concerns about Win10 and all the hoops you are running through to stick to your principals on the issues but I am just wondering why cause yourself all this aggrivation and not migrate entirely to Linux and put this all behind you and have a much more restful experience?

Seriously… I am really interested to understand this because virtually any Windows only app/etc can now be run in some sort of virtualised containter if you MUST use it and there is no native solution… Any one of the linux distros can serve for virtually everything anyone may want to do… add online services to the mix and there isnt much of a reason NOT to go Linux - especially for someone like yourself (obviously based on my interpretation/reading between the lines of your comments)…

Obviously I am being nosy here so no need to answer that rambling… :wink:

Updating via Simplix - look anything to double check and install updates that works for you cannot possibly hurt.

Vulkan - maybe… Quite a few people who tried Vulkan with LE seem to say it doesnt work very well… But no reason not to try.

Installing Unity - maybe… who knows what it may install - obviously you only really need the runtime libraries but if you are willing to install the dev pack/SDK then I figure thats something to try… I’d mess with the cmd line options before going the hole hog on Unity tho…

Dont forget to try the Compatibility modes on the last epoch exe. maybe it will help or at least pop up some other bone for you to chase… :wink:

Haha, Linux, my favourite love/hate child.

I have it running on other devices, along with vm’s inside it and I’m no stranger to it.

The problem is, my main PC drive(s) here has literally hundreds of programs on it, most of which I do still use a lot. I also have a lot of games, old & new, that I go back to from time to time. Most of these games won’t properly run natively inside Linux distros so it means using a VM. Now, while I much prefer Linux for “day to day” tasks, for gaming it’s still very much a problem child, despite all the improvements in recent years. As 80% of my online time is gaming that is a problem. Vulkan arriving and becoming more prevalent is helping a lot with that, but the days of it being a true alternative to DX and game devs using it more seem a little far off yet.

Once we’re no longer as tied to the evils of MS & DX for gaming, then yes I will be a super happy bunny to bounce across to Linux as my main workhorse & daily driver. I really hope this happens before my trusty Win7 dies its inevitable death.

Having done all my diligence & downloading I’m almost about to embark on my daily regime of tests #97879 and up to see if that works. I’ll keep you posted later on…

Finally getting somewhere… I am excited.

Ok, debugging… I did an “update” using Simplex, but it turned out I was hardly missing anything, so that was a bit of a red herring.

I updated my .net from 4.7.x to 4.8, that didn’t fix the crash or the error.

Next, I focused on the fact that one of the key lines in the Player.log was

Blockquoted3d11: CreateDXGIFactory2(…) not found, fallbacking to CreateDXGIFactory1(…).
d3d11: QueryInterface(IDXGIFactory5) failed (80004002)

So, I had a dig around for other games built using Unity that also failed on create DXGI. I found a few old threads where people had not only had issues with Citrix, but also when using ReShade or SweetFX with games. They too caused this error.

That got me to thinking back to Elite Dangerous which I played for a while, and I remembered using a form of ReShade with that to boost the graphics. I did a hunt on my SSD, and sure enough I used a variant of ReShade called EDFX which also contained SweetFX. Now, supposedly those files do not enter any Windows/System32 or affect any “system” dll’s, but I deleted all the directories on my SSD which contained any traces of EDFX/SweetFX. I also uninstalled ED as well to be double sure.

I then did another HD clean & Registry clean, then rebooted.

Now, using the Steam version I got past the client crash and all the way to the login screen. Granted I was now faced with the dreaded LE-13 error, even when using my login credentials from here, and so I couldn’t actually log in, but the client was running!!! (I’ll take it)

So, I’m going to download the standalone (again for the 5th time now) and see if that will let me actually log in. I’m not a fan of running games through Steam anyway, and I only tried that as an early option for a potential fix. I don’t know if you can have both versions installed, but aside from the Appdata directories being common I don’t see any technical reasons why not. So, downloading away I go…

For the time being, it appears that as well as Citrix conflicting with Unity compiled games, Reshade/SweetFX/EDFX also conflict with the main executable.

IF and WHEN I actually manage to log in and play, I will update here.