Still abyssmal loading times

Login was fast now, but zoning, specially to or from a major hub is incredibly slow still. I dont understand how same ppl have no issues while others like me have tons of issues. Makes be suspect if some settings can make them appear?

2 Likes

It is brutal, it works super well for like an hour or two and now it has been hanging and I can’t proceed.

Ja, hier auch. Server scheinen gerade auch gänzlich einzubrechen. Schon wieder.

just got on, so far i have been lucky on my last two loading screens. but guess thatll change soon.

Loading screen into me having to ALT+F4 because it was hanging for 10+ minutes at a loading screen = me now in a 700 person queue.

They need to fix this stuff.

1 Like

how do you see your queue position? i never got such a message up yet, it was just loading.

1.0 Server Status Thread - Announcements - Last Epoch Forums

The real shocker is that these loading times have been an issue for over a year. They can’t blame this on 1.0 release.

1 Like

guys , be patience

Re-launch the game and when you come back you’ll probably be meeting a queue.

2 Likes

It’s getting better, but still not quite there yet

Must be an asia thing then. I have been in queue for over an hour and I am about half way through. Great way to celebrate my Friday night!

1 Like

right? imagine living in a world where you purchase a product to spend some quality time in your free time and it actually works out like that! :smiley:

I joined LE pretty late, so i cant tell how it was during all those beta years, but from what im reading up now on discord/reddit etc, it seems like these issues indeed have been present all the time. That makes me wonder how they were ready for a full release

you must have better luck then us I am still sitting in a load screen trying to zone, every zone whether town or not takes between 3 and 15 mins to load in. dunno what they need to do but they need to do it fast or any new players they may have gotten on launch will drop the game.

Most of the time town portals don’t work. it never loads. i always need to go to a waypoint to travel. sometimes travel is instant. sometimes it takes an eternity. it’s bizzare.

game plays well otherwise but they really need to fix zoning. i usually avoid traveling back town to minimize zoning so i end up ignoring most loot. Not the best experience

Really? I thought it was just version 1.0. I have a lot of hours in the game but it’s been a long time since I’ve been back. Loading times were never an issue for me ever. Which patch introduced the long loading times? This is really a deal breaker for me, I am not patient with this kind of thing.

It’s been like this off and on since multi-player was released.

I’ve mostly been playing overnight because its been unplayable for me during the day. Logging in takes long enough, but I spent 5 minutes waiting for a zone to load when trying to leave a community area until I just gave up. At 51 levels in, I really don’t want to create an offline character and start all over again.

Waiting more than 25 minutes just to get into a zone… and still not getting into it is beyond unacceptable. Stating “Have patience” or “Play Offline” does not compensate for this situation. If you want people to play offline, then make it so that a character can transition between on and offline. This would even temporarily remedy the calamity that we are currently facing… which is a virtually unplayable online game.
I bought this game for myself and a copy for my son… so $70.00 in and the online features of the game can’t be accessed with any consistency. This should be “Priority one” and they should reach out for whatever assistance is required to remedy these issues. Otherwise people will lose faith in what this company/team promised to deliver and the positive reviews will begin to shift into negative reviews and perspectives about Last Epoch.

for me was today all day like minutes to change zones. I expected to be better tested for release…

1 Like