My Account
× My Account Forum Buy Now

Last Epoch Forums

Stash tabs merged/bugged (video)

Hello!

Discovered a bug earlier today, not sure If it’s new or not.
I’ve recorded a video on how the bug seems to work/behave.

So it looks like two of my stash tab categories has merged, not entirely sure how this happened, so not sure how to reproduce it.

Here’s a link to the video → Last Epoch - Stash tab categories bugged - 2021-06-06 - YouTube (unlisted)

  • Both category tabs are highlighted at the same time.
  • Even when separated by other categories in between the bugged category tabs.
  • The actual stash tabs within each category automatically has the “category” of the tab that comes first. So when I move my “Minion” tab before/in front of the Idols category, all stash tabs within will automatically change to that category.
  • Managed to fix the bug by removing all my categories and re-creating all, which was a bit of a hassle too, some stash categories just couldn’t be deleted or right clicked on (for configuration).

Hope the video is helpful :slight_smile:

1 Like

Hey, Welcome to the forums…

Looks like this has happened to a few people:

I am unable to reproduce this.

Can you remember anything that might help to recreate how this happened?

I was adding/removing tab categories at the time, but I didn’t actually see it happening, I only noticed it later on, just tab organizing in general.

This happened to me tonight, I was doing a spring-clean of all my stashes,… I did some big changes like:

  1. I deleted one of the main headings (after moving a sub-heading away), that main heading was also one of the originals id made (on another character).
  2. I bought a new stash in there too
  3. The bug is happening under a different main-heading, which by coincidence is also the place I moved that sub-heading too in step 1).

Not sure if that helps, but gl!

Hello guys!

I have the same bug too, it’s weird that even if I delete all characters, the bug persists in any new char that I create, so maybe it’s a steam file bug?

I recorded this video showing the bug : https://youtu.be/5lagQKVhEOA

All that I can remember was creating more stash tabs and categories, then when I was deleting them, the bug was on.

Hope that this can help, thank you all!

I actually tried to reproduce your fault when you originally posted, but was unable to do. I have 100 tabs so I thought I should be able to break it!

Today, immediately after 0.8.2i I ran into this issue when trying to sort out my stash. I was doing quite a bit of Category reorganisation (right-click a tab, select a new category). This was going fine for several tabs until I noticed one that I had changed Category now persisted in both. Furthermore, tabs from each Category (right-click their settings to confirm) were now listing whichever of the two Categories I selcted.

I quit and restarted the game but they were the same and although the interface lets you apply a new Category without error, the tabs show in both.

For science, I tried to move one of the ‘bugged tabs’ to a different Category, but now there are three different Categories which show the same tabs.

Edit: Using reading comprehension post-coffee on the OP I tried to reproduce their fix.

I created a new Category and moved the tabs I suspected as having a problem to that category. The settings for each tab were clearly problematic. Not that my titles matter, but I have a Purples Category and a Necro Category. The tabs that ought to be in Necro show in purples and vice versa. Changing the category of a tab in necro (which in Settings actually says Purple) lets me move it to the fresh category, however it is stil listed in Necro, and although I’ve done this for all tabs in the category I still cannot delete that category as the system says I can’t when its not empty.

No gear or items have been lost as far as I can see, and the tabs remain perfectly interactable. Low priority annoyance I assume :slight_smile:

Hey… Welcome to the forums…

The stash is a global function across multiple characters (obviously with shared stash) and the stash information is stored in a separate file to the savegames… i.e. using a different character to access the same stored stash should (as you noticed) have little difference…

I completed the process of moving about 50 tabs to two new categories. I restarted teh game between each category change (I dunno, delayed write or whatever) and now I have both those (new) categories functioning the way I expect.

However, although I did not interact with them in this session, my Mage and Sentinel Categories appear to have linked themselves, that is to say the tabs appear in both.

Edit: I just noticed they actually highlight together. Clicking on either Mage or Sentinel lights up both tabs. That’ll probably help trace the issue! I f this system does not support an extension for multiple categories then someone isn’t using unique ids.

Edit2: I doubled checked I indeed do NOT have write cache enabled the drive I’m running my laptop on here (external SSD). So that probably isn’t involved.

Edit3: After another restart of the game and it appeared my new categories were stable, I then created another new category to move my final ‘corrupted’ tabs to, but halfway through the moving process (as I described above), I saw one of the tabs I had just moved to the new temporary category highlighted both the new category, and the previous new category I thought had fixed things a few minutes ago.

I don’t think my methodology is useful so I’ll stop messing around until someone clever comes up with something.

Clearly a bug as it happenned to me too here a month later… no idea what I was doing, I literally just wanted to understand how stash tabs worked, got around to how they worked so I started to delete unwanted tabs I made and then bricked everything as now multiple tabs are LINKED together. Cannot right click the linked empty tab. I can click on it and it is completley empty but no way to edit it to delete the tab.

OK I FIXED IT. KINDA.
You need to empty all tabs, every single item you have.
Then you can delete the big tabs until you have ONE.
The BUG still will exist, the SECOND BIG TAB you create will bug out, it will link to your first big tab. THIRD TAB will be unlinked.
So DO NOT CREATE BIG TABS in this game. Been a month since this bug was seen and still not fixed…

Nevermind it bricked again so i cant even send the micro tabs into the big tab that is linked.

Hey…

While reordering tabs can be done with a mouse, you probably dragged a tab into a category and this is not yet supported and unfortunately has caused a few issues by incorrectly reassigning the category IDs and tab IDs causing duplicates entries that corrupt the stash in various odd ways.

there are two temporary solutions right now… (after backing up your Last Epoch folder C:\Users\USERNAME\AppData\LocalLow\Eleventh Hour Games)

  1. You can consider deleting the global stash - not sure how the game will react, but logically it should recreate it. Important to do a backup first and obviously deleting this file will lose your stash items etc…

  2. You can consider attempting to manually fix the category and tab ids in the global stash file (they are all at the end)… This is obviously NOT allowed in the game ToS and I have no idea if it will work for your specific issue but it has worked for at least one other person.

Very similar. Now fixed.

Same problem with mine, just tried option 1 but it does not solve the issue.

Hey… Welcome to the forums…

This is quite a complicated problem so exactly what yours might be is a little difficult to deduce from a single sentence.

Option 1 involves removing the Epoch_Local_Global_Data_Beta and Epoch_Local_Global_Data_Beta_temp files - this will remove all shared stash from the game for all your characters. Not sure how this is intended to solve the problem - it doesnt, it just gives you a blank slate - i.e. empty uncorrupted stash to start again.

Option 2 is the “best” option but is not easy unless you have a technical background/mindset to figure out what is corrupted and fix it. And obviously if its borked beyond repair then there is nothing you can do but start again.

Sorry for being unclear. I was referring to the fact that I am experiencing the same issue as OP and my 2nd and 3rd big tabs become linked and one of the small tabs (originally under the 2nd big tab) got translocated under the 1st big tab. Deleting my global data files does not seem to work as the cloud recreated the deleted files with all the bugged stash tabs when I logged into the game.

Have a look at this and see if it is comparable to your problem.

I fixed it, but what I did is not formally permitted by the ToS, so it’s up to you to decide if you want to do it or not.

Ah… forgot to mention Steam Cloud Saves as I never use it - I have trust issues so I manually backup all my savegames (in all games) regularly…

If you still want to go the restarting route then just temporarily disable Steam cloud saves for LE.

However, if I were you, I would at least try to fix the corruption as per @Shtrak comment… its not technically allowed but its not hurting anyone imho.

Its alright, I will just repress my OCD self and wait for the patch. Thanks for the advise!