Stash - "Delete Category" targets wrong category - stash ui broken

For me opening the stash right after loading in with the character, for example in the “End of Time”, lines up all stashes under the first category, as seen in the first picture. With the arrow to the right (highlighted in red) you should hopefully be able to find your lost stash tab.
Right clicking it opens the configuration tab, where you would be able to transfer it to another category. The tab should then remain visible to you.
As stated before, this process probably has to be repeated several times, for each tab you are not able to see anymore.

Picture 3 for reference how my stash is supposed to look.

I hope that this is helpful for at least some of you, with the same problem and you are able to recover your items.

1 Like

Same issue for me, as well as my fiance on her account. I had like 10 tabs prior, currently missing 2 of them. Having a hard time sorting all the items I do have because of it.

Same issue for me. I managed the stash tabs yesterday reorganizing the tabs into categories, when the bug came up. After logging on and off my uniques and set items tabs went missing, the stash category was empty. I got lucky though, because after I deleted the empty category, the tabs appeared in one of the remaining categories so i lost nothing. Was a terrifying experience though. Please fix the UI.

Happened to me as well, was about to reorganize my stash tabs, after removing a bunch of tabs, 2 of them are impossible to delete, one of them completely uninteractable

Same thing just happened to me unfortunately.

Any update on a fix? I haven’t seen it mentioned in the Discord, the forums or the patch notes. This is easily the worst bug I have come across in the game.

Same thing just happend when i deleted a category with items in it even when says that you have to remove the items first

Same here, just submitted this bug as well…

my tabs became unattached to a category.
I created a new category to move them into , but when I clicked confirm to move to that new category all tabs vanish except what ive just moved.
I log out back in - tabs are back but still not attached to any category , even the ones i moved to the new category.

Same here. Stash tabs bugged out! stash combined automatically, deleted one will result in deleting another. Unable to delete Stash tabs too.

Hi everyone - in case you didn’t hear, some people have managed to work around this issue by creating more categories / tabs.

Hopefully a bug fix soon, but in the meantime, I hope this works for you :slight_smile:

Tried the fix that you guys said : creating a new category. But I ended up attaching multiples categories to another and I lost most of my stashes. Now creating a category don’t show loosed stashes…
I guess I’ll leave the game

That sounds frustrating!

You can raise a ticket with support at

Maybe they can help

Same happens to me. Organizing my Categories and Tabs lead to almost unusable stash ui, very frustrating. All i tried (creating new categories or moving items and tabs around) leads to even more crangeled stash. On some of the categories right click doesnt work anymore, tabs dont appear anymore in any category. If i create a new category the lost tabs re-appear, but once i click them, they are gone again.

Same this is happening to me.
I have uploaded my system info and my player logs.

Hopefully this is fixed soon as the game is pretty much unplayable like this :frowning:

DxDiag.txt (117.0 KB)
le_graphicsmanager.ini (483 Bytes)
Player.log (31.9 KB)
Player-prev.log (43.0 KB)

How the hell has this not been fixed yet? There’s been hundreds of reports on this. Hell, there’s a thread dating back to June 2021 on this issue. I just lost 3-4 tabs of gear due to this. Creating more categories just made things worse. It’s killed all my desire to play LE until it’s fixed.

I just got the same bug, I deleted an empty category after reorg, and it didn’t dissapeared, then I tried again, but it deleted my Exalted category with like 6 tab full of different type of exalteds which I just wanted to reorg too…

I can’t make it come back, and the price of new tabs are still high, as I had like 6-8 tab on that category with lots of item. Any idea how to fix it as it’s really disheartening that I lost pretty much everything I collected and wanted to use to craft.

Tried creating categories, even with same name, I relogged multiple time. Nothing helped.

Hi, this has happened to me now too, added some new categories, did a transfer to from backpack to put into new tabs, did some category renaming and now I have lost a couple of tabs of my good items. Little depressing as I don’t know what to do.

I could get back my tabs with a bit of a play (and also have some assumption about the bug reason). But it remained in a bit chaotic state.

What I did is the following:

  1. Started to create new categories
  2. Sometimes it created a category which had a “sibling” (when you select one, it select the other too, and always show in the Tab configuration the state of the first in order of the categories).
  3. Started to “move” these categories around a bit and in many cases, it created a “superposition” of category, which doesn’t show as selected at all, and it was one of my “old” deleted category. I could select a tab and move it to a real, working category.
  4. Deleted the new sibling, which resulted in the first of the 2 sibling to remain, but un configurable.
  5. Created a tab again, and it usually create again the sibling, which if I move create the same superposition and I could move around my tabs one-by-one this way.
  6. If you had multiple category deleted, it looks like the “superposition” depends on where the tab is in the order when you create your “sibling”.

In the end I could move all my tabs to real ones, but I had to keep a few sibling at the end, otherwise the categories remain unchangable (as you lose the ability to modify if you delete the sibling), so its a bit ugly that I have a few “category X” at the end of my category list, but at least I have all my stuff back.

The issue is most likely indexing related, as the references to the categories are still there, we just can’t access it, and the duplicate creation (sibling categories) assumes it want to create the next category in order (most likely by the logic of “Highest Category Id + 1” which is prone to failure), but it doesn’t see the category already exists in the data structure, as its only exists on reference level. (Serious data validation error detected!)

I am having the same exact issue. Deleted a blank category, and lost a category with several tabs of exalted items instead. Have been unable to retrieve the items by creating / renaming new tabs. Insane that something like this has been around so long.