Stash - "Delete Category" targets wrong category - stash ui broken

What went wrong?
In the attempt to delete the category (header) labeled “Idols” from the Stash via the “Delete Category” button, a different Tab “Uniques” and on the second attempt “Sets” got deleted instead. This includes the sub tab, which holds the items.
The tab labeled “Idols”, target of the deletion, persists instead.

Player.log (31.4 KB)

Not sure if thats the correct log, (Player-Prev) has a size of 22MB and is not possible to upload here. I created a Copy should it be required.

Edit: Attached Player-prev file (457.3 KB)

1h later:
Seems to be some sort of visual bug, as i now can see the “lost” stashes together with all the others under the first category, even though they are not supposed to be linked to it. This is possible directly after logging in with a character and opening the stash box. As soon as I interact with any of them they disappear again.

With using right click as the first action its possible to bind the two “lost” stashes to another category. With this the stash tabs show again.


Hey @Valohrak – you can zip up your big log file to attach it.

If you are on Windows, right-click the file and Send To → Compressed Folder

1 Like

What went wrong?
I am having a similar issue in that I have tried deleting a created category tab and now the individual stash tabs are hidden, and category tabs are attached to either.

Similarly to Valohrak above, I can right click the two category tabs linked together, and then click Confirm, the have my individual storage tabs show up again.

I have attached the DxDiag, Player Log, and Graphics Settings files.

DxDiag.txt (101.7 KB)
le_graphicsmanager.ini (483 Bytes) (281.0 KB)

Same issue. I have 2 categories linked together. I was able to customize one of them and not the other, but they are both “selected” when I target either of them, and I cant delete any of them.

I have the same issue. Four categories got combined into two, with one tab lost entirely in the process-just vanished into thin air. When I click any category, it selects that one and the one it is “paired” with, treating it as one category with two buttons. Creating new categories just repeats the problem with those as well.

Same happened to me. I had several categories with 1 tab per category. Wanted to delete one category, so I moved the only tab in it to another category and then deleted the catgegory. It deleted not the selected one but another one (I think the last one). I was confused so I tried again and it deleted another one again. So I tried selecting back and forth again to be sure I selected the right one and tried a third time. Same thing. Logging out and joining again showed all tabs from deleted categories in the first category. While I was clicking through all of my tabs, suddenly the bugged ones vanished and were hidden again. Creating a new category makes things worse, multiple categories get selected simultaneously now.

EDIT: The only solution until its fixed was to rejoin again and again, so I could move bugged tabs with right click to categories that were still there. First I moved them to a category that was not General. I could access them then without them disappearing again. In the end I moved all of them to General and deleted all categories. Now only General is left with another bugged category that I cant delete. New categories still get bugged and get selected with other ones.

Came here to report the same bug.

I have the same issue. Categories merged and not removable.

It just happened to me too… how can we solve the problem? I lost a lot…

i have this bug aswell had to add categories until i got all my stash tabs back then moved them all to 1 category. usable but annoying

I’ve lost a tab, somehow, with items inside of it, and one of my main headers cannot be clicked on to show that page/tab. I have to navigate to the quick select list to find a tab. Missing tab is no where to be seen. Also, deleting a tab does not lower the cost associate with your next tab.

The search bar functionality is broken as well.

I two tabs called “generic” searching for “generic” results in no hits.

Having the same kind of issue. I have two separate categories, lets say category A and category B, but when I click on either of them, they both are selected. A and B show the same inventory, but when I go to edit A, A gets edited but B stays the same (when it comes to name, icon and color). The unfortunate thing that happened as well, is that A or B was actually the category for a whole different stash inventory, but it looks like it can no longer reference whatever ID that inventory is.

I feel like they got mixed up when I was moving the tabs around and I may have done it a little too quick, then it stored the reference information incorrectly or something. Now the tab with my exalteds, which A or B were point to, is just MIA

Have the Same problem made a new Category and removed it lost the one before it in line with all tabs.

made one more new Category and cant change it now when i click it it selects the one before

This also happened to me, but I can’t see my tabs from the deleted category anywhere. Do I have to wait more for them to appear? It has been almost an hour now.

Just as an update, I checked the save game folder under AppData, and I have 21 stash tabs in there, but only 20 in game. So this bug isn’t deleting stash tabs, but is hiding them.

Thanks for the report. We’ve already got this tracked internally.

1 Like

Please tell there’s a solution, I’ve lost more than 10 tabs full of exalted and unique items.

same issue for me. HC Online. it is not playable with the bug. stashes with items are all gone…after deleting a an empty catergory. pls fix :smiling_face_with_tear:

Same thing happened to me, I just reported the bug and was looking to see if anyone found a fix in their threads :frowning:

Here’s hoping for a fix. Took all the steam out of my playtime if my stash is going to hide my items if I try to organize it. I am one also sitting on 5 bugged tabs that cant be deleted and new ones are just as borked. Quick search: stash problems have been around for awhile, maybe worse now with online play where values arent saved locally anymore. So here’s me asking any eta?