Random Crashing possible solution using Nvidia drivers on an OverClocked card

I posted this over at the Diablo4 subreddit, but it seems like Last Epoch has the same problem, so I’ll repost the info here so hopefully it will help others experiencing random crashes, freezes, and Crash To Desktop using an Nvidia OC card.

Hold the presses!!! After days of troubleshooting and researching, I think I found a workaround solution that so far, works.

I looked at Event Viewer to see what error was being thrown associated to Nvidia graphics and when D4 crashed (with the GPU spike). There was a mysterious error related to “Event ID 0 from source nvlddmkm cannot be found”. I googled that and found this helpful thread. It is related to the Nvidia driver.


Clean reinstall of the Nvidia driver or even regressing to one from Aug didn’t work.

What caught my eye was Zoltan Kurtos’ comment about Factory Overclocked GPU. My 1080ti was overclocked like that.

He mentioned that “ever since one of the driver/windows updates, most games are unable to handle Factory OC cards and will crash after a while.”

His process workaround was (and I quote him):

Open the Nvidia control panel (usually located next to the clock in your system tray, bottom right)

Click “Help” in the top row and click “Debug mode”

What this does, it downclocks your card to the founder’s edition specs. You would have to enable this every time after a reboot.

Hope this helps anyone with a Factory OC Nvidia card that is experiencing random GPU spikes causing random game crashes with new Nvidia drivers.


Have you tested this yourself?
I get these random crashes maybe every 2 hours sometimes more frequently.
I can play for some sessions and then others end abruptly.

I do have a Factory OC card.
ASUS ROG Strix LC NVIDIA GeForce RTX 3090 Ti OC Edition
Had some issues with D4 initially in 4K, but now it is pretty stable, the key for me there was setting my background fps to 8, and capping fps to 60, and then the crashes stopped almost entirely. I have not had issues with D4 since. I mean graphics card wise. :stuck_out_tongue:

Here the client just closes, I was about to open a ticket but thought I would search here first. I am not even playing in 4K here, just 1080p.

I guess I can give this a try, but I really don’t have issues in most of my other games due to the OC and nVidia drivers.

I have tested this with LE and it seems to have stopped the crashing. I’m only playing in 1080p and my card is an older EVGA GTX 1080Ti OC. I did not go back and troubleshoot the crashes like I did in D4, but the symptoms and behavior were too similar to not try it. Give it a shot and report back here on if it fixed your crashes.

1 Like

So I found a spot where the crash happened twice in the Architect Fight before Lagon.
I am on Rogue Marksman, these are the skills I am using: Multishot, Umbral Blades, Smoke Bomb, Dark Quiver, and the Dash

I listed those because I had no issue here with my Beastmaster. So maybe one of the skill visuals are causing it.

The 3rd time I went to debug mode and the fight went crashless. Still not enough to know if that is the cause or if a combination of the skills visials and the OC is causing it. But at least they can look into it.

1 Like

Just to follow up, even in debug mode I am still getting some crashes, but that fight was definitely a problem area.

My next step is I turned VSYNC on. So far no crashes since yesterday. I had fps limiters on but was seeing a slight bit of tearing. But if this keeps it from crashing it is fine by me, I am playing on a 60fps projector anyway.

1 Like

Hey, a quick question about the freezes you mentioned, can they be related to a black screen freeze where you need to power off your computer?

I ask this as that’s the issue I’ve been having for the past few days, making me unable to play Last Epoch. The screen will turn black, I won’t be able to close down the game, and will need to reboot the computer by powering it off.

The odd thing is that, at least so far, I was unable to find anything in the EventViewer that could indicate what’s causing the problems.

1 Like

No black screen the game just closes no error messages for me. PC is still fine.

Also another follow up, I have not crashed since I turned VSYNC on. I even left Debug mode on the video card, and no crashes since my last post.

Next step going to go back to 4k…to hopefully find out that VSYNC has solved the problem.
Or maybe the last patch has solved it. :slight_smile:

1 Like

My case was the game simply freezing, un-responding, then crashing to desktop. Windows was still running and the game could be restarted. This was the norm without the Nvidia Control Panel set to Debug Mode.

I did experience catastrophic failures where my graphics card failed to black screen and a clicking emitted from the box. No response from Windows and no signal to the black monitor. What was strange was that turning off the power from the main power button didn’t work. I had to do turn off the UPS connected to the computer, making me think it could be a combo between the power supply and graphics card. Probably cutting the power directly on the power supply would have done the same thing. I found out that the cause was an overtaxed Graphics card by running a game, a video, or two windowed games at the same time.

Were you doing any type of simultaneous graphics related operations when this happened to you?

My old GTX 1080Ti has been a powerhouse over the years, but I think its showing its age. Dust buildup, drawing too much power when doing concurrent, taxing graphics operations is not a good thing that I avoid now.

When the crashes happened? No, just playing and maybe had some browser windows open, HW acceleration on browser windows is off, from Diablo4.

Can you check your GPU temps and power usage in task manager and see if it might be overheating of spiking just before it crashes? It does sound similar to what I had when I had overheating issues with dust buildup. I got one of those air pressurized duster cans and cleaned things up around the fans/vents/intakes/etc. and my random crashes went away.

It did not, usually idle they are around 32, and when playing they are at about 51-55, that was the first thing I checked when the client closed it was no different. The card itself has an AIO watercooler 240mm radiator.

1 Like

Your card sounds pretty sweet. It’s very interesting your Rogue char causes the crash but your Beastmaster is not affected. I’m also running a Rogue with Allie’s Shadow Daggers Falconer build (Aerial Assault, Umbral Blades, Falconry, Smoke Bomb, Dive Bomb) with no problems w/Debug Mode on. It sounds like some specific combo of your setup, the game, the graphics, and perhaps the client/server communication could be the cause.

If it is repeatable at that specific location, maybe you can repeat test each skill separately or in combo pairs to narrow down what specifically could be causing it. E.g., just spam Dash first, no crash, add next spam skill Umbral), no crash, add next spam skill (multishot), crash. Then restart battle, spam multishot first to see if crash is the cause.

Have you tested this in offline mode to see if it also crashes?

I hate troubleshooting random problems like these, but if you can find a repeatable case, then the LE Developers might be able to repeat it too. I did something similar with the D3 client updater causing a latest Malwarebytes to Bluescreen Windows. When Malwarebytes was able to repeat the crash, then they got to the root cause and were able to fix it. The key was to document in detail each step in creating the repeated crash.

I do think it is related to one of the skill visuals.

I took another different step. I turned fast sync on for the game through the nVidia control panel and turn vSync off in the game settings and just went back to framerate cap. The screen tearing is gone. And so far no crashes today. Maybe they addressed this in the patch. But I have not crashed since I last posted crashing was an issue, and I have not been playing on the Rogue though, been advancing my beastmaster more.

another thing to try …

Seems like it worked for me


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.