Game stuck on very first launch page, won't load

Once I start the game from steam, the Last Epoch name comes up and it stays there indefinitely. I have gotten the game to load to my characters one time since the new patch released. I have been playing for over a year. I am not a new purchaser. I have had this game a very long time.

Same problem here. I’ve been playing normally this week before the update. Now, it’s perpetually stuck in the Last Epoch logo loading screen until, eventually, Windows says that “Last Epoch.exe has stopped working”. It never reaches the main menu. It’s really frustrating.

Hey there…

Please can you post your player.log, le_graphicsmanager.ini and any crash/error logs that might be created (end of the player.log should indicate location of crash files if they did happen).

Also… be sure to run a Steam game file verification just in-case.

I figured it out by going to the lastepoch.exe file and changing the comapibility tab property to run as administrator. It has worked ever since today.

Hmm… The game shouldnt need compatibility settings or Admin rights…

Any chance you can post more details so that anyone else having this problem can try them?

Things like:

  1. What OS are you using (including patches installed)
  2. what compatibility settings you changed to that worked (or if it was only admin?).
  3. briefly what your system setup is (hardware & gpu driver version)
  4. Are you using Steam or the standalone player?

I did just get a new pc compared to my old pc which ran everything perfect so it’s a fairly new install but I did play before the patch for a few days then quit for a couple of weeks… waiting on the patch knowing things would change drastically.

I am running steam.
Running Windows 10, NOT 11, but with 10 is updated with all of the current patches. I have been warned by 11 beta users do NOT go 11. I am entered into the 11 beta program but my co-users warned me don’t go there yet just fyi. They all had to roll back.
My new graphics card is an NVIDIA GTX 1660 Super running everything at Ultra settings in the graphics tab in the game. At first I thought that might have been the issue but after getting in that hasn’t been an issue.
The only compatibility issue that was changed was Use as Administrator.

Now something that may have made a difference BUT there has been no warning or visual sign of it is Norton Security Antivirus. Last year, for black friday, I bought my old computer 1 pc’s year’s worth of protection with 1 extra month free. Two month’s ago they sent me a warning Luckily that they were going to go ahead and charge me BACK IN OCTOBER! for my next year of protection to make sure I was protected… what a load of… excuse my anger there. Anyhow, I’m glad I caught that email. I canceled the re-up immediately but the actual program’s end on the old computer was supposed to end this month. Then I bought this pc with it already on it for one month. I hated that fact. Anyhow, It is supposed to end some time this week and I think I got a message yesterday saying it ended. The program is still on my computer. I wish it would autountinstall but it doesn’t. Since the antivirus protection ended, that may have done something as well.

Thanks for the added info…

Old machine to new machine… i am wondering if there were permissions on the game files/savegames when you transferred them from the older machine that could explain why setting it to Admininistrator let the game work.

Win 11 - I dont recommend anyone use it yet - it needs time to mature first. I dont believe in being Microsofts free tester.

GTX 1660 Super - Depending on your resolution, ULTRA mode on that card is likely to be unstable and you will probably have the occassional crash/freeze/game stutter. Its only about 40% faster than a 1060 which I use and I play on very low settings at 1080p, 60fps framelimited - purely for stability/performance. If I set it to Ultra I am almost guaranteed a crash or game freeze in a play session. I recommend you drop this to High or Medium - the visual difference really isnt that huge and hardly noticeable in the heat of the play but the game is much more stable. Up to you.

Norton - I have been using it for years. I doubt very much that this would have been the issue unless there was a firewalling configuration issue - i.e. it couldnt get to the EHG servers for the login part.

Anyway… glad you are playing again.

Thanks for the suggestion as to the Super. I’ll downgrade the graphics in a sec. I’m making my wife breakfast (she works the midnight shift and just got off) and I’m about to log back in afterward.

1 Like

Hi, so I have the same issue.

I tried changing compatibility to admin, didn’t help, the game still just won’t load.

I played it previously on a “demo” copy, perhaps, half a year ago or more, worked quite well on an old HDD.

Right now the game is on SSD with the following PC configuration: i5-760, GTX 1050, 8GB RAM, Samsung SSD EVO 870 or something.

The game has actually loaded one time and I played it for an hour or so after quitting. I had my old saves from the “demo” copy, but started a new characted anyway. That was several days ago, since then the game doesn’t load anymore and just gets stuck at the loading screen with a popping message “Application does not respond” .

Any advices on how to tackle this issue?

Please can you make your own thread… This one has been solved so the forum will close it soon.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.