Error "Lost Connection" when switching zones

Now that server are somewhat stable the issue has once again become prominent.
Its the same plague I had when playing multiplayer in early access.

My experience today: Created acolyte; made it to the watcher camp; Dc when I went to the next zone; from the garden fortress to the next another lost connection; same when I finished the armory sidequest and went to the vault. Another two followed after that.

I already searched for solutions but cant find any.

  • Used cmd to flush dns and did the socket thing. The addition of and in the dns/IP4 I already had.
  • Did a complete network reset.
  • Did a new clean game install

I want to enjoy my cosmetics and the bazaar and both are only available online.
I shouldnt have to play in offline just so I can play without any dc´s.


Same problem, I can’t go beyond the starting location. always DC

Same problem here! I noticed that when I’m changing the zones this issue appear. Also, I can predict when the error is going to appear because some actions dont work like completing the quests or casting spells. You don’t get the error right away, only after some time… like 10 - 15 seconds.

I have this problem prior to 1.0 patch but did not reported this issue because I thought that this is going to be solved by devs…

1 Like

I have the exact same problem, appreciate if anybody can provide any fix.

1 Like

Same problem, i cant enter the keepers camp, the zones before i can switch how i like, but camp loading dcs me every time. It drives me insane, i have 16h “playtime” without playing more than 2 areas…

free VPN help me play without DC

Shouldn’t have to use a freaking VPN in order to play a game we paid for.
How ridiculous is it that they even suggest something like that?

1 Like

yep they did that. I had the same problem for a while. For some reason using a VPN fixed my Lost connection problems. Lazy devs or something in the code does this. Anyway, finally 3,5 hours straight without “lost connection” simulator P.S I have used years ProtonVPN and it works awesome. Proton VPN: Sign-up

Iam tempted to try that but Iam already playing offline now. Which works flawlessly.
Going back to online seems a bit of a waste atm.
Maybe I try that next cycle.

If someone else can give feedback if a vpn fixed the connection issue that would be great.

1 Like

Yeah I started running into this issue today on my Steam Deck after the patch they released. No problems whatsoever prior to then.

Doesn’t seem to be occurring on my Windows PC but still incredibly frustrating as I was finding the game to be a better experience handheld. Tried reinstalling, using different versions of proton, etc. but no luck.

Kinda disheartening to see this is a longstanding issue that hasn’t been fixed, my dad and brother were gonna play with me but if this is a common issue then I can’t recommend it to them. They could deal with the UI jank on their Steam Decks but being unable to leave town with your character and the only fix being to connect via VPN is a big no go.

Since yesterday, can’t teleport out of town…and the monolith stopped working too (infinite loading screen and Lost Connection). Euwest, but I switched to other Servers and it’s the same. I tried ProtonVPN and nothing changed.

Same problem, can’t leave End of Time. Disconnect when you try to change to any other zone. I agree using VPN is NOT a solution. I have had no problems the past week besides the occasional disconnect. This has just started happening to me after the last patch yesterday evening EST.

1 Like

I have yet to see an official developer comment on ANY of the disconnect threads.
May help if you list your ISP, connection type and if you’re WiFi or hardwired…

Come on devs! Fix this issue. I kinda lose my patience.

Same issue. Only having lost connection error upon transitioning via load screen. Haven’t been able to complete a dungeon once yet. “Lost Connection” is currently a more fitting name than “Last Epoch”

I also do have this problem, which is kind of annoing the 3rd day im not able to play my HC-Char.
I was doing the campain, riding on the back of this Osprix?-Thing and when switching zones after that, the game crashed.

Now my lvl 70 Hardcore Char is not playable anymore because i get the lost connection error right when i try to login with it :frowning:

Already gave feedback with the ingame button in main menu, but nothing changes.

Please help get my Char unstuck from the “Loading Epoch”!

Try a vpn to at least get your character unstuck. See if that helps. Would be kind of you do this to report back if its actually helping.

hey i also got a char that keeps getting lost connection when i try to log in
after heorot was downed i lost connection on the loading new zone and haven’t been able to log in since with that char other chars no problem

I have no problems playing monolith, even have a lvl 100 Char.
Yet i am always getting disconnected in loading screens while doing dungeons or campaign.
I have tried to resolve this locally without anything getting better. This has to be a server issue. Please fix!

Still getting constant lost connection issues trying to load a character or changing zones. Unplayable currently

1 Like