My Account
× My Account Forum Buy Now

Last Epoch Forums

Enabling RGB Support causes excessive frame drops due to infinitely trying to read LogitechLedEnginesWrapper.dll

When RGB Support is enabled, the game looks for the LogitechLedEnginesWrapper.dll which it will eventually find inside the “…\Last Epoch\Last Epoch_Data\Plugins\x86_64” directory.

Even though the dll is found and read the game never actually stops looking for the file and constantly asks the operating system to read from the same (multiple) locations resulting in 1000s of file read requests per second and causing the game to slow down significantly. At the same time the player.log file is getting filled with the same error message:

Player.log Error Message

(Filename: currently not available on il2cpp Line: -1)

DllNotFoundException: Unable to load DLL ‘LogitechLedEnginesWrapper’: The specified module could not be found.
at EHG.RGB.Integrations.LogitechIntegration.SetLightingFromBitmap (System.Byte bitmap) [0x00000] in <00000000000000000000000000000000>:0
at LE.Integrations.RGB.EpochRGB.Update () [0x00000] in <00000000000000000000000000000000>:0

I have uploaded a short video of me reproducing the behaviour with Process Monitor running besides the game window. The bottom left corner in Process Monitor shows the rapid increase in read events by the game, which ties into the game performance tanking. Though it needs to be said that having Process Monitor running increases the observed fps loss by a factor of roughly 2.25x. There is another fps counter in the bottom left corner of the game window.

DxDiag.txt (86.8 KB)
Player.log (1.8 MB)
le_graphicsmanager.ini (472 Bytes)
I am using a Logitech G915 which should be able to make use of this feature?

Steps to reproduce

  1. Launch the game normally and enter the world
  2. Open the Gameplay Settings tab
  3. Scroll to the bottom and check the RGB Support Checkbox

Once the setting is enabled the same behaviour can be observed in the login menu after
restarting.

Reproducibility
On windows 11 I’m able to reproduce this behaviour 100% of the time.

I also tried reproducing it on my Fedora 36 install to no avail. Neither the native Linux version of the game nor running through proton observe this behaviour.

Expected Behaviour
When enabling the RGB Support setting instead of perpetually failing silently causing slowdowns, the game should present feedback that this feature could not be enabled and disable it automatically.

Workaround
Disable RGB Support in settings

1 Like

Your bug report was too good and the system auto deleted it. Sorry about that. Thank you for the very detailed report.

3 Likes

Thanks for this post. There have been quite a few bug posts on this recently… In fact, I am on discord right now trying to help someone with the exact issue…

The player.log is flooded with potentially hundreds of thousands of the same error and players are experiencing degraded game performance because of it.

Most dont realise the cause as they dont check the log…

When this does happen on Linux, the users experience crashes but Windows users get degraded performance over time.

Also - Some players are finding that the game will not allow them to disable the RGB support - it ignores the checkbox toggle… Still trying to find a workaround on this.

Edit: have found a registry dword for the RGB settings, but I dont really like advising average end users to mess around with this kind of editing…

In regards to your last point about not being able to interact with the checkbox, I want to add that in my case enabling/disabling the feature works but I need to close and re-open the settings menu to see the the actual state of the checkbox. That’s why I had to reopen the settings menu twice in the short clip. Hope this might help narrowing it down a bit :slight_smile:.

1 Like

Perfect… Confirmed opening and closing the settings window helps with the toggle…

Now to see if it actually disabled it…

Edit: Player testing by playing for a while, it looks like its resolved but lets see how it goes…