Controller binding not working

I play with a Controller - PS4. It gets recognized and I can enter the rebind section in Gamplay.
But if I try to bind a button, f.e. square to an action, I get the Message,
Square is already in use.

I can scroll down the item bindings and check - square is not in use.

I tried to bind circle button and it worked. Tried square again, same outcome.

With circle I do get the possibility to rebind it, not with other buttons.

I need help to use my controller buttons.

edit: Steam controller support is deactivated

1 Like

There must be a bug in the game. I am having this same issue but using an Xbox controller. To make sure the button was not in use I even went to the controller assignment and removed it completely and then clicked on “Done” and backed all the way out of the menu. Then went back in, it showed that there was no assigned button for that ability and that button was not in use anywhere else. Then I select that button, whether it’s a bumper or a face button, and I get the message “button is already in use cannot be replaced”.

Specifically for me I am trying to assign the left bumper and the X button. I don’t want the potion on left bumper I prefer it on the X button but I can’t seem to reassign either of those.

2 Likes

I am having the same issue using PS4 controller. I have removed square from key binds and can not rebind it, says its in use. Restore defaults does not restore the original key binds, square is now missing from the hot bar.

1 Like

Same here with Xbox controller. X button can be removed but not assigned. Says X is already in use.

2 Likes

Same issue. Using PS5 controller seems like if you set back to default the X button “square on ps controllers” it will set back to default. But when trying to reassign it will say it is in use and cannot be assigned. If you try and change any other button that is already in use you get a message if you want to replace since it is already in use.

I’m having the exact same issue. PC - XBOX Controller. Gotta be a bug on LE’s side. This is the only game that gives me this issue. Kinda sucks because it has made it to where I cannot use my controller at all in the game as it keeps saying buttons are in use when they are clearly not.

1 Like

Same issue, same controller. I’ve done a search and there’s… dozens of posts about this. One guy in particular had several different controllers and none of them worked.

The weirdest thing for me is that my controller worked - but only 3 buttons on it worked. So I adapted my keybindings to correspond to those 3 useable buttons, and I played a Primalist so I could put companion abilities on the buttons that didn’t work…

So this morning I was playing and I said to myself, okay, I’m getting tired of not being able to use potions while using controller, or pick up items, or most things really - let me try one more time to get the other controller bindings to work… So I go into the interface and try AGAIN. When I did, it REMOVED button functionality on my controller. So then only 2 buttons on it worked. I tried again, and then it removed all button functionality.

So now I can’t use the controller at all, lol

The 1.0.1 update seems to have totally fixed controller for me. Which is crazy :+1:

Still can’t really rebind the keybindings on abilities for the controller but, that’s fine for now. Like I tried to change what Y on the controller does, it didn’t let me do it.

Same problem using a Steam Deck which is basically Xbox input. Didn’t want Y to be minion move, since I won’t be playing with minions, but even after Clearing Y from the bindings it still tells me that It’s assigned. Steam controller config does work as a temporary solution.

I also can’t rebind some keys. I fixed for so long with my drivers and installing apps only to now feel stopped from playing Last Epoch nicely with a controller because I can’t rebind triangle away from minion attack and to one of my skills.

When I was using the same controller but pretended it was a xbox 360 one (through steam or other apps) I instead couldn’t bind anything to L1 (which is the L bumper I believe, the front top ones).

Hoping for a fix! Also you’re listed on steam as unknown if the game supports PS controllers, but given it shows the correct icons for the buttons in game I think you should tell steam that it’s partial just like it shows for xbox.

Yeah, unfortunately for me, the update that rolled out today aimed at controller support did absolutely nothing to fix the issue for me. I still can’t remap buttons, and I can’t even switch back to the default settings on my controller which now has all of its inputs saying they are in use when they are not. I’m unable to play the game w/ a controller at this point. Not the end of the world for me as a PC user, but it’s still really frustrating.

Switching back to the default I guess could be done with a reinstall (also make sure you delete configs stored in C:)
As for rebinding, would be nice to have ingame, but you can always configure stuff through the Steam Controller interface. You can swap buttons there, but of course you would have to learn them after, because the game will still show the default prompts.

I can’t even use a controller it crashes the game altogether especially anytime I’m in a skill tree trying to do points. I’ve actually lost count how many times after around the 15th time. It’s honestly sad.

im having issues rebinding my A button im using xbox controller.

Same issue. Cannot rebind square on PS4 controller.

Same here. Unable to bind square or circle. Ps5 controller.

Same issue here - I’m trying to use my Xbox controller and its button bindings are terrible. Seem completely unable to remap some buttons, like A for example. How can it be so difficult to get a controller working!! I really want to play using controller & its sapping the fun out of it for me ATM - Any fix planned?

No fix or acknowledgement? Still unable to bind buttons dual sense.

I am also having this problem, playing controller on PC. Is there a fix in the works?

Dont expect a fix soon. I reported this issue already in Beta, just to be told that “it should work”.
So most likely there is no priority fo this.