My Account
× My Account Forum Buy Now

Last Epoch Forums

Can't log in

I was just in game, relogged and then the screen shows after i logged into the game “please wait” and it keep doing so and i can’t come into the game. Help would be appreciated. Ty

Sorry to hear this!

What happens if you restart the game client again? Which Operating System do you have?

Thanks for fast respone. Windows 10 64. I tried to restart the game/client again. Even restarted the computer. Still persist. It is as if the game is stuck somehow after i tried to relogg 2 times fast in a row.

Could you please find your log file and attach it to a forum post?

Was just about to “upload” attachment but it said “new users cant upload files”. Anyhow, now the game actually let me in agian, so it’s all good :slight_smile:

Ah, right - sorry. You should be able to do so in now if needed. I’ll tentatively mark the thread as solved, but if the issue reoccurs just upload the log file and we’ll look into this further.

A post was split to a new topic: Getting stuck in a location in Chapter 3

Ok sounds good!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.