My Account
× My Account Forum Buy Now

Last Epoch Forums

Whats up "The Surface" instance? 30fps down!

Let me start by saying im really enjoying the game.
I have a decent rig: i5-8600k @ 4.6ghz, GTX 1070 Asus Overclocked, 16gb ddr4 @3200mhz and game is on a SSD!
I was playing at ultra for about 70-100fps (i think its low for the graphic quality presented, but its a alpha, so no worries), my problem begun when i’ve reached the “The Surface”, my fps dropped down 30fps and theres no coming back!
Is there anything i can do or this is a common issue?
Also, anyone have a guide on graphics settings here? which impact the most and what are the recommended settings?

Could you please post some system information and your graphics INI file?

Graphics.INI (588 Bytes)
DxDiag.txt (79.7 KB)

All there, if anything more is needed just let me know!


Could you disable Advanced Grass and let us know if that helps?

let me try and will post feedback!

1 Like

well, i did get 12fps back, but im still at 42fps, tried disable grass, but no go!

turn off grass quality and advance grass

and maybe the terrain options

Grass quality and advanced grass off, got about 12fps, didn’t try terrain
Edit:I’m still in the 40-45fps terrain, that on a 144hz monitor is though

37 fps for me with low and everything turn off lol…i run path of exile high and grim dawn at max, guess its an alpha thing

Yeah, unfortunately

Any fix for this?

The underground areas at the start of the game were created first and we’ve had more time to optimize them than the newer outside zones. While I’m a bit surprised by the extent of the FPS discrepancy you’re reporting, another member of the team has told me his experience has been similar. We will be gradually improving performance in future patches.

Unfortunately in the interim I can only suggest trying lower settings.

No problem, not complaining, just thought you guys should know! Will lower for now

1 Like

Appreciate it!

Apologies for the poor performance at present.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.