Weird issue, not disconnected but not connected?

I am having a strange problem and I can’t seem to find anyone else sharing the same symptoms. Randomly, without any sort of provocation that I am aware of the game will stop showing skill animations mostly, my blast marksman, for instance, will be shooting arrows like normal, and then all of a sudden I will get no more visuals, once this happens I can no longer call a portal or finish an echo due to it not registering, that being said I can actually kill stuff and pick up items just fine but when I complete the objective, it does not register. My only option is to go back to character select and then come back into the game and do the next echo. this happens sometimes two to three times in a row before letting me play for another hour without issue. Is this happening for anyone else and if so have you found a solution?


Can confirm this happens for me too every few echos/dungeons, really frustrating, hopefully there is a fix for this soon.


I am having what seems like the same problem. I’m playing a warlock and Cthonic Fissure will suddenly stop having a visual, although I do still see the chaos bolts and spirits come out they just appear out of nowhere. I can pick up items and use my various skills, monsters are taking damage and dying, etc, but as OP described it does not register when I leave game and log back in.

I have not noticed a pattern with this,. There are usually fairly long (haven’t timed it, but maybe 30-60 minutes?) intervals of normal play between these occurrences. Occasionally they happen closer together.

1 Like

Yes, happening and leaving me in grey screen with clouds, active chat, portal open, Portaling status, but not going anywhere.

1 Like

I am also having this issue. It seems to happen every ten to twenty minutes. My abilities still work, but their effects no longer appear. Enemies exist but cannot be seen. They can be killed, damage me, and still drop loot. Sometimes I can pick up loot, but other times I cannot. Usually, I cannot portal to anywhere and must log out. If I try to portal to another monolith, I arrive in a textureless area.

Little update: It seems like it has to do with the NIC, Specifically RealTek NIC. I updated to the latest driver directly from their website and also changed my ipv4 and ipv6 DNS settings and have not had a problem since.

Change your ipv6 dns to:
2001:4860:4860::8888 primary
2001:4860:4860::8844 secondary

Change your ipv4 dns to: primary secondary

Hope it helps someone else.

I followed AgentBrel’s advice and updated my RealTek NIC drivers from the manufacturer’s website. It caused the soft disconnects to change into hard disconnects with an actual disconnected message. It also caused it to occur much faster. I would disconnect within a couple minutes each time. I then uninstalled the RealTek drivers completely and let Windows drivers be used instead. I’m basically back to soft disconnecting within twenty minutes again.

I also tried using a USB wireless network device, but I have the same result and am still soft disconnecting within twenty minutes.

I also tried using several different DNS servers (flushing the DNS cache each time) with no apparent effect on the problem.