My Account
× My Account Forum Buy Now

Last Epoch Forums

Vertical Sync and/or FPS limit(er) not working

I am a returning player to the game. Reinstalled everything looked good but my FPS went through the roof and my GPU tried to take off.

Setting my monitor to Vsync did not help with the problem. Neither does limiting background and foreground FPS.

Are the settings bugged?

Running:
AMD Ryzen 5800X
16 Gbb 3600mhz
RX 5700XT

Welcome to the forum…

A few things are possible here… its hard to say without much more info, including things like your player.log, le_graphicsmanager.ini and an the output of a dxdiag report (assuming you are even using Windows?)

If you reinstalled the game on the same system (i.e. it still has your old savegames etc), then I would recommend that you delete the le_graphicsmanager.ini file so that the game can create a new default one - you dont say how long ago you last played so its very possible that recent changes to game settings in newer patches could be messed up.

Your description of the GPU trying to take off is generally what happens if the game tries to run at higher than practical settings without any limits.

Normally the game should be taking the in-game framerate limit perfectly fine - make sure you have the enabled box checked tho - or you should be able to use vsync… Vsync will take whatever your monitor has but this can be a problem if your monitor hz is faster than the framerate your GPU can handle (especially on higher resolutions & quality combinations) - e.g. 144hz. Remember, vsync or framerate limiting are either settings - you cant use both at the same time without causing problems.

Hopefully resetting the settings file should make these settings work again.

Note that LE is still in beta and is unoptimised so its advisable to be conservative with your settings - dont just assume you can run 4k Ultra Quality with 144hz/fps on your hardware.

Also, make sure that your GPU drivers are up to date and that there are no overriding configurations that take priority over the game settings. This is also true for any gsync or dynamic refresh capabilities.

Thats about all I can guess at, the additional information requested may have more specific help as to what is going on.

Fair point.

The resolution I have played on before was 1920*1080 120hz with Vsync on. That would mean that the fps would not go above 120fps. As I said i’ve booted up the game and the settings were the same. My AMD control panel showed 250+ fps with the fans at full speed trying to compensate.

I’ve indeed reinstalled on the same device (saved content was still there). Where can I find this le_graphicsmanager.ini file/folder?

System: Windows 10 btw, I have the most recent drives for both my gpu and mobo/cpu.

Edit1: I’ve found the file with a bit of help from google. The game has created a new .ini. At this point i can confirm that when I am in game (ergo, loaded my character the frames/fps are 120fps at 1980*1080 using fullscreen and Vsync ON.

In the menu however the Vsync is not doing it’s job? I spike there to inbetween 250 / 266 FPS. This is now where my GPU fans really ramp up. I don’t think this is supposed to happen.

Is there a way to cap or limit my frames in the menu… there is no need to have 250fps in the menu.

If i need to upload files just tell me which ones and i’ll try to comply.

Ok…

If the game created a new le_graphicsmanager.ini correctly, it should be set on Medium quality @ your default Windows res, with framerate limiting on 60fps (and enabled) and vsync off… I am assuming that you removed the file while the game was not running?

If the game didnt reset to that then something is definitely odd here…

Again, info is lacking in that you dont say if you are playing the game via Steam or standalone, so I am going to assume Steam - if this is the case, then please run the game verification process in Steam to make sure your installation has actually run properly to tick this off the list as a possible cause of your troubles.

Side note: Sometimes the settings UI can get a little borked and you have to toggle a setting, close the menu and reopen it to double check that it actually changed. This doesnt usually happen on normal graphics settings but its obvious something is odd on your setup so anything is possible.

Also, if you have any driver level overrides, then that will ignore any in-game settings and based on your description of whats happening its very important that you check the driver settings to see what is taking priority.

The framerate limiting (with enable checkbox) in the in-game settings window is exactly what you are meant to use to do this - its there for this specific purpose and works perfectly for this normally… Its what most of us use while the game is in beta/unoptimised to get the best compromise between performace/stability/quality.

Honestly dont recall anyone having this kind of issue where graphics settings are ignored and I have been helping out here for almost 2 years… There has to be something overriding or even ignoring the game settings. The game wouldnt be shooting up to 250fps if vsync was working properly AND/OR it was correctly reading the enabled framerate limit in-game. It simply doesnt do that.

And yes, there is no need for 250fps in a game like LE… in fact, imho, anything more than 100fps is pointless from a gameplay perspective as there is no need for millisecond first person shooter interactions… Some people argue for smoother animation, but honestly once you get to a certain point anymore fps is just wasted.

The files I recommended you include would help - its very hard to guess or assume things that would be simply answered by the info they contain.

I’ve added some files that might be usefull (perhaps)

So my OS is windows 10
I use Steam, that is correct.

The framerate limiting (with enable checkbox) in the in-game settings window is exactly what you are meant to use to do this - its there for this specific purpose and works perfectly for this normally… Its what most of us use while the game is in beta/unoptimised to get the best compromise between performace/stability/quality.

I assumed that this was what the fucntionallity was made for. I just can’t seem to get it to work. Vsync (with monitor set to 60hz or 120hrz doesnt cap it) but also not the ticking of the minimum and maximum framerates works. I really don’t know what to do. What would you reccomend?

le_graphicsmanager.ini (487 Bytes)
DxDiag31-8-2022.txt (97.2 KB)

Ok…

The le_graphicsmanager.ini file you provide should be working fine (although I would disable Streamer Mode) and the game should not exceed 60fps with this config if there is nothing else overriding the settings.

At your hardware spec, with these settings no part of your system should be ramping up fans or doing anything stressful.

  1. Are you 100% sure that no part of your drivers are configured to override application settings?

  2. Are you 100% sure that no third party gpu apps or overlays are enforcing override gpu settings?

  3. Have you attempted to test LE without any other apps running? Do not run any screen capture devices or anything like this while testing. There are plenty of known issues with Unity (the game engine) and third party apps so its best to not use them while testing.

  4. Have you done the game file verification through Steam?

  5. There are more recent driver updates - 22 Aug is the newest for your GPU. Be sure to install it with a CLEAN installation - do not do an upgrade.

  6. I see you are using dual monitors - have to attempted to use the alternative monitor - just to see if its physical monitor related?

  7. IMPORTANT Your diagnostic section of the dxdiag report is showing Livekernel Event 141 Errors that are directly related to your AMD GPU or AMD Driver components. It is also showing 141 errors for various other issues… Livekernel Events are VERY serious as they could point to everything from overheating, physical hardware failures to corrupted OS installs to bad device drivers and a wide variety of things that could be warning that something is about to fail on your system. There are 7 LiveKernel events out of the 10 latest logged events - there should never be any… This is NOT something that you should be ignoring and imho, you MUST resolve this by figuring out what is going wrong before something fails catastrophically. If you are lucky, it may just be software corruption or driver issues… if not, it could be something failing that needs replacing. Note that these LiveKernel events could very well be part of the underlying cause of the weird and abnormal LE experiences…

Thank you for the respons. It looks like I have my homework cut out for me. This will take a while to all go though but I will get back to you.

Regarding point 7 would you recommmend doing a clean installation of the OS or fixing the problems one by one?

Live Kernel Errors are very tricky…

Before doing a clean OS install - which is usually a fairly good approach - I would try and establish if the issue is hardware/software related… Its hard to do this if you just wipe everything and reinstall because you lose all the logs and event history on your system that could help figure out what happened…

If you can get some idea of what exactly is failing from the logs or maybe even running some stress tests etc, then that will help you isolate the issue and know what to fix potentially.

My gut feeling is that you may have corrupted AMD drivers of some kind - but its very hard to tell… the other side of the issue is, if the problem is corruption related, why did it happen in the first place - is there some other intermittent issue happening that caused it? like a harddrive dying or memory failing…

After that I would advise a clean install - just because I am so used to doing that and its easy for me - but it can be very daunting for normal users especially if they havent backuped up all thier things first and havent gone through all the effort of reinstalling apps, drivers, configs etc…

Obviously after a reinstall you then still need to check things carefully… but if you check first, it may be easier to know where to look and what to test…