My Account
× My Account Forum Buy Now

Last Epoch Forums

Updates not downloading since version .8D

I purchased last Epoch in 2019? as a part of the early beta rel. It plays well, but i have not gotten any of the updates over this year… i am still on version .8D and have not gotten any of the beta code updates since, including the latest from this October. I performmed the Steam verify code function and tried and uninstall/re-install twice with no change. I have it set to the priority download upgrades and confirmed this has firewall access. Someone suggested it might be a corrupt .acf file? Do you know why this isn’t updating for me? I’m missing out on all the enhancements i paid for. Thanks! Tim

Hi, Welcome to the forums…

The latest game version is 0.8.3e and this should be automatically updating on Steam.

The fact that this hasnt updated in over a year probably indicates a problem with the Steam client specifically and you may want to reinstall Steam itself.

The ACF files mentioned are the ones that register the install, updates, space on the disk etc… Last Epoch is the one in your SteamLibrary/Steamapps folder with the id of appmanifest_899770. If this file is messed up then you will likely have issues updating… if this file is removed, then Steam will assume that the game simply has not been installed and you will need to reinstall the game…

Not knowing for sure what is happening, you might want to consider backing up the .acf file and then removing it and the last epoch install folder under steamapps/common and then reinstalling the game from scratch.

your savegames etc are in a different folder on your system:
bootdrive:\Users\Username\AppData\LocalLow\Eleventh Hour Games

ALTERNATIVELY - you could try the standalone Last Epoch launcher (that does not use Steam) which you can download from the EHG account page.

ps. I am assuming that you are using Windows.

Thank you for some real suggestions… I tried those, to no avail. I am on a Mac so there is s light folder path difference but was able to perform the same tasks. I re-installed thru steam and still at 0.8D. Ive been letting Steam continue to run in the background as the 'auto-update" might need some time to kick in, but that doesn’t seem to be doing anything. I looked for that launcher on you site, couldn’t find it anywhere… would that work with Mac? Again, I can launch ok, I just cannot get the app to update. Any other suggestions??

Ahh… Trying to play LE on Apple is unfortunately a problem… There have been no official updates since Oct 2020 so its interesting that you were actually even able to get ANY steam updates at all…

Apple support has been suspended due to the transition to the M1 chip (ARM).

Imho, the main issue here is that the game engine (and other components) version that LE uses (UNITY 2019) doesnt support the M1 Arm processor so for now EHG hands are tied… Transitioning to the new Unity versions that are testing ARM support will likely add another year of dev time to the game and I dont think EHG can afford that right now. I dont personally think that Mac support is totally dead, just that it might have to wait until LE is launched and EHG has the time/resources/money to update.

See: