My Account
× My Account Forum Buy Now

Last Epoch Forums

Unplayable on AMD GPU / Linux (kinda solved)

Hi, since I swapped my Nvidia GPU for an AMD Vega 64, I can no longer play Last Epoch at all under Linux. The game starts, but has very low FPS and doesn’t load textures. Running through Proton and forcing Vulkan rendering brings back some textures, but by far not all. Here is how it looks ingame:

The only thing that was changed was the GPU, so instead of an Nvidia card and their proprietary drivers, I now run a similarly powerful AMD card with Mesa drivers. They are fairly recent too, given that I run a rolling distribution.

Here’s my specs:

Intel Xeon E3-1240v5
Sapphire Nitro+ RX Vega64 8G
16GB DDR4 Ram
512GB Samsung 960evo NVMe
OpenSUSE Tumbleweed

Hi.

The purple issue on the character screen is a known issue that is unique to Linux and not specific to any particular GPU. Devs are aware of that one and there is currently no workaround for it.

The other issue you mention with textures seems very similar to what happens if there is a problem with the install of the game - on Steam with windows, its recommended to verify the game files to ensure that the installation is ok - I expect that you should be able to do similar on the Linux version.

Please run the game file verification before doing anything else.

While the current game has known performance issues and is generally unoptimised, performance issues are complicated and will need a lot more information from you to begin to troubleshoot anything.

Linux and the various distributions also add a level of complication that be hard to figure out. (Note that LE is only officially supported on Ubuntu but Debian based distros tend to have success playing more than others). Driver versions & even underlying graphical api versions and the combinations of specific versions of these drivers on specific distros can mean success or failure. These combinations can also behave differently depending on the version of the LE you try to run (i.e. native or proton etc). E.g. driver X with Vulkan Y with Proton might work, but not work with the native version. Or driver Y with native works, but not with Proton…

Obviously the Unity Game engine version 2019LTS has its own quirks to consider on Linux too.

To start troubleshooting performance issues please include the following files:

  • The game configuration/settings file - le_graphicsmanager.ini - we need to see what config you are trying to run at.

  • The game debug logfiles - player.log / player-prev.log - contains all the debug information and might be logging a possible cause for the problems.

See: Useful Files (EHG Support Site)

Specific to the Vega 64 - these cards are notorious for overheating and power draw issues (peak spikes can be 400W) so this part of the issue needs to be considered - especially if you were able to play on the same system with a different card (i.e. no other hw change). With LE being unoptimised if you did not set some sort of limit on the AMD card, its likely to max out and go into throttling mode or even stress the power delivery. There is no way to tell what effect this would have on the game but it will likely not be pretty.

With this in mind, please can you monitor your CPU usage, GPU (power, usage & temps) while trying to play LE… this could indicate an potential issue to work from.

Also… Considering your CPU - you dont say what Nvidia GPU you were using before, but perhaps there could be a bottleneck issue - the Vega 64 might be too fast for your CPU and this could translate into substantial FPS loss depending on the config you are trying to use… A quick check of some online bottleneck calcs does suggest this could be an issue with your match… (15-20% bottleneck) - the sites are making estimates so I dont always take them as gospel, but it does confirm the possibility.

1 Like

I was using an Nvidia Titan X (Pascal) before, which is actually a bit more powerful than the Vega.

Thank you for the helpful and detailed answer. I’ll see if the file verification changes anything and try to add the requested files and further info tomorrow. :slight_smile:

Ok… The CPU bottleneck was probably less (10-15%) with the TitanX and its power requirement is way lower than the Vega 64 so its still possible that the Vega is stressing things more than the Titan was - assuming everything else stays the same. Ideally to ignore bottlenecks as having an impact, it needs to be less than 10% difference - preferably less than 5%. Obviously bottlenecking depends on the options/resolution/loads etc and I dont expect bottlenecking to account for more than 5-10fps either way so while it may have an impact, there is likely something else involved…

Been going through older posts specific to Vega 64 and there were a lot of them related to performance issues - even on windows… Thankfully, most seem to have gone away with driver updates and a few specific issues like overheating/power supplies/people trying to run Ultra at 4k and even Vulkan wrappers solving AMD gpu related issues temporarily… etc. A few problems were actually solved by game updates about 2 years ago but there havent been many recent Vega 64 related items (one on a FirePro Mac via Bootcamp, but thats way different to your setup).

Logs would be really helpful as sometimes they can show something that is a known problem and bypass all the guesswork…

I’m in a testing session right now and about to provide you with more information. You’ll love this, as I already found something useful and unexpected.

First of all, I have made sure that the game files are validated by Steam.

Let me give you some better description of the game’s behaviour:

Native:
Everything actually looks normal, from UI to ingame graphics. It is ONLY the 3D main menu background with the character selection being that purple haze without textures for the assets.
Ingame FPS are actually decent at around 90 - 100 FPS on ULTRA settings, but there are constant little stutters, which are annoying.

Here comes the fun part: I’ve taken a look at the log files you mentioned and found the game spamming an error about - fasten your seatbelt - the Logitech RGB integration you have in the game and its missing dll. Which makes sense, since this is the Linux version and I believe dlls are not a thing over here? From there, I tried to disable the feature in the game settings, but the UI wouldn’t let me uncheck the setting. I then turned the feature off in the game config file and voila - the stutters are gone!

You’ll definitely want to disable this RGB feature by default on the Linux build.
(I am not sure if I have enabled it manually at some point and Steam would sync these settings from the cloud, but I don’t have an RGB keyboard, so I wouldn’t decide to turn that on.)

However, the weird, purple character selection issue remains for me as the only real issue with the native Linux build right now.

Native, with -force-vulkan
Now, the main menu has textures, but looks blurry somehow. FPS drop to slideshow levels, and ingame, the floor is missing, along with unplayable FPS. Clearly not an option.

Here’s a zip file containing the log files, my System Information from the Steam client and my preferences config file. (Please note that in this config file I have already manually set the RGB feature to zero.)

Last Epoch Logs, Config, System Info.zip (65.7 KB)

Great.

Definitely would not recommend running the game in Ultra on a Vega 64. even at 1080p. That is asking for trouble with the current unoptimised game state… However, if you are not convinced to reduce the quality, then I would suggest that you limit the framerate to no more than 60-70fps depending on if your GPU usage is hovering close to or above 85% usage for most of the time - short spikes to 100% are expected at certain times, but it should not flatline that high else LE starts to have issues… The stuttering you are getting is most definitely this - crashes on loading maps etc, big FPS spikes and lags of a second or more are other symptoms that usually happen. The general concensus with the current game build is to be conservative with the settings - e.g High quality is unlikely to look much different in the heat of play but it could help with stability/performance in game and can make your hardware run cooler too. Whatever you chose to do, dont leave LE unlimited or use a limit that is too high as to be effective in restricting LE from running away with itself…

The next patch 0.9 with multiplayer should also include the first real performance updates to the game - its the first time the devs have explicitly included performance as part of the patch in their dev blog… I dont expect miracles but I definitely am expecting a noticeable improvement.

This is why i wanted the logs - this is a known issue on Linux - the game is meant to auto disable the feature (like it does on windows) if the drivers dont exist and if it messes up then you end up with a flooded logfile of repeated errors that usually causes Linux systems to crash and windows systems drop down to single digit fps after about an hour or so of play (system dependant). Disabling this is the way to go… The toggling option you were struggling with is usually resolved by opening the settings in-game, toggling the checkbox, closing the settings and then going back in so see the change - again a known UI issue with that setting (and one other if I recall).

I expect that this Logitech issue is the primary cause of your troubles - everything else is likely just incremental issues compounding this. The other logs without it enabled look fairly normal.

As I said before the purple character screen is a known problem - not specific to your setup, just a general bug for all linux users…

Vulkan has not been the chosen solution for most players - but again, there have been a few that perfer it - again I expect this is very dependant on system setup from hardware/OS and driver version levels…

So long as you have found something that works for you thats great…

Well, if the purple character screen is on the radar, I’m fine. :slight_smile:

You are right that I shouldn’t run the game on Ultra in its current state. Knowing that it is not really optimized for performance yet and the general quirks of Unity, I usually go for mid to high settings. I was just setting everything to max to have a common point of comparison for testing and see how my hardware would handle it.

About that RGB feature… it is very gimmicky and I don’t think that it really adds to the game. If it causes problems and is specific to Logitech hardware anyway, maybe it is better to remove it from the game entirely? Just a thought thrown into the room.

I could do some more testing with Proton, but since the game has a native build and there are too many variables involved with different Proton versions on top of Linux and hardware configurations, I think it’s not worth the hassle. It’s better to focus on getting the native build to run as expected.

Anyway, thank you very much for your helpful, patient and kind interaction. You’re a good member of the game’s community.

Ultra & testing - I’d jot down your results now and then test again after 0.9 drops - I am doing the same (and have a fairly long list of very specific performance hogs to test that have caused people trouble over the last year or so)… I am doing it just out of interest really but it will help objectively see how well the devs have been able to improve things this coming patch… I help out a lot here on the forum so I want to be sure before I change tack and tell people to go ahead with Ultra settings… :grinning:

RGB… I tend to feel the same way and I actually have a supported Logitech Keyboard that can light up… but I have it disabled - I hate RGB… They only added it relatively recently and I personally think it was purely on a whim to test hardware integration like this more than really wanting it…

Native on Linux is the way to go imho… The devs havent shown much appetite to get it working perfectly right now but they have committed to putting in the effort when the game is more completed… Unlike the Mac issues, from my understanding Linux support isnt going anywhere, they just dont have the warm bodies to dedicate to making it work well yet…

Cheers… Hope you can enjoy LE …

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.