My Account
× My Account Forum Buy Now

Last Epoch Forums

Unable to link Steam account :/

I’m going off the following:

When trying to link my Steam account, nothing is working. I’m stuck in an endless loading loop.


Not sure if I linked it or not here as I did the bit on Steam page but it crash when returning to Last Epoch. Plus Account info page seem to be down.


Yeah, I click sign in and it doesn’t do anything. 522 error.

Same thing happened to me & when trying to redeem my Steam key i get 404: Page Not Found.

Got the same behaviour. And can’t start the launcher, not even as admin.

You can in offline mode but that is useless.

I got in after signing in via steam, however the page says it doesn’t exist.

Just tried the link again to redeem my steam key and the link opened up with a fresh page with no errors.
It says “My Steam key” with a big blank space with no steam key :confused:

Yeah i just tried again. I guess my account hasnt linked, now im getting a message saying [You must link your Steam account before receiving a key.]

Same exact thing here

I can’t link it, when i click to link my account ; it just open a new page of lastepoch website -_-

Everytime I try to link my steam account it just redirects me to the LastEpoch homepage but then the other link says I need to link my steam account before I can get a key…

STX i get the same page but it doesn’t say anything about linking my steam account, just a big blank space where my key should be.

We need some answers come on guys whre you all ? My lil skellies need me -_-

Cool, now says i’m a spammer lol -_-

1 Like

I just got the same thing… It tells me my account isnt linked, but now wont let me try to link my account.

You need to do something …; i cannot download standalone file … cannot link account on steam … One on the worst Launch Game ever …

The worst launch Game…same issues- not able to link, not able to download standalone…