My Account
× My Account Forum Buy Now

Last Epoch Forums

Unable to complete last update, either on steam or launcher

Hello,

I couldn’t find any threads about this issue or even articles mentionning this.
Yesterday afternoon I played the game for several hours straight, no problem.

By the evening, the last patch is deployed. Using the launcher, the update process runs smoothly until the integrity verification. At that point the launcher seems to enter an infinite loop where :
1 ) It runs the integrity verification (slow as hell but nevermind :slight_smile: ) and around 70%
2) it starts downloading the update
3) Once downloaded, the integrity verification runs again
4) Go back to step 1

I tried reinstalling the game through Steam. There the update cannot be completed too.
In the download section I get the error message “Content file Locked”
First time ever that I get this error message.

Need help getting this problem sorted out please.

I already tried :
a) admin rights on both launcher and steam
b) Clearing steam download temp file