The Northern Road - cannot speak to keeper Guard

When I try to interact with the guard with the quest marker in the Northern Road, there was only a “hmm?” from the guard. Not sure how to progress. Anyone else has this problem?
please help.

I’ll link a thread below about this. Basically you need to rerun The Keepers’ Vault to get Balthas to accompany you up to the guard. I just had this happen and that’s what fixed it for me. Good luck!

2 Likes

This worked for me too, thank you.

yeah, I walked back to the vault entrance and found him there. Just need to “pick him up” and walk back to the keep guard.

thanks!

Walking back to the beginning of The Northern Road also worked for me. Thank you much.

This isn’t working after the 1.01 patch. My friend and I have zoned, logged out, rebooted Steam and we still end up in the same situation. We can’t progress and are dead in the water. The tips above are not working. The NPC has a yellow quest marker but won’t talk to us. This just repeats if we start over.

1 Like

Two new characters, same issue each

Same…made extra characters…still no dice, seems like a massive bug that will turn a LOT of new players away not being able to progress in the game…

EDIT: I’m a controller player, turns out i couldnt interact with the guard with controller inputs but could with mouse clicks.

2 Likes

By the gods. You’ve found it. I was playin on steam deck and just clicked him with the touchscreen and it worked. (With the old man standing there)

1 Like

Thanks for the fix. I appreciate it. They still need to fix this stuff. It could have been gamebreaking.

Please fix this repeating issue when using a controller. Not everyone will know to click on it with a mouse and they will be stuck and upset.

Can confirm that tapping the guard on my steam deck fixed the problem!

Tapping the touch screen on steam deck worked for me too! Thanks for this. I was about to lose my mind

I had the problem while using my xbox-controller. When I used my mouse and clicked the guard, the story progressed for me.

It looks like they fixed this in the new patch 1.0.2. Yay!