My Account
Ɨ My Account Forum Buy Now
ā˜°

Last Epoch Forums

Suddenly very low FPS in every savegame

Since yesterday my FPS are very low. Even with very low settings I have only <10 FPS. No matter if in town (Outcast Camp) or really playing.

2 Days before everything went fine. Tested another char (older savegame), but same problem.
Updated chipset, BIOS and GPU-driver afterwards - no changes.
Repaired files under Steam - no changes. Reinstall - no changes.

Edit 1:
Just upgraded to Windows 11 - no changes.
NVIDIA overlay says 13 FPS at 10% CPU and 20% GPU. AC Valhalla runs at 70 FPS.

Edit 2:
Just saw, that the game has >100 FPS in main menu right after the loading screen. Then the FPS drop to 5-10.

le_graphicsmanager.ini (517 Bytes)
Player.log (33.2 KB)
DxDiag.txt (110.8 KB)

Hey thereā€¦ Welcome to the forumsā€¦

Wish you hadnt upgraded to Windows 11 in the middle of the problemā€¦ There is a major issue with Windows 11 Performance on AMD CPUsā€¦ Its supposedly fixed only a week ago but who knows if this is actually true yetā€¦ (Microsoft fixes Windows 11 AMD CPU performance issues with new update - The Verge)

Soā€¦ On the assumption that Windows 11 has decreased performance compared to Windows 10 by up to 20% Lets assume that this doesnt account for the massive drop you are experiencing but keep that in mind as a possibility when comparing before and after performance for now.

Looking at the player.log - I do not see any major complaints from the games internal debug messages that could indicate a performance issueā€¦

Your in game settings (le_graphicsmanager) is not showing any issue and you are running Very low settings on your 1060 which should be fine - I run the same 1060 on very low with framerates limited to 60fps (for stability) @ 1080p and the performance never drops to 13fps. It barely drops to 30 unless the screen is totally covered in mobs and skill effectsā€¦

From the DXDIAG output (obviously OLD windows 10), the OS and general drivers are OKā€¦ howeverā€¦ there is one huge warning sign - Citrixā€¦ specifically Citrix Indirect Display Adapterā€¦ There are a lot of issues with Citrix and the Unity game engine causing problems with each other - crashes, poor performance, stuttering etcā€¦ Plenty of players from a while back have found that they have to disable Citrix entirely while playing LE - i.e. no citrix related process can be runningā€¦ Just looking at this, if LE is trying to play via the Citrix display adapter it is defintiely going to failā€¦ You can also attempt to set the LE exe to run ONLY on the 1060 via the Windows Advanced Graphic settings - I have no idea where this has moved to in Win 11ā€¦ You might also have success trying to do this on the Nvidia driver level but I am unsure of how the Citrix drivers would hijack this.

You are also having a lot of OneDrive errros (look at the diagnostic section at the end of the Dxdiag report) but this could have been changed with the Win11 update.

One last thing is related to hardwareā€¦ Your GPU driver seems ok (cant say for Win11 tho) but you might want to monitor its clock speeds to see if anything fishy is happeningā€¦ There have been people who all of a sudden experienced poor performance only to realise that the driver had messed up and their clock speeds were being artificially locked down for various reasons (previous overheating etcā€¦)ā€¦

My recommendation is to try and test without any citrix services enabled and runningā€¦ No citrix graphics drivers or anything like thatā€¦ I would also make 100% sure that you have all the AMD and Microsoft patches installed to counter the Win11 AMD problems. and monitor your system while attempting to play or running benchmarks just to see if its performing as it should be / to specā€¦

Thank you, I will try the part with Citrix. Hope I can remove something temporarily, because I need it when I have to work.

Windows 11 reduced the problem a little bit (Beta Channel because of the AMD problem :slight_smile: ). But still far away from a few days before. I usually played with high settings and had no problems. Changed no driver BEFORE the FPS drop appeared. Everithing I did happened later.

Good luckā€¦ Citrix / Teamviewer are known to cause problems with Unity so this is likely the issue but it might be hard to figure out how to separate them if you have to have it for workā€¦ Dont forget to monitor your system while testing things - it could highlight what is happeningā€¦

Ignoring your recent upgrades etc, logically something happened on your system between when you had good performance and when you did notā€¦ It could have been anything - an automatic software update, a windows updateā€¦ The key is that its unlikely that LE was ok one moment and then bad the next without something changingā€¦ and LE has not had an update in a while nowā€¦ Obviously its impossible to tell what could have changed because of your upgrade to Win11 so its sort of a needle in the haystack approach.

One thing that is niggling me, did you Upgrade to Win11 or do a clean Win11 installā€¦ I dont personally advocate upgrading Windows - I prefer clean installsā€¦ They take a little more effort but at least by doing a clean install you dont have to struggle with some problem from a previous install still potentially causing an issue. People on this forum have had issues with upgrading from windows 8 and 7 to Win10ā€¦ but had no problems after clean installsā€¦

Man you are a genius :slight_smile:

The problem was caused by Citrix (there might have been an Update, but I thought it was some days earlier than my issues).
Canā€™t tell which step exactly worked but:

  1. I set everthing with Citrix to ā€œmanualā€ to avoid anything starting.
  2. I disabled the ā€œCitrix Indirect Display Adapterā€ in device manager.

After this, I have 70+ FPS in town with Settings on high. If I find some time I will test a little bit more and next week I will see if I can still do my job from home - or have to change settings frequently for a while.

To your other questions:
I also didnā€™t expect LE alone to be the problem. But many brains might find some troublemakers. And it worked ^^
Win 11 was just an upgrade, no clean install. Didnā€™t have the time for clean install.

Thanks again and you are doing a great job. I really love LE. Thumps up

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.