My Account
× My Account Forum Buy Now

Last Epoch Forums

Stuttering even with gsync on exclusive fullscreen mode

I’m getting constant stuttering even though my fps never drops below 58, on default, high medium or even low settings. Drivers up to date, this happens on both up to date windows 10 and 11. Verified the game’s files, deleted the game’s config files so it would reset to default. I have browser opened in the background but my pc is pretty decent so it should be able to handle it. Plus without anything opened the issue persists. I have gsync enabled and the game set to exclusive fullscreen, with vsync on in game, so it doesn’t cause screen tearing if framerate goes above 60, even with the limiter as it usually does happen. Vsync in this case hard limits the game’s framerate to that of my monitor refreshrate, which prevents tearing from above monitor’s refreshrate. Gsync makes my monitor’s refreshrate match the game when below 60 to prevent tearing. Both vsync and gsync combined prevent tearing completly in most games causing smooth framerate even when it’s below 56 fps. With gsync off and just vsync I get half frame rate as per usual vsync rules when the game fps drops bellow 60. If it’s 59 fps then it feels like 30. Not the case with gsync on. With just gsync I get no frame drops but occasional tearing as the framerate sometimes fluctuates to 61 fps even with a limiter to 60, causing tearing. In other games both combined, give the best experience, but in LE, it doesn’t work. I get stutters while playin when my framerate drops bellow 60, which leads me to believe the game isn’t enabling gsync even on exclusive fullscreen mode, which is a common problem with Unity games. I don’t know if EHG can remedy this unity engine level issue, but hopefully they can. If anyone can help me solve this someway, it would be much appreciated.

PC Specs: 2060 Super, Ryzen 5 3600xt, 16 GB DDR4 RAM, 480 GB Sata SSD (which both the game and windows are in), Asus Prime 450m Gaming BR.

Sorry for my English I’m not a native.

PS: If any files like logs or windows diagnostics are needed I can provide.

Vsync in-game setting doesnt always seem to work and can cause odd behaviour… Have you tried to set the framerate limit in game to 60 - I.e. not use vsync and see what happens. A fps limit in-game (instead of vsync) also seems to create a more stable framerate overall.

What resolution are you running at? There are a few reports of 1440p having screen tearing but 1080p on the same system does not - this seems to be performance related with the system being unable to maintain more than 60fps at 1440p but was able to do so at 1080p. Perhaps reducing your settings to get a higher average FPS could also help prevent the tearing?

I doubt very much that the game is supporting Gsync in any way… The version of unity 2019.4 LTS that LE uses has no reference to Gsync support - not that I can find anyway…

Have you tried different window modes to see if there is any difference - perhaps another window mode doesnt need gsync to stop tearing…

Hi I’m running the game at 1080p, even on low settings I get framerate issues while fighting. I tried disabling vsync and enabling the in game limiter and it caused screentear as expected. I tried setting it to default settings by deleting the game’s settings file, verifying the game files thru steam and neither helped. It’s only on certain zones that I get combat fps drops, on some echos I get no frame rate issues at all, while a few I get horrific performance. I noticed that most games on windowed borderless do not support gsync at all, but do when on exclusive fullscreen, an example is path of exile and skyrim, two games I play often and haveto use exclusive fulscreen to make sure gsync works. I’m running the game on pure exclusive fullscreen and still gsync doesn’t seem to work. I don’t know if gsync needs to be supported by the engine in order to work or on a driver level but if it is engine level, EHG could modify the engine to support it as they have with other engine level issues. Just to clarify, I get 100+ fps without a limiter or vsync at most areas on even high settings, but when fighting in some areas, it goes to 40 fps 30 I seen it go below that once. The problem is that all those were with in game vsync. I don’t know if I would get the drops without it and with limiter as I get horrible tearing that way. Maybe force vsync thru nvidia control pannel? I’m running it on windows 11 but the issue also happened when I was running 10. My system is up to date as are my drivers.

I run a 1060(3gb) @ 1080p with low settings on a 75hz monitor and have zero problems with screen tear and my average fps is around 55fps expect for known performance issues (i.e. lots of mobs, lots of minions, lots of skill procs or map particle effects). even then fps seldom drops to less than 40fps for more than a split second unless I am using something like a Devouring Orb build painting the screen purple (known to kill fps)… I do not use vsync - I set the game on 60fps framerate limited and I disable all the special graphics features like AA, shadows etc, as they are performance hogs. I can run at Medium without any issue other than fps loss so I prefer not to. I can even run at High, but the fps spikes / freezing that it causes is not worth it. At low, I can get 100+ fps, but then LE will max out my GPU can the game stability goes down the drain.

My processor is about 10% slower than yours so even the issue with CPU bound parts of the game shouldnt be affecting your FPS.

A 2060 Super at 1080p on low quality setting should be having no problems at all and should be performing much better than you are experiencing. In fact, at that config, it shouldnt even need “artificial help” like gsync… I dont know what you consider “horrific performance” but you shouldnt be getting less than what I do on my older hardware - thats for sure…

I think something else is going on here and I think that something is conflicting between the game settings and whatever driver level settings you are using… or even gsync. At the moment, for best stability & performance, its very important to framerate limit LE and I think that your combination of vsync/gsync is somehow causing the game to struggle with how its handing the actual processing of the framerate and what its restricted to… If you do not limit LE in a way that it “understands” then it attempts to max out the GPU which causes big fps spikes, freezes and even crashes in certain situations…

What is your GPU doing while playing - i.e. when you are experiencing these issues, is your GPU maxed out or are the temps high and its throttling?

Are you running anything else while testing LE? Have you monitored other components in your system to see if there is some other activity that is happing at the same time you are having issues?

EHG can do nothing about the game engine - they use what the version the game is using can support and its fairly old right now… This issue has come up many times with people asking for specific technical features like AMD FSR & NVIDIA DLSS and the devs have said that it would add over a years additional dev time to convert the game to a newer Unity version that supports additional features or addresses deficiencies in the current version.

The devs have committed to including performance improvements in the next patch(s) so perhaps this will also have an impact on what you are experiencing - I cannot say for sure…

The only thing I can say is that your hardware, even with the unoptimised game, should be getting better performance… so there is definitely something happening on your config that is causing this…

U are absolutely right, my hardware shouldn’t be struggling to run the game on even high settings, tho the game is in early access so high settings on any pc is asking for unoptimized performance, medium or low should be a breeze so definitely there is something else impacting my performance. The fps drops happen mid combat, when there are a bunch of enemies. I’m playing rogue blade dancer with sinc strikes and shadow cascade. I’m gonna try and use vsync thru the nvidia control panel in order to better limit the fps and prevent the issues u said the in game vsync causes. If that doesn’t work I’ll use rivaturner to limit it on top of vsync. I cannot run the game without it as I experience lots of screen tear on my 60hz monitor, even with limiter on 60, 57, 55 fps. I’ll also disable gsync for testing and report back to you if any of these help mitigate the issue. I also disabled game mode in windows, but, it didn’t seem to help. I noticed tho, that changing the nvidia control panel settings with the game open, doesn’t seem to affect the game at all, until I restart the game.
In regards to the engine, ur right they can’t really update it to a newer version of unity without years of dev time. However I have been watching the dev streams on twitch and youtube, and Mike has said that they have more than once edited the engine code to support changes they needed to make to the game. I imagine however, that adding functionality like gsync or any of the other new hot dlls fsr thingies, would take a lot of effort and might end up breaking more stuff than fixing.
Regardless, I’ll report back if any of the changes I said help. I’ll also install msi afterburner with rivaturner to monitor my gpu temps, usage, RAM, and cpu.
Thanks for taking ur time to respond to my post, it’s really appreciated.

I am having the same issue.
RTX 3080
Ryzen 7 5800X
32gb RAM

Screen tears literally every 4 seconds. I have done everything you listed as well with no resolution.

Its best to start your own thread and include your unique files & problem with a link to other threads that MAY be related.

With your spec, you should not be having performance issues unless you are using Ultra quality levels or higher resolutions. I.e. with conservative settings you should be getting decent FPS to the point where screen tearing shouldnt be happening.

To confirm: Are you also using gsync?

Kk will do.

No I am not running gsync. I do not know why but my Nvidia control panel does not have it.

Edit: Ok not 10 minutes after I posted this I think I resolved the issue. It is caused by a singular item: Torch of the Pontifex. Removing it from my character immediately resolved the issue in all locations.

PLEASE can you double check this result and post it in a separate thread in the bug section…

There have been specific Uniques that have caused problems like this in the past and if you are correct, then you may have found one that the devs need to check… Please can you explain what is happening with as much detail in a bug post and include your player.logs etc…

The devs may not respond directly, but they use the bug threads as a source for internal bug tracking so I know that they will see it and add it to things to check.

Thanks