My Account
× My Account Forum Buy Now

Last Epoch Forums

Stuck on Initializing


this is all i get when i try to launch the launcher. running as admin turned off firewall just in case that was the problem but nothing is working

well it finally got to the launcher it took about 10 mins just sitting there but now it won’t download at all =/

Having the same issue, stuck on initializing - wont move past that at all. Even tried restarting and running as admin…

And now I got the error mentioned on this link: - although running as admin doesn’t help.

Same here …

Damn it, i just bought the game and now i cant even launch it

same for me.
twitter msg : everything is looking good atm - cannot say it does.

Same for me - it throw Unknown error. Please try again.
Run as admin didn’t help

Same here. Run as admin doesn’t help. Any ideas?

Hi guys! I’m sorry you’re having issues with the launcher. We’ve got the people who made it working on it. If you have launcher-log files we would like them to help diagnose the issue.

In the mean time, the only option for you will be to link in a steam account to use their download process.

Hi Mike it’s not possible to link it with steam account…the steam key url didn’t display anything after you connect accounts…

Thanks for your reply here! I do have to add that the steam linking doesn’t work at the moment. When using the link steam, it just loads you back to the main page on the website without linking.

Sorry, I just found out that wasn’t working yet. We’ve got the web devs working on that right now.

1 Like

It’s really unfortunate that the guys supporting you from the beginning can’t play but people buying it right now on Steam can.

It’s really unfortunate that people can’t understand how everything doesn’t revolve around them, and that sometimes things out of the dev’s control can happen.
Give them a break.

I think I just stated a fact. Didn’t want to blame them for anything. There is a lot worse going around these forums or Reddit right now.

It’s all good guys, we know it’s very frustrating. We’ve all been customers in the same situation for other games too.

We’re working hard to get it up an running. It is really unfortunate that it’s not going smooth.

im just chilling making dinner ty for updates

Also, the steam linking should be working now. Go ahead and give it a try guys.

Hi Mike, now another issue Steam Key page is blank

Just tried, still the same. After signing in it’s just redirecting to and still showing "“You must link your Steam account before receiving a key.”.