My Account
× My Account Forum Buy Now

Last Epoch Forums

Stuck in login screen

Hey I just logged in after a few Months and the game looks great. BUT after switching between characters 2-3 times I got stuck in the login screen… It keeps loading but nohting happens :open_mouth: That’s a bug right? xD what can i do? Wait for a patch? Kinda sad cause I really wanted to play the game :frowning:

Does restarting the game client help? What about restarting your computer?

Moving to Technical Support.

I restarted my client multiple times and my pc once… then i didnt touched the game for an hour or so and now it works again don’t know what the problem was. Just btw after restarting my pc it still didn’t work…
But well now it works again

If this happens again could you please give us your log file?

This has happened to me. Just as top poster described it.
Came back after some time away, wanted to make a new toon, so was cleaning out the previous characters. After about 3-4 relogs, i suddenly got stuck on “Please Wait” at login screen. output_log.txt (407.7 KB)

Does restarting the game client help?

Have the same problem now, after entering my credentials I just get “please wait” and that’s it. Restarted my pc, didn’t help. I was also switching characters quite a few times when this happened (I forgot which character was wearing Ward Trail). I restarted the client numerous times when it did not work, before I checked here, so dunno if it helps: output_log.txt (5.9 KB)

A post was split to a new topic: Graphical issues at log in screen

Apologies for the slow response. I’ve made a change which should help with this, could you please try again now? If you continue to experience issues, could I ask whether you attempt to log in with your account name or your e-mail address?

Hey Sarno, no need to apologize, it’s all good. It’s working again, and I am using my account name. Thanks for your efforts. And thanks to your team as well, really like what you’re all doing.

1 Like

Appreciate the kind words! :slight_smile:

Continuing the discussion from Stuck in login screen:

I can’t get in it’s saying name is “taken” when loading in

now it’s correct credential, old account…

Hi everyone.

I’m going to lock the thread as we’ve now reached the point where people are posting about different issues in it (e.g. stuck at log in screen, “Username Taken” error) and having multiple different discussions occurring in the same place leads to confusion.

If you get the Username Taken or Correct Credentials, Old Account error messages, then please e-mail us at and we’ll assist you there. Thanks!

Stefent you may not need to, as due to your post we’ve made a change on our end which may resolve the issue for you. If not, just shoot us an e-mail and we’ll investigate further.

I’m also going to mark the thread as resolved, as in the third post we learned that the person who created the thread is now once again able to play without issue.