My Account
× My Account Forum Buy Now

Last Epoch Forums

Sorcerer passive Dragon Mage

Dragon Mage seems to be bugged in multiple ways. I first noticed this when I put my 7th point in it and it didn’t grant me any more fire damage after casting a cold spell than it did with 6 points. Tried going all the way to 10 points, and it still gave the same amount of damage (from 385% to 465%).

I wanted to further test the bug, so I respecced my last 20 points, and started putting points in it again. Essentially the same thing happened, only with different values this time. Now it increases my fire damage from 385% to 405%, but the amount of points still makes no difference. I tried to restart the game to see if that was the problem, but it doesn’t seem so.

There is a chance that it’s a tooltip bug, but I doubt it since I took my gear off and tried casting a level 1 fireball on a dummy multiple times and produced almost the same numbers with and without a level 10 Dragon Mage active. I took screenshots of me having 0, 1, 5 and 10 points in the passive skill with and without casting a cold spell. Album below.

I think the related skill “Mirror breath” has bug also.
“Mirror breath” does not reverse effect, it only addtional effect.

A default

B use fireball

C use fireball and “mirror breath” (of course after 5 sec or more later from B)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.