[Solved] Ubuntu game won't start

[This started off as a question, but as i typed it in, i starting finding the answer. It’s a jumble, but anyone having issues on Ubuntu might find this helpful.]

A friend just told me about Epoch and boy does it look good! I’m running Ubuntu 16.04 on my laptop, so i downloaded the tarball.

The executable is not marked as an executable. This can be changed in the File gui, by right-clicking on it, choosing properties, clicking the Permissions tab, and checking the checkbox, “Allow executing file as program”. Of course, chmod +x will do the same thing.

Anyway, it ran and showed me the config screen. I left it on the default settings of 1024 x 768, Low, and did not choose Windowed. I clicked OK, and it just goes away.

So, i ran it from the console to get more messages, and here’s what i found:

~$ Epoch/Last\ Epoch\ Kickstarter\ Demo.x86_64 Set current directory to /home/chacham Found path: /home/chacham/Epoch/Last Epoch Kickstarter Demo.x86_64 Mono path[0] = '/home/chacham/Epoch/Last Epoch Kickstarter Demo_Data/Managed' Mono config path = '/home/chacham/Epoch/Last Epoch Kickstarter Demo_Data/Mono/etc' Preloaded 'ScreenSelector.so' Preloaded 'libfmod.so' Preloaded 'libfmodL.so' Preloaded 'libfmodstudio.so' Preloaded 'libfmodstudioL.so' Preloaded 'libgvraudio.so' Preloaded 'libresonanceaudio.so' Logging to /home/chacham/.config/unity3d/Eleventh Hour Games/Last Epoch/Player.log ~$ cat /home/chacham/.config/unity3d/Eleventh\ Hour\ Games/Last\ Epoch/Player.log Desktop is 1440 x 900 @ 60 Hz Unable to find a supported OpenGL core profile Failed to create valid graphics context: please ensure you meet the minimum requirements E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer Vulkan detection: 0 No supported renderers found, exiting (Filename: Line: 560)
So, OpenGL is out of date. Let's see what i have:
glxinfo | grep "OpenGL version" OpenGL version string: 2.1 Mesa 18.2.0-devel
If glxinfo is not installed, Ubuntu will tell you what to run to get it. There are a bunch of sites out there that will help, but it changes by version of Ubuntu. Anyway, none of this helped me. I was only getting an earlier version of OpenGL. Then i found this help:
Open the dash menu(super key>> windows icon button) and type "additional drivers".

So, i was using the default driver, which did not supply a later OpenGL driver. So, i chose the top option to get NVIDIA’s driver, which might include an OpenGL driver. Personally, i like the open driver better, but i will have to give that up (at least for now) if i want this to work.

It took a little to get installed, so i wanted to see what the version was:

~$ glxinfo X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 155 (GLX) Minor opcode of failed request: 24 (X_GLXCreateNewContext) Value in failed request: 0x0 Serial number of failed request: 35 Current serial number in output stream: 36
So, i broke it. :) Actually, i just needed to reboot. After rebooting:
glxinfo | grep "OpenGL version" OpenGL version string: 3.3.0 NVIDIA 340.104
And now it works! Well, except that when typing in my name all characters are doubled, and it is pretty slow. But that's an adventure for another day.


If you cannot run it, mark it as an executable, either via Files, Properties, Permissions, checkbox. Or chmod +x.

If it disappears after the video selection screen, check your version of OpenGL:

glxinfo | grep "OpenGL version"
(You may need to install glxinfo). If the version is less than 3.2, you can try updating mesa, or more easily and prone to work: Open the dash menu(super key>> windows icon button) and type "additional drivers". Choose the vendor supplied driver, wait for it to finish, and reboot.



I can confirm that we are only support the proprietary driver for Nvidia’s cards. Perhaps we need to mention this in more places - I’ll add it to the FAQ, and it will be in a sticky thread at some point. I apologise for this not being stated clearly somewhere on our site.

The duplicate characters issue is a bug with the Unity game engine.


I didn’t even check the site. Silly me. I only checked the log, which made mention of the OpenGL version. Also, there is no mention of the error outside the logfile.

If i may be so bold, i would like to see a few changes to the Linux version, if possible an practical. One, mark the binary as executable. Two, generate a message on error, if possible in the gui, and certainly in the console. Three change the logfile itself to report if the wrong driver is being used, as opposed to wrong OpenGL version. Four, on error, cat out the logfile automatically.

In any case, i’m excited i got it installed. I’m still not sure it will run at a decent speed on my laptop, but that’s my problem, not yours. :slight_smile:

Previous ones have been. I haven’t yet had an opportunity to test the latest build myself.

The install guide I created does suggest checking this (and the driver, actually). Perhaps the information from the troubleshooting sections should also be their own entry on the FAQ.


I’ll certainly pass this onto the team.

It’s not something I can say we can or can’t do (in theory, should certainly be possible).


This one I’m less sure of. I would think that an error citing the OpenGL version is a good indication that it is a driver issue (I’m not sure how many games support the Nouveau drivers?) Perhaps when you start up the client we could put a message explicitly outlining our driver support.

I would think that an error citing the OpenGL version is a good indication that it is a driver issue (I’m not sure how many games support the Nouveau drivers?) Perhaps when you start up the client we could put a message explicitly outlining our driver support.
My first attempt was to update OpenGL, as there is much information out there on it. On which version of Ubuntu supports which version of OpenGL, and related info. After that all failed, i found that it was the driver itself that was limited, and i needed to go for the manufacturer provided version, by going to a part of Ubuntu i never used before. (I feel so pampered under Ubuntu. :P)

The original issue was, there was no report of error. There was just no game. I had to find the error myself by running from the console and getting output which included a logfile (that was not really tab-completable, for whatever reason, making it slightly annoying), then checking the logfile to realize the error was OpenGL related, then searching online to find out how to even check my OpenGL version. Adding more information to the website is a good idea, but there’s no indication that i ought to even check there. I only found this forum when i went to report an error.

I got the file itself from the kickstarter link, so i really didn’t pay much attention to the website. My fault, certainly. But i worry i am alone in my wreckless behavior. At the very, very least, please, if nothing else can be done, have the binary popup a (checkbox turn-offable) message saying if the game does not start, check the logfile and website.