My Account
× My Account Forum Buy Now

Last Epoch Forums

Social panel is flat out broken

i’ve submitted to bug reports, but the only person to respond from EHG has lost interest :frowning:

i’m running in linux. have not tried in windows yet.

my social panel is flat out broken (and yes, i’ve reinstalled the game, more than once).

  • changing status doesn’t do anything.
  • blocking a player doesn’t show up in the block list
  • if someone sends me a friend request i see a VERY fast label go across the screen, but nothing about a pending friend request shows up in the panel.
  • last but not least, this happened upon starting with the current patch.

I don’t understand if this information in maintained on a server tied to my account, but it has the stink of a permission problem on a key file somewhere…

at this point i’m willing to burn the whole thing down and lose my characters to fix it.

help…?

Hey there…

Cannot really help you other than to say that all of this is is going to be changed when the MP components are added to the game - imho, what would be the point of fixing any of this if its all already replaced on the internal MP enabled version that we just dont have access to yet?

There are screenshots & more info of all these changes in the MP updates - the Jan 2022 one especially Multiplayer Progress Update - January 2022 but also in the Feb one with regard to all the back end systems that have been changed and directly affect the system that would handle all of the social features…

The strange thing is that it’s “working” in the sense that friends are still friends, i.e. i show up in their friend list.
my status change works but the message isn’t displayed in my panel.
really weird…

Honestly… its probably something specific to the Linux OS version - I bet if you logged into your account on a Windows install of LE, it would probably be ok… There are some seriously odd bugs that only happen on the linux version and I wouldnt be surprised if this is similar…

thankfully, all of this “should” hopefully already be “fixed”… its just another thing dependant on “when” the devs decide to let us get our grubby little paws on it…

My chat is broken as well. My friends list and blocked list went away around the time of the latest patch. I can add no one to either my friends list or blocked list.

1 Like

Welcome to the forums…

Honestly cannot offer anything other than making sure your install is ok (Steam Game file verification & Standalone reinstall)… This would make sure that you are not experiencing some sort of corruption related issue…

As I mentioned in my previous posts, all of the front & back end handling these features have changed (from dev posts) and I am not entirely sure if there is anything the devs would be willing to do to patch the existing system that is guaranteed to change when they release it to the rest of us… Not an EHG staff member so I am just guessing tho…

The issue is not that it’s not being fixed, i can understand how they have to set priorities as to what to work on, the issue is that it’s not been acknowledged.

this is not “my fonts are weird in the social panel”, this is “the social panel is completely fubar” and it WAS working just fine.

i provided log files, including log files that included me trying to add friends, etc… and they were not acknowledged.

this is NOT an install issue. i have tried installing under windows, a brand new fresh install, and i have not played under windows in a VERY long time - same problem.

so this is a bug in EHGs handling of the social panel content in some way, and they seem to be stashing this stuff server side since a fresh install in windows has the same problem.

Hey… I dont work for EHG… all I can provide is my opinion…

Which is that the issue you are experiencing, while definitely annoying, is irrelevant… The entire system that will be handling the social interactions/aspects has been replaced and the devs have confirmed what it will look like & have confirmed that the back end systems have changed - we just dont have access to it right now…

My comments about making sure an install is not corrupted are quite simply because the issue you & the new poster are experiencing is limited - i.e. while outdated & buggy, the existing system does still seem to be working for the majority of people which logically would say that there is something very specific to your situation that is causing this…

Corrupted installs for LE are VERY COMMON and cause a wide variety of odd issues so thats why I suggested it to the NEW poster in this thread.

I am still of the opinion that EHG spending any time fixing the current (read old) version of this system is entirely useless and a waste of their resources… I would much rather they buckled down and released the replacement than worry about the exisitng version that everyone knows is generally poor.

I dont see what the point would be to acknowledge the problem - they already have by replacing the entire system with a new one…

Again… I dont work for EHG… I have no insight into their thought process or decision making… a EHG dev could swoop in here like a shining knight on a white horse and fix the issue…

LOL. i’ve been wanting to link this forever.

I realize it’s your opinion, and you are right that install issues can cause problems. I did have an installation a while back so i know it happens. humorously i fixed it by reinstalling steam. AND I DON’T USE STEAM FOR LE. LOL

No shining knight needed, which is my point. What would be nice is - “yeah, we know it’s problem, it’s not getting fixed, it will be fixed when we release the new system.”

:wink:

1 Like