Server problem. Cant play because of rubber banding

I have problem with server rubberbanding to the maxed. I can only play 1 monolith before got rubberband server. no enemy and I still can got hit. i have died multiple of times because of that. this is the video of my gameplay.

Problem start at 4.28. as you can see before it I can play normally. I need to log out and log in again after every monolith map to play.

Same for me. I got this post too:

and its start more or less at the same time. after patch 0.9f I can play like 1 day. and after that it was like the video I sent. I will monitor your thread too.

I have been having a similar problem. It got much worse once I got to monoliths. It will slow down and I’ll keep rubber-banding back to the same place or or all of the enemies freeze up on the screen for a while and then everything will catch back up if I wait long enough. The latency indicator stays at roughly the same reading through out this whole process. I’ve taken to checking to see if it is fixed and quitting after 1 mon.

Try removing Arcane Ascendance from your bar… Doing this solved my issue

1 Like

Thank you. this is my solution. didnt think it was because I tried new skill. and it was Arcane Ascendance.

Cool, yeah hopefully we get a patch to fix the issue soon… I’d really like to start using Arcane Ascendance, hopefully you find something to use int he meantime

I’m using a build that swaps between swarmblade and spriggan form often. Do you know if there is a similar issue with those skills?

I haven’t seen anything about that, no…

I already report it on my ticket that Arcane Ascendance skill is the one that cause this issue. hopefully the dev can fix it soon.

hi guys !

yes its terrible annoying and unplayable for me too…
not only in multiplay… in soloplay aswell…
packetloss, desync, rubberbanding, extremely lags and so on … all these problems are after the “fix” patch ^^ before it was just a little bit with movement skills

90% of my deaths are = after lag i am died … dosnt see effects or enemies around me before … cant use and timing my abilities … sometimes cant use potions … and much more
AND NOT ONLY with movement skills … i have all the time these problems and the longer ingame the more lags … sorry but this game is unplayable

BTW: its dosnt matter wich setting u are using for graphics … low or high/ultra = same fps and fps drops

If you use arcane ascendance, remove it from the quick skill toolbar. it fix my problem. I you dont use it maybe other skill cause it. just try. it should not play like that. and the dev already know. I just dont know if they know how to fix it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.