My Account
Ɨ My Account Forum Buy Now
ā˜°

Last Epoch Forums

Really slow startup and loading

Hi guys,
I m experiencing extremely slow loadings on Last Epoch when starting the game.
After starting Last Epoch from my Steam library it takes about 45sec to reach the title screen. And then it takes about 90sec to reach the login screen.
I have quite a good PC as you can see and i ve never had such an issue on any other game (all other games launch very rapidly).
So what is going on exactly regarding Last Epoch loadings and how to fix it?

Thanks in advance for your help on this issue.
Best regards.

My DxDiag: DxDiag.txt (114.8 KB)
My Player.log:Player.log (9.0 KB)
My Samsung 860 EVO 1TB (dedicated to only games) read performance: https://ibb.co/VgZ2JkG

Hi,

A few things:

  1. Is this player.log from a session immediately after you experienced this slow load time? Reason I ask is that this log has no game play debug messages - it just stops and there is very little to work fromā€¦

  2. Is this a new issue - i.e. has the game loaded acceptably previously? Is this happening after the recent patch? Has something happened / changed on your machine recently? New software installed? New Drivers or or Updates applied to anything? Remember there are definitely instances where other running apps & things affect the Unity game engine and supporting files and can cause odd behaviour. Are testing the game with any other apps running? If so, temporarily disable them to see is any of them are involved.

  3. Is there any issue with your networking? Reason I ask is that there used to be similar loading issues a few versions ago with people who were experiencing DNS related timeouts where the game would basically hang while it retried to contact the EHG servers. Sometimes this could be as long as a minute or more and then the game would ā€œwake upā€ after waiting. The solution for those people was to swap to google DNS rather than their ISPsā€¦

  4. Have you tried to verify the game files through steam? Hangs on startup could be related to corrupted game filesā€¦ Similarly, your GPU driver is recent, but did you do an upgrade or CLEAN install? Sometimes problems with GPU drivers are not solved if you just upgrade the driverā€¦

  5. Savegame corruptions can also cause an issue like this - as a test, disable Steam Cloud if you are using it, backup your save folder ( C:\Users\USERNAME\AppData\LocalLow\Eleventh Hour Games) ) and then remove all the files from the saves folder while the game isnt runningā€¦ If the game then loads properly and faster, then it could be that one of the saves could be causing the game to timeoutā€¦ The trick is to add back the savegames one at a time to see which one causes the issue and then obviously remove that specific oneā€¦ Be warned, if you are using Steam Cloud but dont disable it or force it to sync with the LOCAL files as most recent, then steam can resync older files back from the cloudā€¦

  6. What in-game settings are you using? The game can struggle to load if the in-game graphics settings are set too high - it has performance related stability issuesā€¦ You are using decent hardware but its the game and how it handles itself - especially when people push it, as they would expect to do with a released & optimised game. As a test, drop the settings to 1080p, 60fps framerate limited (not vsync) with all quality to very low and special features disabledā€¦ (you can also delete the le_graphicsmanager.ini file to force the game to reset to the default 1080p, medium config). If this helps/works then you simply need to be more conservative with settings - and/or make sure nothing else running is using your GPU while playing LE.

  7. I see that you are using a Topping DAC audio deviceā€¦ (or at least your system is loading the drivers)ā€¦ Sometimes LE struggles with special audio features like thisā€¦ two things here to verify that its not involved - 1) temporarily disable it / services to see if it makes any differenceā€¦ 2) try updating to the 5.30 version of the driverā€¦

  8. The diagnostic section of the DXDIAG report shows a lot of different errorsā€¦ Last Epoch has hung at least once, but there are other errors with everything from Steam to Java to Gimpā€¦ Things dont seem to be closing or exiting properly and some are crashingā€¦ You need to confirm that everything is generally ok on your system & that you know exactly why all these errors happened so that you can be sure they are not causing secondary problems.

  9. Monitor your system processes etc when you try and run LEā€¦ Try and see what is happening when the game loads - especially if there are any spikes or if the CPU/GPU is flatlining on anything, is something hogging the harddrive at the same time? View Reliability History on your system to see if Windows is reporting errors / warnings that could explain what is going onā€¦

1 Like
  1. Yes this player.log was just me launching the game from steam, accessing the title screen and then waiting for the login one. I exited the game after that.

  2. I havenā€™t played Last Epoch for quite a long time so i donā€™t want do say something that may be wrong. That being said i think that it has always been an issue but take this comment with a pinch of salt.

  3. No issue that i can tell. No disconnection or slow internet, lag, etc. I have a 2Gbit/ā€‹s down / 600 Mbit/ā€‹s up internet connection from Orange, a French provider.

  4. Yes, already done.

  5. I ll give it a try for as far as i have Steam Could activated for Last Epoch if i m not mistaken, thanks.

  6. I have everything set to max running the game at 1440p. The game always runs above 60FPS (most of the time i m running the game at about 100-120FPS) except during specific fights where some monsters use skills that seem to cause a huge perf drop (most of the time it doesnā€™t last for more than 1 sec that being said). As said before i have a quite good PC configuration so i donā€™t expect to face perf issue related to my specs.

  7. I ll give it a try, thanks. That being said i m not going to disable my DAC/amp for Last Epoch if it ends up being what is causing this long loading issue. Sound quality is very important to me so i wouldnā€™t even think about pluging my Sennheiser HD 800 S into my computer headphone jack.

  8. I ve never had any issue with any of those programs so far. And as said before Last Epoch is the only program that is causing such an issue for the moment. I installed Gimp a couple days ago and i havenā€™t had any issue with it. So this is quite strange. I m running Kaspersky Internet Security as my antivirus. I know that this antivirus can be quite aggressive when detecting strange behaviors from whatever program but it didnā€™t reported me anything regarding Last Epoch or anything else so far. I had a java update a couple days ago if i remember correctly but i havenā€™t noticed any issue after that.

  9. Ok, i ll launch Process Explorer to monitor what is happening (i can record it in a video if needed) and i ll post the result of what i have or havenā€™t noticed during Last Epoch start process.

Thanks for the help. :+1:

Ok so after disabling the support of Steam Cloud for save files on Last Epoch and deleting all my save files but the most recent ones (the couple ones from today) i went from more than 2 minutes from starting the game to reaching the login screen to a bit less than 20 seconds to do the sameā€¦ This is much better to say the least (yet it should be even faster for such a game on a computer like mine imo).

Anyway thanks a lot for your help, @vapourfire ! :+1:

Okā€¦ So it would then seem like there is something wrong with one or more of the older savegamesā€¦ If you wanted to, you could try and add them back one at a time to find the problem file and just delete that single oneā€¦

EDIT: Depending on how long ago you played, it may also be that the game is struggling to convert the older savegames for whatever reasonā€¦ Might be an explaination as to what is causing the problem but removing them is still likely the best solutionā€¦

Regarding load timesā€¦ I get about 30-40seconds load time from clicking Play in steam to having the purple play button ready in LE on my old i5-7500/1060GPU/16gb/NVME system via 100mb fibre. I would say 20s is more than fast enough for a beta unoptimised app with debugging enabledā€¦ :wink:

A few points from your comments above that I think might be worth replying to as the cause of the corruption hasnt really been established so it could happen again.

0 - Based on the savegames being the problem - I would recommend that you manually backup your files regularly - this way if anything like this happens again, you have a ā€œlast known goodā€ copy to revert back to without losing more than a playsessionā€¦ Just watch out for Steam Cloud - I have had so many problems with it over the years that I now never use it and most definitely wouldnt rely on its ability to sync saves reliablyā€¦

6 - Running the game at Ultra (i.e. max settings) is not something I recommendā€¦ even if your hardware should be capable of it. The state of the game means that if something is likely to go wrong, it will do so at the highest in-game settings or when the config is not limiting the game from flying off the rails (like not having a fps limit)ā€¦ Stability is noticeably better just dropping from Ultra to VeryHigh/High and issues like FPS spiking tend to be lower in magnitude if you leave your GPU decent headroom rather than letting the game have full reignā€¦ Crashes and odd things also tend to be less by being more conservative with the game right nowā€¦ All up to you.

7 - Sound. Each to their ownā€¦ Just needed to be mentioned as LE has had issues with sound in the past and the more obscure or complicated a setup, the more chance that this can affect the gameā€¦

8 - All that info is at the end of the Dxdiag file and should be repeated in View Reliability Historyā€¦ Probably has nothing to do with LE, but I hate it when I see things like that in my logs - but then I am a techie and I want everything running smoothly at all timesā€¦ The key for me is to know that they happened and know why it occured before I could ignore them safely.

1 Like

Words canā€™t express how grateful i am regarding the great help that you provided me on this issue. I would never had imagined that such a problem could be coming from save files. So, once again, thank you so much for your help. :+1:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.