Please change alt+z

Issues:

  1. alt+z is functionally similar to the loot filter, making people think its related to it when it isn’t - it toggles between a) using your loot filter, and b) hiding all loot. It does not toggle between a) using your loot filter, and b) showing all loot.
  2. alt+z has an impact on visible loot and not much actual usefulness.
  3. alt+z is too easy to press by accident.
  4. alt+z displays toggled notification in the chat window, but from then on, there’s no indication it is toggled on.
  5. alt+z is bound by default when it is so rarely needed.

Recommend:

  1. Change the default binding to something much harder to press by accident, such as alt+p, or dont bind it by default as so few people will actually use it.
  2. Add a tooltip into the keybind settings for it: “(has no affect on loot filter)”.
  3. Add another option to the keybind settings, “toggle loot filter”, bound to alt+x by default. This is something people would actually use, makes sense as an alternative to holding x, and it’d be pretty obvious when loot filter is disabled, as you’d see everything.

Below is original post and working out what exactly was going on.


New player here. Somewhere along the line I’ve accidentally pushed alt+z.

Loot hidden on the ground just looked as though my filter hiding it.
Playing really did feel like a struggle, argh. Thought I was just having super bad luck lol.

Something that lets you know this is toggled would be great, out of the way somewhere like down next to ‘shop’ maybe.

I’ve removed the bind for this altogether now. Not sure alt+z should even exist (why does it?).

EDIT: not sure why when it’s toggled, it doesn’t hide everything - but I dont really understand its functionality anyway just that I never want it on.

1 Like

The toggle is to disable the filter for the time when you hit the button. I use it to doubblecheck my filter from time to time and I think it’'s fine. It even shows you a prompot in the bottom left corner that it’s toggled. (Or maybe it’s in the chatbox don’t know my chat is disabled for a reason :smiley: )

Ok, yeah, it shows a notification in the chat, when its activated, or deactivated. Thats no use if you’ve accidentally activated it 50 levels ago.

I hold down ‘x’ to deactivate the filter… that works fine. IMO, having an accidental toggle possibility is much worse.

Ah, you know, I just realized, the problem is that holding ‘x’ doesn’t deactivate the toggle, even temporarily while held down. No wonder it seemed buggy.

I couldn’t understand the use case for it, so had to test haha.
With random idols on the ground.

Filter set to ‘show all idols’, nothing else.
WIth alt+z enabled: no idols shown
With alt+z disabled: idols shown

Filter set to ‘hide all idols’, nothing else.
With alt+z enabled: no idols shown
With alt+z disabled: no idols shown

OK, I still dont get when you’d ever turn it on. It doesn’t disabled your loot filter, it just hides everything.

Still not sure why I still found stuff with it enabled, albeit very rarely.

Sounds like it’s time to write a bug report then :wink: .

Thanks.

Yeah mm, well, technically, it does what it says. It “toggles tooltip for items on ground”.

It’s just that there’s zero use for that, and only serves to cause problems, like mine, and confuse people.

It should be removed, and they should add

  1. alt+z: “toggles loot filter on and off”.

If they want it for screenshots (the only use I can think of), make an “alt + print screen” or whatever.

From this conversation it sounds like there may be some confusion, forgive me if I misread that. The Als+Z has nothing to do with the loot filter at all, it simply enables or disables the ground labels. All items on the ground will be hidden and not be affected by pressing X, it doesn’t matter whether they are hidden or not by the loot filter.

Pressing the X is tied to the Loot Filter and yes, it doesn’t help if the items hidden by the Loot Filter were passed by a long time earlier, but you will normally notice very quickly if you don’t see anything on the ground.

I think the Alt+Z is actually too close to too many other keys that are used during gameplay but that would go in a Feedback/Suggestion post, not a bug report, so this is the right place. Until then I could only suggest remapping the default to something that you will not accidentally press. I know that this is still something that new players will have to deal with as they learn it the hard way, but it’s something that we have the option for now that we know it.

1 Like

Hi

Well thats just it, not everything is hidden with alt+z enabled. Its bugged. I still found stuff, just very infrequently.

And it does, functionally, have to do with the loot filter. It’s (functionally) toggling between using your loot filter, and displaying nothing (bug above aside).

But yeah, I clarified everything at top of first post, the rest was working out what the issues were really. Mostly, it just shouldnt be alt+z, or should be removed, its too easy to press by accident, make it alt+p or something hard. Its a useless function anyway.

I agree that there should be some indicator when the “hide all labels” toggle is turned on.

I found out this even existed the hard way. I thought my loot filter was just blocking most things dropping but after a little bit it seemed kind of weird, then I had a couple uniques drop, a shard shrine, an idol shrine… ugh… I thought my game was glitched or something, tried doing things like going back to town, etc. by the time I figured out alt-z was a thing and I’d accidentally activated it, it was too late and the items weren’t there anymore. It happens… now I know, lesson learned. But I still worry about accidentally activating it and potentially missing things before realizing I did.

It’s always going to be my fault – I’ll admit that – but it would be nice if there were maybe either periodic chat reminders or just some constant text reminder like “hiding all loot (alt-z)”

Neither you or I are the first its happened to. Searching forum for similar topic I came across a bunch from ages ago, where turning off alt+z was “the solution”, which is really a bandaid fix for a real problem.

Hopefully you discovered it quicker than me, seriously, 50 levels in.

Go into your keybindings, click on the alt+z binding, and click on ‘remove’. Not worth risking turning it on by mistake.

1 Like

Yeah, good call.

I do the same. Or when I just want to check a mono reward, to see if there’s anything useful for an alt.

It doesn’t disable your loot filter - how does hiding all loot help checking for an alt?

I actually use this function sometimes when there is a lot of loot on the ground. The nameplates for loot will push outward if you have a ton, so sometimes clicking on loot can be difficult. As you pick some up, disabling the nameplates then turning them back on will reset their locations. Had to do the same thing in PoE sometimes.

Oh btw don’t mind me I mixed up everything with “X” :smiley: . I just leave the threads up there like they are for consistency ^^. No I need to yee what alt+z does at all :smiley: .

I am new player. Same thing happen to me. I found my solution on the forum. I’ve changed my key to ~ now it is working cool :wink: Up-vote to the suggestion +1.

Highly recommend removing it from keybinding altogether so you dont accidentally push it :slight_smile:

This right here is the issue. All-encompassing toggles like this should be “opt-in” by default considering that the overwhelming majority of gamers never touch their keybinds.

1 Like