Online monoliths are not loading - stuck at loading screen

I have not been able to load successfully any of the Online Monoliths of Fate on ANY SERVER on the Last Ruin timeline.

All nodes do not respond after clicking on them.

The screen just stops at the loading screen and it has been so for 2 days!! Can someone from the development team pls help… this is so frustrating i am almost level 100 and this is the last Monolith before i hit Empowered.

If online play is screwed, can you at least allow online characters to be converted to offline!!! or allow interchangability!!!

If you’re experiencing a crashing issue, please provide the information in this support article after repairing the game.

If you need assistance with an account-related problem (or don’t want to post files here), use our support site to contact us directly.

Screw this i am going to ask for a refund, wasting my time reloading the game.

This game should not even be sold in the first place. Terrible

same here, also i lost connection to the servers a lot, im tired of this sht… no other games do this, tried a lot of things to solve this issue, nothing worked so far, its annoying gonna refund the game if no fix coming soon…

Same here,

Even when I try to group with a friend, both of us are stuck in loading screen. But after my friend can play again, not me.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.