Occasionally an item still can't be picked up, regardless of filter or tooltip status

I was not able to pick up this unique item echo reward:

imgur link screenshot

Searching for this issue, there are many threads, though all seem to be locked after only the suggestions of toggling/disabling the filter, or toggling the option to hide tooltips. Sadly I must make this thread again because there is still an issue independent of those ideas suggested in all the other locked threads.

The screenshot shows I have tried to adjust said settings. I disabled and enabled ground item tooltips multiple times, this did NOT fix the issue. That setting affected all other items shown with the red arrow, but did not affect the unique item. Tabbing out and in to the game was another suggestion that did nothing.

I tried various things with the filter: toggling it both with the hotkey and manually in the filter menu, changing filters, toggling every item in my filter that was related to uniques, cycling through show/recolor/emphasize options for said items, moving around the position of rules related to uniques, even toggling the entire UI, etc. All while weaving in disabling and re-enabling the filter, and weaving in toggles of the “hide ground item tooltips” setting.

Nothing allowed interaction with the item. Although the word ‘toggle’ has now lost all meaning in my head.

Player.log (1.2 MB)