My Account
× My Account Forum Buy Now

Last Epoch Forums

New players LE-24, LE-26, cant find lisence issue

lots of my friends have joined LE during the steam discount, and some of them have met LE-24, LE-26, cant find lisence issue(already bought and sign-up but in game saying Welcome but no LE lisence found). We tried many methods but few of them still cannot login. Most of them are in Chinese region, please help!

1 Like

Having the same problem

Submit a ticket to support: Known Issue - LE-24 Error - Please Submit a Ticket

In my case, 3 steps helped to fix the LE-24 issue:

  1. logged out of all sessions on the site « https://lastepoch.com/player/account/sessions » - Log out all
  2. Delete all game saves on the disk: «C:\Users*User name*\AppData\LocalLow\Eleventh Hour Games\Last Epoch», disk C:\ on which Windows is installed.
  3. I checked the integrity of the game files with the built-in steam tool.

Upd
But it looks like my problem was solved in real time by technical support, in the interval when I followed these steps. For which special thanks to them.