My Account
× My Account Forum Buy Now

Last Epoch Forums

Need help please, game runs slow on good pc

So I found this game very interesting, looks very fun and I would love to play it. For some reason, the game runs slow. I have a friend with the exact same pc as me and he has all his graphic settings on high and the game is smooth and flawless for him but for me I click and then a second later my character moves. I have tried even putting the graphic settings on very low and it still has this issue. I have re installed the game 3 times through the steam launcher and the Epoch launcher and nothing seems to work. I feel like I’ve wasted my money. If anyone has any insight on the problem i would truly appreciate it because i would love to play this game.

First of all, nah, your Money isn’t wasted. It just got into beta stage, it will improve in every area before release. If you “just want to Play a (finished) game” you’d Need to wait for release next year :stuck_out_tongue:

Concerning your Problem:
Do you and your friend live in the same area? Is your Internet Connection good? Do you have People using the same Connection as you, and they might download big files, stream movies or something?
Does the game also stutter? Or does your character run smoothly, after the one second lag?
Do you have the newest Drivers installed? Maybe different ones than your friend?

Besides of that, have you tried starting with another class? There seem to be some issues with primalist if you happen to have started as one, might be worth a try testing if you still lag with the same character class as your friend.

Sorry to hear that!

Could you post your system information & graphics settings?

Thanks for taking the time to help me out.
My friend and I do live in the same town, my internet connection is currently 55 Mbps download and 37 upload on a wired connection. There is no one else in the house with anything on. As far as the lag goes, it seems like everything is delayed. It’s every time i click to move that my character moves a second later, and it’s a choppy movement, character and background. I updated windows and all my drivers as well. And for the class, he is actually running the primalist whereas i chose the mage.

Thanks for taking the time to help me out here.
The graphics settings in game i messed around with, but right now it is set to medium with shadows and grass off. I set them to very low and still had a problem with it. I also have games like diablo 3 and fortnite which run around 200 fps with no problem.

System Information

  Time of this report: 5/8/2019, 12:17:45
         Machine name: DESKTOP-OGG2RO5
           Machine Id: {3EB86AA3-EA35-4F19-B6C6-AD19286B4E81}
     Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
             Language: English (Regional Setting: English)
  System Manufacturer: System manufacturer
         System Model: System Product Name
                 BIOS: 0402 (type: UEFI)
            Processor: Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (12 CPUs), ~3.2GHz
               Memory: 16384MB RAM
  Available OS Memory: 16228MB RAM
            Page File: 7291MB used, 11369MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17134.0001 64bit Unicode

I have a very similar problem. Spoke with some devs on Discord as well. At this point besides waiting for optimization patches, there isn’t much they/we can do. They’ve noticed this situation with modern rigs where they just randomly dont work well.

I am going to be reformatting my PC this weekend to see if that does anything, but ive done pretty much all the same troubleshooting you have. Even in the main menu its slow responses like you are experiencing.

Just be careful if you have chars you want to keep. They are stored in your local registry and gone after reformatting, unless backed up before.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.