Native Linux version (Ubuntu) - Stuck on a blank character select screen

Hi, really excited to finally play LE. I played in the beta a year or two ago, but wanted to wait for Falconer to come out. I used to be on Windows and it of course ran fine, but I’ve since switched to Ubuntu.

I’ve read on some other google searches / reddit posts that this is a problem with the native linux launcher of the game - where it works, but upon entering the game and, where you should be able to select a character, there being just… nothing? Just a the purple/stars/wormhole background art and animated foreground. But that’s it, you can’t do anything else.

I have also tried with using Proton (aka, running the Windows version while using Steam’s Proton for compatibility). I have tried the Experimental, 8.0-5, 7.0-6, and 6.3-8. Four different versions of proton.

All of them didn’t work. The game ran at like… 3 fps. And no amount of tinkering in graphics settings solved it. Windowed, fullscreen, etc. For some reason I can’t turn on/off VSYNC to test that…

I don’t know what to do, kinda at my wit’s end and am thus asking here. Thanks.

1 Like

This fix still works.

Everything else works pretty good except the minimap, as far as I can tell.

Try running the native client and adding the launch option -force-vulkan. This works pretty well but will sometimes still have missing textures for skills in towns.

1 Like

Yes, I have since gotten it to work… I tried to delete this post but you can’t delete top-level posts and they need to be removed by a moderator.

Wow! I tried the -force-vulkan option. Night and day difference. 1000% recommend to anybody else. @Bebopp thanks for the pro tip.